summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2009-11-08 12:42:23 +0000
committerPatrick Lauer <patrick@gentoo.org>2009-11-08 12:42:23 +0000
commit8f6b28b219f2ec926df4ad99d863bdaa80d9d1e0 (patch)
tree80fa82fce9a80b2bd76e2a660785aacceb334753 /app-benchmarks
parentBump, remove old (diff)
downloadgentoo-2-8f6b28b219f2ec926df4ad99d863bdaa80d9d1e0.tar.gz
gentoo-2-8f6b28b219f2ec926df4ad99d863bdaa80d9d1e0.tar.bz2
gentoo-2-8f6b28b219f2ec926df4ad99d863bdaa80d9d1e0.zip
Bump
(Portage version: 2.2_rc49/cvs/Linux x86_64)
Diffstat (limited to 'app-benchmarks')
-rw-r--r--app-benchmarks/stress/ChangeLog7
-rw-r--r--app-benchmarks/stress/stress-1.0.1.ebuild45
2 files changed, 51 insertions, 1 deletions
diff --git a/app-benchmarks/stress/ChangeLog b/app-benchmarks/stress/ChangeLog
index b920432a81ec..fd182c3db856 100644
--- a/app-benchmarks/stress/ChangeLog
+++ b/app-benchmarks/stress/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-benchmarks/stress
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-benchmarks/stress/ChangeLog,v 1.37 2009/09/13 22:21:56 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-benchmarks/stress/ChangeLog,v 1.38 2009/11/08 12:42:23 patrick Exp $
+
+*stress-1.0.1 (08 Nov 2009)
+
+ 08 Nov 2009; Patrick Lauer <patrick@gentoo.org> +stress-1.0.1.ebuild:
+ Bump
13 Sep 2009; Patrick Lauer <patrick@gentoo.org> stress-0.18.6.ebuild:
Removing virtual/libc deps
diff --git a/app-benchmarks/stress/stress-1.0.1.ebuild b/app-benchmarks/stress/stress-1.0.1.ebuild
new file mode 100644
index 000000000000..1284b06ec60d
--- /dev/null
+++ b/app-benchmarks/stress/stress-1.0.1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-benchmarks/stress/stress-1.0.1.ebuild,v 1.1 2009/11/08 12:42:23 patrick Exp $
+
+inherit autotools flag-o-matic
+
+MY_P="${PN}-${PV/_/}"
+S="${WORKDIR}/${MY_P}"
+DESCRIPTION="Imposes stressful loads on different aspects of the system."
+HOMEPAGE="http://weather.ou.edu/~apw/projects/stress"
+SRC_URI="http://weather.ou.edu/~apw/projects/stress/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE="static"
+
+DEPEND="sys-apps/help2man"
+RDEPEND=""
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # Force rebuild of the manpage.
+ rm -f doc/stress.1
+
+ # Honour Gentoo CFLAGS.
+ sed -i -e "/CFLAGS/s/-Werror//" \
+ -e "s/CFLAGS/AM_CFLAGS/" \
+ src/Makefile.am || die "sed cflags failed"
+
+ eautoreconf
+}
+
+src_compile() {
+ use static && append-ldflags -static
+ econf
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc ChangeLog AUTHORS README
+}