summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2012-04-16 07:18:38 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2012-04-16 07:18:38 +0000
commit32b30ca435161be630160c5fc654298fc9309e7f (patch)
tree89b505ada4c54dc8657167071b975241c7e87afc /app-benchmarks
parentVersion bump. (diff)
downloadgentoo-2-32b30ca435161be630160c5fc654298fc9309e7f.tar.gz
gentoo-2-32b30ca435161be630160c5fc654298fc9309e7f.tar.bz2
gentoo-2-32b30ca435161be630160c5fc654298fc9309e7f.zip
Fix pybootchart shebang to work on active python3 setup. Allow pycairo[svg] for USE="-svg" case.
(Portage version: 2.2.0_alpha96_p5/cvs/Linux x86_64)
Diffstat (limited to 'app-benchmarks')
-rw-r--r--app-benchmarks/bootchart2/ChangeLog9
-rw-r--r--app-benchmarks/bootchart2/bootchart2-0.14.2-r2.ebuild80
2 files changed, 88 insertions, 1 deletions
diff --git a/app-benchmarks/bootchart2/ChangeLog b/app-benchmarks/bootchart2/ChangeLog
index 97ee7eff35b0..97dc5e42485b 100644
--- a/app-benchmarks/bootchart2/ChangeLog
+++ b/app-benchmarks/bootchart2/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-benchmarks/bootchart2
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-benchmarks/bootchart2/ChangeLog,v 1.4 2012/04/04 06:11:34 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-benchmarks/bootchart2/ChangeLog,v 1.5 2012/04/16 07:18:38 slyfox Exp $
+
+*bootchart2-0.14.2-r2 (16 Apr 2012)
+
+ 16 Apr 2012; Sergei Trofimovich <slyfox@gentoo.org>
+ +bootchart2-0.14.2-r2.ebuild:
+ Fix pybootchart shebang to work on active python3 setup. Allow pycairo[svg]
+ for USE="-svg" case.
04 Apr 2012; Justin Lecher <jlec@gentoo.org> files/bootchart2.init:
Initscripts only can use einfo not elog
diff --git a/app-benchmarks/bootchart2/bootchart2-0.14.2-r2.ebuild b/app-benchmarks/bootchart2/bootchart2-0.14.2-r2.ebuild
new file mode 100644
index 000000000000..a7b83ad19db6
--- /dev/null
+++ b/app-benchmarks/bootchart2/bootchart2-0.14.2-r2.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-benchmarks/bootchart2/bootchart2-0.14.2-r2.ebuild,v 1.1 2012/04/16 07:18:38 slyfox Exp $
+
+EAPI=4
+
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+
+inherit linux-info python systemd toolchain-funcs
+
+DESCRIPTION="Performance analysis and visualization of the system boot process"
+HOMEPAGE="https://github.com/mmeeks/bootchart/"
+SRC_URI="mirror://github/mmeeks/bootchart/${P}.tar.bz2"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="svg"
+
+RDEPEND="
+ !app-benchmarks/bootchart
+ dev-python/pycairo[svg?]
+ dev-python/pygtk"
+DEPEND="${RDEPEND}"
+
+CONFIG_CHECK="~PROC_EVENTS ~TASKSTATS ~TASK_DELAY_ACCT ~TMPFS"
+
+src_prepare() {
+ tc-export CC
+ sed \
+ -e "/^install/s:py-install-compile::g" \
+ -e "/^VER/s:0.14.1:0.14.2:g" \
+ -e "/^SYSTEMD_UNIT_DIR/s:=.*:= $(systemd_get_unitdir):g" \
+ -i Makefile || die
+}
+
+src_test() {
+ testing() {
+ emake test
+ }
+ python_execute_function testing
+}
+
+src_install() {
+ export NO_PYTHON_COMPILE=0
+ export DOCDIR=/usr/share/doc/${PF}
+ default
+
+ # Note: LIBDIR is hardcoded as /lib in collector/common.h, so we shouldn't
+ # just change it. Since no libraries are installed, /lib is fine.
+ keepdir /lib/bootchart/tmpfs
+
+ installation() {
+ emake \
+ DESTDIR="${D}" \
+ PY_SITEDIR=$(python_get_sitedir) \
+ py-install-compile
+ }
+ python_execute_function installation
+
+ # does not like python3 as active interpreter
+ python_convert_shebangs 2 "${ED}"/usr/bin/pybootchartgui
+
+ newinitd "${FILESDIR}"/${PN}.init ${PN}
+}
+
+pkg_postinst() {
+ elog "Please add the init script to your default runlevel"
+ elog "rc-update add bootchart2 default"
+ echo ""
+ elog "Please review /usr/share/doc/${PF}/README"
+ elog "for further usage informations."
+ echo
+ python_mod_optimize pybootchartgui
+}
+
+pkg_postrm() {
+ python_mod_cleanup pybootchartgui
+}