summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAchim Gottinger <achim@gentoo.org>2002-07-25 12:11:11 +0000
committerAchim Gottinger <achim@gentoo.org>2002-07-25 12:11:11 +0000
commite4c29984d911b9103337189dabcec1cff6486cf6 (patch)
treeb94c39b1ed77a6c9b21500e093565e7acf9a6352 /app-benchmarks/dbench/dbench-2.0.ebuild
parentnew versions of librsvg eel and nautilus (2.0.1) librsvg ebuilded (diff)
downloadgentoo-2-e4c29984d911b9103337189dabcec1cff6486cf6.tar.gz
gentoo-2-e4c29984d911b9103337189dabcec1cff6486cf6.tar.bz2
gentoo-2-e4c29984d911b9103337189dabcec1cff6486cf6.zip
Added new version
Diffstat (limited to 'app-benchmarks/dbench/dbench-2.0.ebuild')
-rw-r--r--app-benchmarks/dbench/dbench-2.0.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/app-benchmarks/dbench/dbench-2.0.ebuild b/app-benchmarks/dbench/dbench-2.0.ebuild
new file mode 100644
index 000000000000..758641842c80
--- /dev/null
+++ b/app-benchmarks/dbench/dbench-2.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-benchmarks/dbench/dbench-2.0.ebuild,v 1.1 2002/07/25 12:11:11 achim Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Popular filesystem benchmark"
+SRC_URI="ftp://samba.org/pub/tridge/dbench/${P}.tar.gz"
+HOMEPAGE="ftp://samba.org/pub/tridge/dbench/"
+DEPEND="virtual/glibc sys-apps/sed"
+
+KEYWORDS="x86"
+SLOT=0
+LICENSE="GPL-2"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ cp Makefile Makefile.orig
+ sed -e "s:-O2 -Wall:${CFLAGS}:g" Makefile.orig > Makefile
+}
+
+src_compile() {
+ emake
+}
+
+src_install() {
+ dobin dbench tbench tbench_srv
+ dodoc README results.txt
+ insinto /usr/share/dbench
+ doins client_plain.txt client_oplocks.txt
+ doman dbench.1
+}
+
+pkg_postinst() {
+ einfo "dbench info:"
+ einfo "You can find the client_*.txt file in ${ROOT}usr/share/dbench."
+ echo
+}