summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEmanuele Giaquinta <exg@gentoo.org>2006-06-27 23:46:07 +0000
committerEmanuele Giaquinta <exg@gentoo.org>2006-06-27 23:46:07 +0000
commitf591404393701e8f6da11b37510376d4001e4d2d (patch)
tree9b0819c08c867b867c8f504db20b9618deb72ba7 /app-benchmarks/acovea/acovea-5.1.1.ebuild
parentMarked ~hppa (for media-gfx/inkscape). (diff)
downloadgentoo-2-f591404393701e8f6da11b37510376d4001e4d2d.tar.gz
gentoo-2-f591404393701e8f6da11b37510376d4001e4d2d.tar.bz2
gentoo-2-f591404393701e8f6da11b37510376d4001e4d2d.zip
Version bump, bug #86142. Add ~ppc keyword. Fix linking with --as-needed. Fix
double free issue by kristiaan.lenaerts@gmail.com. (Portage version: 2.1.1_pre1-r4)
Diffstat (limited to 'app-benchmarks/acovea/acovea-5.1.1.ebuild')
-rw-r--r--app-benchmarks/acovea/acovea-5.1.1.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/app-benchmarks/acovea/acovea-5.1.1.ebuild b/app-benchmarks/acovea/acovea-5.1.1.ebuild
new file mode 100644
index 000000000000..460b44aec01f
--- /dev/null
+++ b/app-benchmarks/acovea/acovea-5.1.1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-benchmarks/acovea/acovea-5.1.1.ebuild,v 1.1 2006/06/27 23:46:07 exg Exp $
+
+inherit autotools
+
+DESCRIPTION="Analysis of Compiler Options via Evolutionary Algorithm"
+HOMEPAGE="http://www.coyotegulch.com/products/acovea/"
+SRC_URI="http://www.coyotegulch.com/distfiles/lib${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+RDEPEND="dev-libs/libcoyotl
+ dev-libs/libevocosm
+ dev-libs/expat"
+DEPEND="${RDEPEND}"
+
+S=${WORKDIR}/lib${P}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-asneeded.patch
+ epatch "${FILESDIR}"/${P}-free-fix.patch
+ eautomake
+}
+
+src_install() {
+ make DESTDIR="${D}" install
+ dodoc ChangeLog NEWS README
+}