summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2007-02-11 19:19:10 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2007-02-11 19:19:10 +0000
commitc068885cb141ac2eb77ac21bede40375f2383f11 (patch)
tree721ad60251638d60f470264c819dbd361f4d0e3e /app-arch
parentChange warnings added in October to mention that mail-mta/qmail is going to b... (diff)
downloadgentoo-2-c068885cb141ac2eb77ac21bede40375f2383f11.tar.gz
gentoo-2-c068885cb141ac2eb77ac21bede40375f2383f11.tar.bz2
gentoo-2-c068885cb141ac2eb77ac21bede40375f2383f11.zip
Version bump, and add a src_test function with the libarchive/bsdtar tests, it is currently failing.
(Portage version: 2.1.2-r9)
Diffstat (limited to 'app-arch')
-rw-r--r--app-arch/bsdtar/ChangeLog10
-rw-r--r--app-arch/bsdtar/bsdtar-2.0_beta11.ebuild (renamed from app-arch/bsdtar/bsdtar-2.0_beta10.ebuild)15
-rw-r--r--app-arch/bsdtar/bsdtar-2.0_beta9.ebuild83
-rw-r--r--app-arch/bsdtar/files/digest-bsdtar-2.0_beta103
-rw-r--r--app-arch/bsdtar/files/digest-bsdtar-2.0_beta113
-rw-r--r--app-arch/bsdtar/files/digest-bsdtar-2.0_beta93
-rw-r--r--app-arch/bsdtar/files/libarchive-2.0b11-tests.patch12
7 files changed, 37 insertions, 92 deletions
diff --git a/app-arch/bsdtar/ChangeLog b/app-arch/bsdtar/ChangeLog
index 73467cee0fc4..27971cef9e61 100644
--- a/app-arch/bsdtar/ChangeLog
+++ b/app-arch/bsdtar/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for app-arch/bsdtar
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/bsdtar/ChangeLog,v 1.49 2007/02/07 14:03:34 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-arch/bsdtar/ChangeLog,v 1.50 2007/02/11 19:19:10 flameeyes Exp $
+
+*bsdtar-2.0_beta11 (11 Feb 2007)
+
+ 11 Feb 2007; Diego Pettenò <flameeyes@gentoo.org>
+ +files/libarchive-2.0b11-tests.patch, -bsdtar-2.0_beta9.ebuild,
+ -bsdtar-2.0_beta10.ebuild, +bsdtar-2.0_beta11.ebuild:
+ Version bump, and add a src_test function with the libarchive/bsdtar tests,
+ it is currently failing.
*bsdtar-2.0_beta10 (07 Feb 2007)
diff --git a/app-arch/bsdtar/bsdtar-2.0_beta10.ebuild b/app-arch/bsdtar/bsdtar-2.0_beta11.ebuild
index 33984a850498..bac23581513a 100644
--- a/app-arch/bsdtar/bsdtar-2.0_beta10.ebuild
+++ b/app-arch/bsdtar/bsdtar-2.0_beta11.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/bsdtar/bsdtar-2.0_beta10.ebuild,v 1.1 2007/02/07 14:03:34 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-arch/bsdtar/bsdtar-2.0_beta11.ebuild,v 1.1 2007/02/11 19:19:10 flameeyes Exp $
inherit eutils autotools toolchain-funcs flag-o-matic
@@ -13,7 +13,7 @@ SRC_URI="http://people.freebsd.org/~kientzle/libarchive/src/${MY_P}.tar.gz"
LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64 ~hppa ~ppc ~sparc-fbsd ~x86 ~x86-fbsd"
-IUSE="build static acl xattr"
+IUSE="build static acl xattr test"
RDEPEND="!dev-libs/libarchive
kernel_linux? (
@@ -24,6 +24,7 @@ RDEPEND="!dev-libs/libarchive
app-arch/bzip2
sys-libs/zlib ) )"
DEPEND="${RDEPEND}
+ test? ( virtual/pmake )
kernel_linux? ( sys-fs/e2fsprogs
virtual/os-headers )"
@@ -36,6 +37,7 @@ src_unpack() {
epatch "${FILESDIR}"/libarchive-1.3.1-static.patch
epatch "${FILESDIR}"/libarchive-2.0b6-acl.patch
epatch "${FILESDIR}"/libarchive-2.0b7-noacl.patch
+ epatch "${FILESDIR}"/libarchive-2.0b11-tests.patch
eautoreconf
epunt_cxx
@@ -62,6 +64,15 @@ src_compile() {
emake || die "emake failed"
}
+src_test() {
+ cd "${S}/libarchive/test"
+ $(get_bmake) || einfo "Ignore this failure."
+ $(get_bmake) test || die "$(get_bmake) test failed"
+
+ cd "${S}/tar/test"
+ PATH="${S}:${PATH}" $(get_bmake) test || die "$(get_bmake) test failed"
+}
+
src_install() {
emake -j1 DESTDIR="${D}" install || die "emake install failed"
diff --git a/app-arch/bsdtar/bsdtar-2.0_beta9.ebuild b/app-arch/bsdtar/bsdtar-2.0_beta9.ebuild
deleted file mode 100644
index eba921bae569..000000000000
--- a/app-arch/bsdtar/bsdtar-2.0_beta9.ebuild
+++ /dev/null
@@ -1,83 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/bsdtar/bsdtar-2.0_beta9.ebuild,v 1.2 2007/02/01 13:01:58 flameeyes Exp $
-
-inherit eutils autotools toolchain-funcs flag-o-matic
-
-MY_P="libarchive-${PV/_beta/b}"
-
-DESCRIPTION="BSD tar command"
-HOMEPAGE="http://people.freebsd.org/~kientzle/libarchive/"
-SRC_URI="http://people.freebsd.org/~kientzle/libarchive/src/${MY_P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~hppa ~ppc ~sparc-fbsd ~x86 ~x86-fbsd"
-IUSE="build static acl xattr"
-
-RDEPEND="!dev-libs/libarchive
- kernel_linux? (
- acl? ( sys-apps/acl )
- xattr? ( sys-apps/attr )
- )
- !static? ( !build? (
- app-arch/bzip2
- sys-libs/zlib ) )"
-DEPEND="${RDEPEND}
- kernel_linux? ( sys-fs/e2fsprogs
- virtual/os-headers )"
-
-S="${WORKDIR}/${MY_P}"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
- epatch "${FILESDIR}"/libarchive-1.3.1-static.patch
- epatch "${FILESDIR}"/libarchive-2.0b6-acl.patch
- epatch "${FILESDIR}"/libarchive-2.0b7-noacl.patch
-
- eautoreconf
- epunt_cxx
-}
-
-src_compile() {
- local myconf
-
- if use static || use build ; then
- myconf="${myconf} --enable-static-bsdtar"
- else
- myconf="${myconf} --disable-static-bsdtar"
- fi
-
- # Upstream doesn't seem to care to fix the problems
- # and I don't want to continue running after them.
- append-flags -fno-strict-aliasing
-
- econf \
- --bindir=/bin \
- $(use_enable acl) \
- $(use_enable xattr) \
- ${myconf} || die "econf failed"
- emake || die "emake failed"
-}
-
-src_install() {
- emake -j1 DESTDIR="${D}" install || die "emake install failed"
-
- # Create tar symlink for FreeBSD
- if [[ ${CHOST} == *-freebsd* ]]; then
- dosym bsdtar /bin/tar
- dosym bsdtar.1 /usr/share/man/man1/tar.1
- fi
-
- if use build; then
- rm -rf "${D}"/usr
- rm -rf "${D}"/lib/*.so*
- return 0
- fi
-
- dodir /$(get_libdir)
- mv "${D}"/usr/$(get_libdir)/*.so* "${D}"/$(get_libdir)
- gen_usr_ldscript libarchive.so
-}
diff --git a/app-arch/bsdtar/files/digest-bsdtar-2.0_beta10 b/app-arch/bsdtar/files/digest-bsdtar-2.0_beta10
deleted file mode 100644
index 5ee2bc65f1b1..000000000000
--- a/app-arch/bsdtar/files/digest-bsdtar-2.0_beta10
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 1dd7bebc4c1cae6281f09502fe9168bf libarchive-2.0b10.tar.gz 952208
-RMD160 1462e919195c51a737eecd94b8d60d69f800822c libarchive-2.0b10.tar.gz 952208
-SHA256 2d933d126fe4b1bc284d59da18d34fca050a7de494746f6aac856022d9fe5dde libarchive-2.0b10.tar.gz 952208
diff --git a/app-arch/bsdtar/files/digest-bsdtar-2.0_beta11 b/app-arch/bsdtar/files/digest-bsdtar-2.0_beta11
new file mode 100644
index 000000000000..24c62dea220c
--- /dev/null
+++ b/app-arch/bsdtar/files/digest-bsdtar-2.0_beta11
@@ -0,0 +1,3 @@
+MD5 e8a9ff3e8e4735217e2eb168fa6e9604 libarchive-2.0b11.tar.gz 557357
+RMD160 a32209cdf0fd6f68473927ce5ce28989e055eeac libarchive-2.0b11.tar.gz 557357
+SHA256 fc475b995e9d0f0541bf5e77d1372eadfb9c83777a0788596b40af54a7b4f3e9 libarchive-2.0b11.tar.gz 557357
diff --git a/app-arch/bsdtar/files/digest-bsdtar-2.0_beta9 b/app-arch/bsdtar/files/digest-bsdtar-2.0_beta9
deleted file mode 100644
index f2485b61600b..000000000000
--- a/app-arch/bsdtar/files/digest-bsdtar-2.0_beta9
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 fae6ca3ffe8fccb0002c2e0e14163c88 libarchive-2.0b9.tar.gz 951737
-RMD160 0aebba3f780dd1fd44f071cc202c0082c49b8d04 libarchive-2.0b9.tar.gz 951737
-SHA256 af6a23d536891429fe90e671889849b17a2298bc6565103c6aa374caa2ef02e4 libarchive-2.0b9.tar.gz 951737
diff --git a/app-arch/bsdtar/files/libarchive-2.0b11-tests.patch b/app-arch/bsdtar/files/libarchive-2.0b11-tests.patch
new file mode 100644
index 000000000000..c45b1d604107
--- /dev/null
+++ b/app-arch/bsdtar/files/libarchive-2.0b11-tests.patch
@@ -0,0 +1,12 @@
+Index: libarchive-2.0b11/libarchive/test/main.c
+===================================================================
+--- libarchive-2.0b11.orig/libarchive/test/main.c
++++ libarchive-2.0b11/libarchive/test/main.c
+@@ -28,6 +28,7 @@
+ * Each test program is linked against this file.
+ */
+ #include <stdarg.h>
++#include <time.h>
+
+ #include "test.h"
+