summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2013-06-23 15:40:57 +0000
committerJeroen Roovers <jer@gentoo.org>2013-06-23 15:40:57 +0000
commit8d9899f1b6eb0139962448b47ad6812714430a61 (patch)
tree63581b6eead705cff63c070f9735673a266536c2 /app-arch
parentAdd l10n for 4.1 rc1 release. (diff)
downloadgentoo-2-8d9899f1b6eb0139962448b47ad6812714430a61.tar.gz
gentoo-2-8d9899f1b6eb0139962448b47ad6812714430a61.tar.bz2
gentoo-2-8d9899f1b6eb0139962448b47ad6812714430a61.zip
Respect AR. Disable silent rules.
(Portage version: 2.2.0_alpha184/cvs/Linux x86_64, signed Manifest commit with key A792A613)
Diffstat (limited to 'app-arch')
-rw-r--r--app-arch/dpkg/ChangeLog5
-rw-r--r--app-arch/dpkg/dpkg-1.16.10.ebuild7
2 files changed, 10 insertions, 2 deletions
diff --git a/app-arch/dpkg/ChangeLog b/app-arch/dpkg/ChangeLog
index d4b688c4a8de..f78b32a7617f 100644
--- a/app-arch/dpkg/ChangeLog
+++ b/app-arch/dpkg/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for app-arch/dpkg
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/dpkg/ChangeLog,v 1.218 2013/06/18 04:06:12 ottxor Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-arch/dpkg/ChangeLog,v 1.219 2013/06/23 15:40:57 jer Exp $
+
+ 23 Jun 2013; Jeroen Roovers <jer@gentoo.org> dpkg-1.16.10.ebuild:
+ Respect AR. Disable silent rules.
18 Jun 2013; Christoph Junghans <ottxor@gentoo.org> dpkg-1.16.10.ebuild:
fix prefix build
diff --git a/app-arch/dpkg/dpkg-1.16.10.ebuild b/app-arch/dpkg/dpkg-1.16.10.ebuild
index 408f689030e5..a9b66b6e0366 100644
--- a/app-arch/dpkg/dpkg-1.16.10.ebuild
+++ b/app-arch/dpkg/dpkg-1.16.10.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/dpkg/dpkg-1.16.10.ebuild,v 1.2 2013/06/18 04:06:12 ottxor Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-arch/dpkg/dpkg-1.16.10.ebuild,v 1.3 2013/06/23 15:40:57 jer Exp $
EAPI=4
inherit eutils multilib autotools toolchain-funcs
@@ -72,11 +72,16 @@ src_configure() {
--disable-compiler-optimisations \
--disable-compiler-warnings \
--disable-linker-optimisations \
+ --disable-silent-rules \
--disable-start-stop-daemon \
--localstatedir="${EPREFIX}"/var \
--without-selinux
}
+src_compile() {
+ emake AR=$(tc-getAR)
+}
+
src_install() {
strip-linguas ${LANGS}
if [ -z "${LINGUAS}" ] ; then