summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2009-07-05 20:30:10 +0000
committerMike Frysinger <vapier@gentoo.org>2009-07-05 20:30:10 +0000
commit76816bdec9d5f63b70b6f5c26eee4835d3127ee3 (patch)
tree57bede9d78dd2ac88ef06232c1f0ceca137dd580 /app-arch
parentPull in gettext/cvs when building autotools #272880 by David Watzke. (diff)
downloadgentoo-2-76816bdec9d5f63b70b6f5c26eee4835d3127ee3.tar.gz
gentoo-2-76816bdec9d5f63b70b6f5c26eee4835d3127ee3.tar.bz2
gentoo-2-76816bdec9d5f63b70b6f5c26eee4835d3127ee3.zip
Add ebuild for latest release #273732 by Sebastian Mingramm.
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'app-arch')
-rw-r--r--app-arch/xz-utils/ChangeLog8
-rw-r--r--app-arch/xz-utils/xz-utils-4.999.8_beta.ebuild51
2 files changed, 58 insertions, 1 deletions
diff --git a/app-arch/xz-utils/ChangeLog b/app-arch/xz-utils/ChangeLog
index 3fb7323d6b01..fa76fe71d247 100644
--- a/app-arch/xz-utils/ChangeLog
+++ b/app-arch/xz-utils/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-arch/xz-utils
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/xz-utils/ChangeLog,v 1.2 2009/07/05 20:28:59 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-arch/xz-utils/ChangeLog,v 1.3 2009/07/05 20:30:10 vapier Exp $
+
+*xz-utils-4.999.8_beta (05 Jul 2009)
+
+ 05 Jul 2009; Mike Frysinger <vapier@gentoo.org>
+ +xz-utils-4.999.8_beta.ebuild:
+ Add ebuild for latest release #273732 by Sebastian Mingramm.
05 Jul 2009; Mike Frysinger <vapier@gentoo.org> xz-utils-9999.ebuild:
Pull in gettext/cvs when building autotools #272880 by David Watzke.
diff --git a/app-arch/xz-utils/xz-utils-4.999.8_beta.ebuild b/app-arch/xz-utils/xz-utils-4.999.8_beta.ebuild
new file mode 100644
index 000000000000..81bc3e9f6ff4
--- /dev/null
+++ b/app-arch/xz-utils/xz-utils-4.999.8_beta.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-arch/xz-utils/xz-utils-4.999.8_beta.ebuild,v 1.1 2009/07/05 20:30:10 vapier Exp $
+
+# Remember: we cannot leverage autotools in this ebuild in order
+# to avoid circular deps with autotools
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="git://ctrl.tukaani.org/xz.git"
+ inherit git autotools
+ SRC_URI=""
+ EXTRA_DEPEND="sys-devel/gettext dev-util/cvs" #272880
+else
+ MY_P="${PN/-utils}-${PV/_}"
+ SRC_URI="http://tukaani.org/xz/${MY_P}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
+ S=${WORKDIR}/${MY_P}
+ EXTRA_DEPEND=
+fi
+
+inherit eutils
+
+DESCRIPTION="utils for managing LZMA compressed files"
+HOMEPAGE="http://tukaani.org/xz/"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+IUSE=""
+
+RDEPEND="!app-arch/lzma
+ !app-arch/lzma-utils
+ !<app-arch/p7zip-4.57"
+DEPEND="${RDEPEND}
+ ${EXTRA_DEPEND}"
+
+src_unpack() {
+ if [[ ${PV} == "9999" ]] ; then
+ git_src_unpack
+ cd "${S}"
+ ./autogen.sh || die
+ else
+ unpack ${A}
+ cd "${S}"
+ sed -i 's:-static::' $(find -name Makefile.in)
+ fi
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die
+ dodoc AUTHORS ChangeLog NEWS README THANKS
+}