summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVictor Ostorga <vostorga@gentoo.org>2009-10-27 22:23:38 +0000
committerVictor Ostorga <vostorga@gentoo.org>2009-10-27 22:23:38 +0000
commitc5a1621b2e25af7a833be88b91462035130195e5 (patch)
tree43ac1231ebae619da12489f3f60023fa05ca2b46 /app-arch/pigz
parentRemoving old versions for #287936 (diff)
downloadgentoo-2-c5a1621b2e25af7a833be88b91462035130195e5.tar.gz
gentoo-2-c5a1621b2e25af7a833be88b91462035130195e5.tar.bz2
gentoo-2-c5a1621b2e25af7a833be88b91462035130195e5.zip
Version bump to 2.1.5 , bug #284038
(Portage version: 2.1.6.13/cvs/Linux i686)
Diffstat (limited to 'app-arch/pigz')
-rw-r--r--app-arch/pigz/ChangeLog8
-rw-r--r--app-arch/pigz/files/pigz-2.1.5-respect-flags.patch14
-rw-r--r--app-arch/pigz/pigz-2.1.5.ebuild32
3 files changed, 53 insertions, 1 deletions
diff --git a/app-arch/pigz/ChangeLog b/app-arch/pigz/ChangeLog
index eda227ac0089..41b412b6927c 100644
--- a/app-arch/pigz/ChangeLog
+++ b/app-arch/pigz/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-arch/pigz
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/pigz/ChangeLog,v 1.4 2009/10/25 20:13:58 tove Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-arch/pigz/ChangeLog,v 1.5 2009/10/27 22:23:38 vostorga Exp $
+
+*pigz-2.1.5 (27 Oct 2009)
+
+ 27 Oct 2009; Víctor Ostorga <vostorga@gentoo.org> +pigz-2.1.5.ebuild,
+ +files/pigz-2.1.5-respect-flags.patch:
+ Version bump to 2.1.5 , bug #284038
25 Oct 2009; Torsten Veller <tove@gentoo.org> metadata.xml:
Remove drizzt from metadata.xml (#149111)
diff --git a/app-arch/pigz/files/pigz-2.1.5-respect-flags.patch b/app-arch/pigz/files/pigz-2.1.5-respect-flags.patch
new file mode 100644
index 000000000000..3b81bc5cdfed
--- /dev/null
+++ b/app-arch/pigz/files/pigz-2.1.5-respect-flags.patch
@@ -0,0 +1,14 @@
+diff -U5 pigz-2.1.5.original/Makefile pigz-2.1.5/Makefile
+--- pigz-2.1.5.original/Makefile 2009-10-27 22:41:31.000000000 -0600
++++ pigz-2.1.5/Makefile 2009-10-27 22:42:45.000000000 -0600
+@@ -1,9 +1,7 @@
+-CFLAGS=-O2
+-
+ pigz: pigz.o yarn.o
+- cc -o pigz pigz.o yarn.o -lpthread -lz
++ $(CC) $(LDFLAGS) -o pigz pigz.o yarn.o -lpthread -lz
+ ln -f pigz unpigz
+
+ pigz.o: pigz.c yarn.h
+
+ yarn.o: yarn.c yarn.h
diff --git a/app-arch/pigz/pigz-2.1.5.ebuild b/app-arch/pigz/pigz-2.1.5.ebuild
new file mode 100644
index 000000000000..b0cf6db564fe
--- /dev/null
+++ b/app-arch/pigz/pigz-2.1.5.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-arch/pigz/pigz-2.1.5.ebuild,v 1.1 2009/10/27 22:23:38 vostorga Exp $
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="A parallel implementation of gzip."
+HOMEPAGE="http://www.zlib.net/pigz/"
+SRC_URI="http://www.zlib.net/pigz/${P}.tar.gz"
+
+LICENSE="PIGZ"
+SLOT="0"
+KEYWORDS="~amd64 ~sparc ~x86"
+IUSE=""
+
+DEPEND="sys-libs/zlib"
+RDEPEND=${DEPEND}
+
+src_unpack() {
+ unpack ${A}
+ epatch "${FILESDIR}"/${P}-respect-flags.patch
+}
+
+src_compile() {
+ tc-export CC
+ emake || die "make failed"
+}
+
+src_install() {
+ dobin ${PN} || die "Failed to install"
+ dodoc README
+}