summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <drac@gentoo.org>2007-07-22 14:21:32 +0000
committerSamuli Suominen <drac@gentoo.org>2007-07-22 14:21:32 +0000
commitbae14b02faba5dc98028df0eb6336ee8988e6ec7 (patch)
tree85ab78841bae4acc584f42d96ae4c7eb39713ceb /app-arch/lha
parentInitial commit for bug 186102. (diff)
downloadgentoo-2-bae14b02faba5dc98028df0eb6336ee8988e6ec7.tar.gz
gentoo-2-bae14b02faba5dc98028df0eb6336ee8988e6ec7.tar.bz2
gentoo-2-bae14b02faba5dc98028df0eb6336ee8988e6ec7.zip
Enable feature which was disabled because of Cygwin/MinGW, bug 184911.
(Portage version: 2.1.3_rc8)
Diffstat (limited to 'app-arch/lha')
-rw-r--r--app-arch/lha/ChangeLog10
-rw-r--r--app-arch/lha/files/digest-lha-114i-r73
-rw-r--r--app-arch/lha/files/lha-114i-file-list-from-stdin.patch29
-rw-r--r--app-arch/lha/lha-114i-r7.ebuild35
4 files changed, 75 insertions, 2 deletions
diff --git a/app-arch/lha/ChangeLog b/app-arch/lha/ChangeLog
index 54f1a77b917a..4f5fc40799b4 100644
--- a/app-arch/lha/ChangeLog
+++ b/app-arch/lha/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-arch/lha
-# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/lha/ChangeLog,v 1.38 2006/12/03 18:27:23 tove Exp $
+# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-arch/lha/ChangeLog,v 1.39 2007/07/22 14:21:32 drac Exp $
+
+*lha-114i-r7 (22 Jul 2007)
+
+ 22 Jul 2007; Samuli Suominen <drac@gentoo.org>
+ +files/lha-114i-file-list-from-stdin.patch, +lha-114i-r7.ebuild:
+ Enable feature which was disabled because of Cygwin/MinGW, bug 184911.
06 Nov 2006; MATSUU Takuto <matsuu@gentoo.org>
-files/lha-114i-build.patch,
diff --git a/app-arch/lha/files/digest-lha-114i-r7 b/app-arch/lha/files/digest-lha-114i-r7
new file mode 100644
index 000000000000..30dceb7d89f8
--- /dev/null
+++ b/app-arch/lha/files/digest-lha-114i-r7
@@ -0,0 +1,3 @@
+MD5 9f52430410928ba4390a73a41a36d56f lha-1.14i-ac20050924p1.tar.gz 285518
+RMD160 7603dc93d8afdeed6cfbaa193f68ae4283bea39b lha-1.14i-ac20050924p1.tar.gz 285518
+SHA256 b5261e9f98538816aa9e64791f23cb83f1632ecda61f02e54b6749e9ca5e9ee4 lha-1.14i-ac20050924p1.tar.gz 285518
diff --git a/app-arch/lha/files/lha-114i-file-list-from-stdin.patch b/app-arch/lha/files/lha-114i-file-list-from-stdin.patch
new file mode 100644
index 000000000000..4bd0d17d7527
--- /dev/null
+++ b/app-arch/lha/files/lha-114i-file-list-from-stdin.patch
@@ -0,0 +1,29 @@
+Index: src/lharc.c
+===================================================================
+--- src/lharc.c (revision 773)
++++ src/lharc.c (working copy)
+@@ -561,7 +561,7 @@
+ if (!isatty(1) && cmd == CMD_ADD)
+ quiet = TRUE;
+ }
+-#if 0 /* Comment out; IMHO, this feature is useless. by Koji Arai */
++#ifndef MINGW32
+ else {
+ if (argc == 3 && !isatty(0)) { /* 1999.7.18 */
+ /* Bug(?) on MinGW, isatty() return 0 on Cygwin console.
+Index: configure.ac
+===================================================================
+--- configure.ac (revision 773)
++++ configure.ac (working copy)
+@@ -289,6 +289,11 @@
+ [Define to 1 if you want to ignore dot files with -X command line switch])
+ fi
+
++AC_MINGW32
++if test "x$MINGW32" = xyes; then
++ AC_DEFINE(MINGW32, 1, [Define to 1 if we're being compiled with MinGW.])
++fi
++
+ AC_CONFIG_FILES([Makefile src/Makefile man/Makefile olddoc/Makefile])
+ AC_CONFIG_FILES([tests/Makefile tests/lha-test])
+ AC_OUTPUT
diff --git a/app-arch/lha/lha-114i-r7.ebuild b/app-arch/lha/lha-114i-r7.ebuild
new file mode 100644
index 000000000000..41333d22503d
--- /dev/null
+++ b/app-arch/lha/lha-114i-r7.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-arch/lha/lha-114i-r7.ebuild,v 1.1 2007/07/22 14:21:32 drac Exp $
+
+inherit eutils autotools
+
+MY_P="${PN}-1.14i-ac20050924p1"
+
+DESCRIPTION="Utility for creating and opening lzh archives"
+HOMEPAGE="http://lha.sourceforge.jp"
+SRC_URI="mirror://sourceforge.jp/${PN}/22231/${MY_P}.tar.gz"
+
+LICENSE="lha"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~ppc ~ppc-macos ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+S="${WORKDIR}"/${MY_P}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-file-list-from-stdin.patch
+ eautoreconf
+}
+
+src_install() {
+ emake DESTDIR="${D}" \
+ mandir=/usr/share/man/ja \
+ install || die "emake failed."
+ dodoc ChangeLog Hacking_of_LHa
+}