summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMamoru Komachi <usata@gentoo.org>2004-09-07 13:18:13 +0000
committerMamoru Komachi <usata@gentoo.org>2004-09-07 13:18:13 +0000
commitd2dc51c99bfc3491f71b135101d3c6e12eeb079b (patch)
treea2fa7687b5534a720c2f945f44f671b66943cea2 /app-arch/lha/lha-114i-r4.ebuild
parentVersion bump without support for sqlite (Manifest recommit) (diff)
downloadgentoo-2-d2dc51c99bfc3491f71b135101d3c6e12eeb079b.tar.gz
gentoo-2-d2dc51c99bfc3491f71b135101d3c6e12eeb079b.tar.bz2
gentoo-2-d2dc51c99bfc3491f71b135101d3c6e12eeb079b.zip
Fixed multiple vulnerabilities; bug #62618. Thanks to vorlon <vorlon@vorlons.info>.
Diffstat (limited to 'app-arch/lha/lha-114i-r4.ebuild')
-rw-r--r--app-arch/lha/lha-114i-r4.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/app-arch/lha/lha-114i-r4.ebuild b/app-arch/lha/lha-114i-r4.ebuild
new file mode 100644
index 000000000000..fc55fb930bd9
--- /dev/null
+++ b/app-arch/lha/lha-114i-r4.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-arch/lha/lha-114i-r4.ebuild,v 1.1 2004/09/07 13:18:13 usata Exp $
+
+inherit eutils
+
+DESCRIPTION="Utility for creating and opening lzh archives"
+HOMEPAGE="http://www2m.biglobe.ne.jp/~dolphin/lha/lha-unix.htm"
+SRC_URI="http://www2m.biglobe.ne.jp/~dolphin/lha/prog/${P}.tar.gz"
+
+LICENSE="lha"
+SLOT="0"
+KEYWORDS="x86 ppc sparc alpha amd64 ppc64"
+IUSE=""
+
+DEPEND="virtual/libc"
+
+src_unpack () {
+ unpack ${A} ; cd ${S}
+ sed -i -e "/^OPTIMIZE/ s:-O2:${CFLAGS}:" Makefile
+ cd src
+ epatch ${FILESDIR}/${P}.diff
+ epatch ${FILESDIR}/${PN}-command_buffer.patch
+ epatch ${FILESDIR}/${P}-symlink.patch
+ epatch ${FILESDIR}/${P}-malloc.patch
+ epatch ${FILESDIR}/${PN}-dir_length_bounds_check.patch
+}
+
+src_compile() {
+ emake || die
+}
+
+src_install() {
+ dodir /usr/bin
+ dodir /usr/share/man/ja/man1
+ make \
+ BINDIR=${D}/usr/bin \
+ MANDIR=${D}/usr/share/man/ja \
+ install MANSECT=1 || die
+
+ dodoc *.txt *.euc *.eng
+}