summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Scherbaum <dertobi123@gentoo.org>2009-10-17 17:21:19 +0000
committerTobias Scherbaum <dertobi123@gentoo.org>2009-10-17 17:21:19 +0000
commit50f1dbe7d1633c28414ba36cdbc9bdde95fb7b4c (patch)
treefc09c2115aec6ba0103bcde3f82b4ed52aff042a /app-antivirus
parentVersion cleanup and [R]DEPEND moved into vim.eclass (diff)
downloadgentoo-2-50f1dbe7d1633c28414ba36cdbc9bdde95fb7b4c.tar.gz
gentoo-2-50f1dbe7d1633c28414ba36cdbc9bdde95fb7b4c.tar.bz2
gentoo-2-50f1dbe7d1633c28414ba36cdbc9bdde95fb7b4c.zip
Cleanup, remove -fno-strict-aliasing from configure (#275928)
(Portage version: 2.2_rc46/cvs/Linux x86_64)
Diffstat (limited to 'app-antivirus')
-rw-r--r--app-antivirus/clamav/ChangeLog9
-rw-r--r--app-antivirus/clamav/clamav-0.95.2-r1.ebuild (renamed from app-antivirus/clamav/clamav-0.95.1.ebuild)89
-rw-r--r--app-antivirus/clamav/files/clamav-0.95.2-fno-strict-aliasing.patch18
3 files changed, 60 insertions, 56 deletions
diff --git a/app-antivirus/clamav/ChangeLog b/app-antivirus/clamav/ChangeLog
index 4951774b691e..f5d083748084 100644
--- a/app-antivirus/clamav/ChangeLog
+++ b/app-antivirus/clamav/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-antivirus/clamav
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-antivirus/clamav/ChangeLog,v 1.340 2009/10/12 16:23:46 halcy0n Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-antivirus/clamav/ChangeLog,v 1.341 2009/10/17 17:21:18 dertobi123 Exp $
+
+*clamav-0.95.2-r1 (17 Oct 2009)
+
+ 17 Oct 2009; Tobias Scherbaum <dertobi123@gentoo.org>
+ -clamav-0.95.1.ebuild, +clamav-0.95.2-r1.ebuild,
+ +files/clamav-0.95.2-fno-strict-aliasing.patch:
+ Cleanup, remove -fno-strict-aliasing from configure (#275928)
12 Oct 2009; Mark Loeser <halcy0n@gentoo.org> clamav-0.95.1.ebuild:
QA fixes; remove autotools inherit since none of its functions are used
diff --git a/app-antivirus/clamav/clamav-0.95.1.ebuild b/app-antivirus/clamav/clamav-0.95.2-r1.ebuild
index 807a14f48a3f..a153d75027ce 100644
--- a/app-antivirus/clamav/clamav-0.95.1.ebuild
+++ b/app-antivirus/clamav/clamav-0.95.2-r1.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-antivirus/clamav/clamav-0.95.1.ebuild,v 1.12 2009/10/12 16:23:46 halcy0n Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-antivirus/clamav/clamav-0.95.2-r1.ebuild,v 1.1 2009/10/17 17:21:19 dertobi123 Exp $
+
+EAPI=2
inherit eutils flag-o-matic fixheadtails multilib versionator
@@ -15,11 +17,10 @@ SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="alpha amd64 hppa ia64 ppc ppc64 sparc x86 ~x86-fbsd"
-IUSE="bzip2 clamdtop crypt iconv milter selinux ipv6"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="bzip2 clamdtop iconv milter selinux ipv6"
COMMON_DEPEND="bzip2? ( app-arch/bzip2 )
- crypt? ( >=dev-libs/gmp-4.1.2 )
milter? ( || ( mail-filter/libmilter mail-mta/sendmail ) )
iconv? ( virtual/libiconv )
clamdtop? ( sys-libs/ncurses )
@@ -38,54 +39,36 @@ PROVIDE="virtual/antivirus"
RESTRICT="test"
pkg_setup() {
- if use milter; then
- if [ ! -e /usr/$(get_libdir)/libmilter.a ] ; then
- ewarn "In order to enable milter support, clamav needs sendmail with enabled milter"
- ewarn "USE flag, or mail-filter/libmilter package."
- fi
- fi
-
enewgroup clamav
enewuser clamav -1 -1 /dev/null clamav
}
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}/${P}-nls.patch"
+src_prepare() {
+ epatch "${FILESDIR}/${PN}-0.95.1-nls.patch"
+ epatch "${FILESDIR}/${P}-fno-strict-aliasing.patch"
}
-src_compile() {
+src_configure() {
has_version =sys-libs/glibc-2.2* && filter-lfs-flags
- local myconf
-
- # we depend on fixed zlib, so we can disable this check to prevent redundant
- # warning (bug #61749)
- myconf="${myconf} --disable-zlib-vcheck"
- # use id utility instead of /etc/passwd parsing (bug #72540)
- myconf="${myconf} --enable-id-check"
- use milter && {
- myconf="${myconf} --enable-milter"
- }
-
ht_fix_file configure
- econf ${myconf} \
+ econf \
$(use_enable bzip2) \
$(use_enable ipv6) \
$(use_enable clamdtop) \
+ $(use_enable milter) \
$(use_with iconv) \
--disable-experimental \
+ --enable-id-check \
+ --disable-zlib-vcheck \
--with-dbdir=/var/lib/clamav || die
- emake || die
}
src_install() {
- make DESTDIR="${D}" install || die
+ emake DESTDIR="${D}" install || die
dodoc AUTHORS BUGS NEWS README ChangeLog FAQ
- newconfd "${FILESDIR}"/clamd.conf clamd
- newinitd "${FILESDIR}"/clamd.rc clamd
- dodoc "${FILESDIR}"/clamav-milter.README.gentoo
+ newconfd "${FILESDIR}/clamd.conf" clamd
+ newinitd "${FILESDIR}/clamd.rc" clamd
dodir /var/run/clamav
keepdir /var/run/clamav
@@ -94,7 +77,7 @@ src_install() {
keepdir /var/log/clamav
fowners clamav:clamav /var/log/clamav
- # Change /etc/clamd.conf to be usable out of the box
+ # Modify /etc/clamd.conf to be usable out of the box
sed -i -e "s:^\(Example\):\# \1:" \
-e "s:.*\(PidFile\) .*:\1 /var/run/clamav/clamd.pid:" \
-e "s:.*\(LocalSocket\) .*:\1 /var/run/clamav/clamd.sock:" \
@@ -115,28 +98,26 @@ src_install() {
"${D}"/etc/freshclam.conf
if use milter; then
- # And again same for /etc/clamav-milter.conf
- # MilterSocket one to include ' /' because there is a 2nd line for
- # inet: which we want to leave
- sed -i -e "s:^\(Example\):\# \1:" \
- -e "s:.*\(PidFile\) .*:\1 /var/run/clamav/clamav-milter.pid:" \
- -e "s:^\#\(ClamdSocket\) .*:\1 /var/run/clamav/clamd.sock:" \
- -e "s:.*\(User\) .*:\1 clamav:" \
- -e "s:^\#\(MilterSocket\) /.*:\1 /var/run/clamav/clamav-milter.sock:" \
- -e "s:^\#\(AllowSupplementaryGroups\).*:\1 yes:" \
- -e "s:^\#\(LogFile\) .*:\1 /var/log/clamav/clamav-milter.log:" \
- "${D}"/etc/clamav-milter.conf
+ # And again same for /etc/clamav-milter.conf
+ # MilterSocket one to include ' /' because there is a 2nd line for
+ # inet: which we want to leave
+ dodoc "${FILESDIR}/clamav-milter.README.gentoo"
+
+ sed -i -e "s:^\(Example\):\# \1:" \
+ -e "s:.*\(PidFile\) .*:\1 /var/run/clamav/clamav-milter.pid:" \
+ -e "s+^\#\(ClamdSocket\) .*+\1 unix:/var/run/clamav/clamd.sock+" \
+ -e "s:.*\(User\) .*:\1 clamav:" \
+ -e "s+^\#\(MilterSocket\) /.*+\1 unix:/var/run/clamav/clamav-milter.sock+" \
+ -e "s:^\#\(AllowSupplementaryGroups\).*:\1 yes:" \
+ -e "s:^\#\(LogFile\) .*:\1 /var/log/clamav/clamav-milter.log:" \
+ "${D}"/etc/clamav-milter.conf
fi
if use milter ; then
- echo "
+ cat << EOF >> "${D}"/etc/conf.d/clamd
+MILTER_NICELEVEL=19
START_MILTER=no
-MILTER_NICELEVEL=19" \
- >> "${D}"/etc/conf.d/clamd
- echo "MILTER_SOCKET=\"/var/run/clamav/clmilter.sock\"" \
- >>"${D}"/etc/conf.d/clamd
- echo "MILTER_OPTS=\"-m 10 --timeout=0\"" \
- >>"${D}"/etc/conf.d/clamd
+EOF
fi
diropts ""
@@ -147,15 +128,13 @@ MILTER_NICELEVEL=19" \
}
pkg_postinst() {
- echo
if use milter ; then
elog "For simple instructions how to setup the clamav-milter"
elog "read the clamav-milter.README.gentoo in /usr/share/doc/${PF}"
- echo
+ elog
fi
ewarn "The soname for libclamav has changed in clamav-0.95."
ewarn "If you have upgraded from that or earlier version, it is"
ewarn "recommended to run revdep-rebuild, in order to fix anything"
ewarn "that links against libclamav.so library."
- echo
}
diff --git a/app-antivirus/clamav/files/clamav-0.95.2-fno-strict-aliasing.patch b/app-antivirus/clamav/files/clamav-0.95.2-fno-strict-aliasing.patch
new file mode 100644
index 000000000000..e36411d0d801
--- /dev/null
+++ b/app-antivirus/clamav/files/clamav-0.95.2-fno-strict-aliasing.patch
@@ -0,0 +1,18 @@
+--- configure.in
++++ configure.in
+@@ -97,9 +97,15 @@
+ AC_MSG_RESULT([ok (${gcc_version})])
+ ;;
+ esac
++ case "${gcc_version}" in
++ [[56789]].* | 4.[[3456789]].*)
+ # bb #1581 - temporarely add -fno-strict-aliasing so gcc 4.4.0
+ # works correctly
+ CFLAGS="$CFLAGS -fno-strict-aliasing"
++ ;;
++ *)
++ ;;
++ esac
+ fi
+ else
+ CFLAGS="$CFLAGS -O0"