summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey Popov <pinkbyte@gentoo.org>2014-08-04 09:07:20 +0000
committerSergey Popov <pinkbyte@gentoo.org>2014-08-04 09:07:20 +0000
commitd3f56d3dcb1ee7f133274d90bbb8243511823c02 (patch)
treee2a3efd2c95dda2c654b1bf1cc72d383ef25199c /app-admin
parentPull random clean up fixes from upstream to simplify build and make it cross-... (diff)
downloadgentoo-2-d3f56d3dcb1ee7f133274d90bbb8243511823c02.tar.gz
gentoo-2-d3f56d3dcb1ee7f133274d90bbb8243511823c02.tar.bz2
gentoo-2-d3f56d3dcb1ee7f133274d90bbb8243511823c02.zip
Version bump
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 0x1F357D42)
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/ansible/ChangeLog7
-rw-r--r--app-admin/ansible/ansible-1.6.10.ebuild60
2 files changed, 66 insertions, 1 deletions
diff --git a/app-admin/ansible/ChangeLog b/app-admin/ansible/ChangeLog
index e34ce81caeb7..6b803d96896a 100644
--- a/app-admin/ansible/ChangeLog
+++ b/app-admin/ansible/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-admin/ansible
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/ansible/ChangeLog,v 1.48 2014/07/31 06:04:14 pinkbyte Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/ansible/ChangeLog,v 1.49 2014/08/04 09:07:20 pinkbyte Exp $
+
+*ansible-1.6.10 (04 Aug 2014)
+
+ 04 Aug 2014; Sergey Popov <pinkbyte@gentoo.org> +ansible-1.6.10.ebuild:
+ Version bump
31 Jul 2014; Sergey Popov <pinkbyte@gentoo.org> -ansible-1.5.5.ebuild,
ansible-1.6.8.ebuild:
diff --git a/app-admin/ansible/ansible-1.6.10.ebuild b/app-admin/ansible/ansible-1.6.10.ebuild
new file mode 100644
index 000000000000..7eb4deff2394
--- /dev/null
+++ b/app-admin/ansible/ansible-1.6.10.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/ansible/ansible-1.6.10.ebuild,v 1.1 2014/08/04 09:07:20 pinkbyte Exp $
+
+EAPI="5"
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1 readme.gentoo
+
+DESCRIPTION="Radically simple deployment, model-driven configuration management, and command execution framework"
+HOMEPAGE="http://ansible.com/"
+SRC_URI="https://github.com/ansible/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+KEYWORDS="~amd64 ~x86"
+LICENSE="GPL-3"
+SLOT="0"
+IUSE="test"
+
+DEPEND="test? (
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/passlib[${PYTHON_USEDEP}]
+ dev-vcs/git
+ )"
+RDEPEND="
+ dev-python/jinja[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ net-misc/sshpass
+ virtual/ssh
+"
+
+DOC_CONTENTS="You can define parameters through shell variables OR use config files
+Examples of config files installed in /usr/share/doc/${PF}/examples\n\n
+You have to create ansible hosts file!\n
+More info on http://docs.ansible.com/intro_getting_started.html
+
+Some optional dependencies, you might want to install:\n
+dev-python/keyczar - needed to support accelerated mode\n
+dev-python/paramiko - alternative SSH backend"\
+
+python_test() {
+ make tests || die "tests failed"
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ doman docs/man/man1/*.1
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+ # Hint: do not install example config files into /etc
+ # let this choice to user
+
+ newenvd "${FILESDIR}"/${PN}.env 95ansible
+}
+
+src_install() {
+ distutils-r1_src_install
+ readme.gentoo_create_doc
+}