summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAchim Gottinger <achim@gentoo.org>2001-01-02 18:50:03 +0000
committerAchim Gottinger <achim@gentoo.org>2001-01-02 18:50:03 +0000
commit99f9477a12c9893d9e73ed777f908cc39496b731 (patch)
tree358f8543ce91f8acbd799cc226a44b352c9349d7 /app-admin
parent*** empty log message *** (diff)
downloadgentoo-2-99f9477a12c9893d9e73ed777f908cc39496b731.tar.gz
gentoo-2-99f9477a12c9893d9e73ed777f908cc39496b731.tar.bz2
gentoo-2-99f9477a12c9893d9e73ed777f908cc39496b731.zip
A replacement for vcron with other nice features
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/fcron/fcron-0.9.4.ebuild39
-rw-r--r--app-admin/fcron/files/digest-fcron-0.9.41
2 files changed, 40 insertions, 0 deletions
diff --git a/app-admin/fcron/fcron-0.9.4.ebuild b/app-admin/fcron/fcron-0.9.4.ebuild
new file mode 100644
index 000000000000..17cab21f5778
--- /dev/null
+++ b/app-admin/fcron/fcron-0.9.4.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Your Name <your email>
+# $Header: /var/cvsroot/gentoo-x86/app-admin/fcron/fcron-0.9.4.ebuild,v 1.1 2001/01/02 18:50:03 achim Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="A replacement for vcron"
+SRC_URI="http://fcron.free.fr/${P}.src.tar.gz"
+HOMEPAGE="http://fcron.free.fr/"
+
+
+src_compile() {
+
+ cd ${S}
+ try ./configure --prefix=/usr --host=${CHOST} \
+ --with-etcdir=/etc/fcron \
+ --with-spooldir=/var/spool/fcron \
+ --with-sendmail=/usr/sbin/sendmail
+ cp Makefile Makefile.orig
+ sed -e "s:script/:#script/:" Makefile.orig > Makefile
+ try make
+
+}
+
+src_install () {
+
+ cd ${S}
+
+ try make prefix=${D}/usr \
+ DESTMAN=${D}/usr/man \
+ DESTDOC=${D}/usr/doc/${PF} \
+ FCRONTABS=${D}/var/spool/fcron \
+ ETC=${D}/etc/fcron install
+ dodoc MANIFEST VERSION doc/CHANGES doc/README doc/LICENSE
+ docinto html
+ dodoc doc/*.html
+ rm -rf ${D}/usr/doc/${PF}/${PN}-${PV}
+}
+
diff --git a/app-admin/fcron/files/digest-fcron-0.9.4 b/app-admin/fcron/files/digest-fcron-0.9.4
new file mode 100644
index 000000000000..c23e530da087
--- /dev/null
+++ b/app-admin/fcron/files/digest-fcron-0.9.4
@@ -0,0 +1 @@
+MD5 5d7acdb64772023d8a9805da19210496 fcron-0.9.4.src.tar.gz