summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2015-03-20 19:15:47 +0000
committerAnthony G. Basile <blueness@gentoo.org>2015-03-20 19:15:47 +0000
commit5912cfb4d9c58cae0c016b454b153b1328b2f74b (patch)
tree8b56f6e59339f51c5694742742caee6abe3f6123 /app-admin
parentold (diff)
downloadgentoo-2-5912cfb4d9c58cae0c016b454b153b1328b2f74b.tar.gz
gentoo-2-5912cfb4d9c58cae0c016b454b153b1328b2f74b.tar.bz2
gentoo-2-5912cfb4d9c58cae0c016b454b153b1328b2f74b.zip
Add xtender patch, bug #499976.
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key 0xF52D4BBA)
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/webalizer/ChangeLog9
-rw-r--r--app-admin/webalizer/files/webalizer-2.21.02-gcc-4.4.patch11
-rw-r--r--app-admin/webalizer/webalizer-2.21.02.ebuild116
-rw-r--r--app-admin/webalizer/webalizer-2.23.08.ebuild26
4 files changed, 30 insertions, 132 deletions
diff --git a/app-admin/webalizer/ChangeLog b/app-admin/webalizer/ChangeLog
index 1c5284df06a2..052fd6e93ca3 100644
--- a/app-admin/webalizer/ChangeLog
+++ b/app-admin/webalizer/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-admin/webalizer
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/webalizer/ChangeLog,v 1.104 2014/06/30 00:46:02 blueness Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/webalizer/ChangeLog,v 1.105 2015/03/20 19:15:47 blueness Exp $
+
+ 20 Mar 2015; Anthony G. Basile <blueness@gentoo.org>
+ -files/webalizer-2.21.02-gcc-4.4.patch, -webalizer-2.21.02.ebuild,
+ webalizer-2.23.08.ebuild:
+ Add xtender patch, bug #499976.
30 Jun 2014; Anthony G. Basile <blueness@gentoo.org> webalizer-2.21.02.ebuild,
webalizer-2.23.05.ebuild, webalizer-2.23.08.ebuild:
diff --git a/app-admin/webalizer/files/webalizer-2.21.02-gcc-4.4.patch b/app-admin/webalizer/files/webalizer-2.21.02-gcc-4.4.patch
deleted file mode 100644
index 2f6549c46c4f..000000000000
--- a/app-admin/webalizer/files/webalizer-2.21.02-gcc-4.4.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- webalizer.c
-+++ webalizer.c
-@@ -28,7 +28,7 @@
- /* Fix broken Zlib 64 bitness */
- #if _FILE_OFFSET_BITS == 64
- #ifndef _LARGEFILE64_SOURCE
--#define _LARGEFILE64_SOURCE = 1
-+#define _LARGEFILE64_SOURCE 1
- #endif
- #endif
-
diff --git a/app-admin/webalizer/webalizer-2.21.02.ebuild b/app-admin/webalizer/webalizer-2.21.02.ebuild
deleted file mode 100644
index 43d661535ae6..000000000000
--- a/app-admin/webalizer/webalizer-2.21.02.ebuild
+++ /dev/null
@@ -1,116 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/webalizer/webalizer-2.21.02.ebuild,v 1.14 2014/06/30 00:46:02 blueness Exp $
-
-# uses webapp.eclass to create directories with right permissions
-# probably slight overkill but works well
-
-EAPI="2"
-
-inherit versionator eutils webapp db-use
-
-WEBAPP_MANUAL_SLOT="yes"
-
-MY_PV="$(get_version_component_range 1-2)-$(get_version_component_range 3)"
-MY_P="${PN}-${MY_PV}"
-
-DESCRIPTION="Webserver log file analyzer"
-HOMEPAGE="http://www.webalizer.org/"
-SRC_URI="ftp://ftp.mrunix.net/pub/webalizer/${MY_P}-src.tar.bz2
- mirror://gentoo/${PN}.conf.gz"
-
-LICENSE="GPL-2"
-KEYWORDS="sparc"
-IUSE="bzip2 geoip nls"
-SLOT="0"
-
-DEPEND=">=sys-libs/db-4.2
- >=sys-libs/zlib-1.1.4
- >=media-libs/libpng-1.2
- >=media-libs/gd-1.8.3[png]
- dev-libs/geoip
- bzip2? ( app-arch/bzip2 )"
-RDEPEND="${DEPEND}"
-
-S="${WORKDIR}"/${MY_P}
-
-pkg_setup() {
- webapp_pkg_setup
-
- # USE=nls has no real meaning if LINGUAS isn't set
- if use nls && [[ -z "${LINGUAS}" ]]; then
- ewarn "you must set LINGUAS in /etc/make.conf"
- ewarn "if you want to USE=nls"
- die "please either set LINGUAS or do not use nls"
- fi
-}
-
-src_prepare() {
- epatch "${FILESDIR}"/${P}-gcc-4.4.patch
-}
-
-src_configure() {
- # really dirty hack; necessary due to a really gross ./configure
- # basically, it just sets the natural language the program uses
- # unfortunatly, this program only allows for one lang, so only the first
- # entry in LINGUAS is used
- if use nls; then
- local longlang="$(grep ^${LINGUAS:0:2} "${FILESDIR}"/webalizer-language-list.txt)"
- local myconf="${myconf} --with-language=${longlang:3}"
- else
- local myconf="${myconf} --with-language=english"
- fi
-
- econf --enable-dns \
- --with-db=$(db_includedir) \
- --with-dblib=$(db_libname) \
- ${myconf} \
- $(use_enable geoip) \
- $(use_enable bzip2 bz2) \
- --with-geodb=/usr/share/webalizer/geodb \
- || die "econf failed"
-}
-
-src_install() {
- webapp_src_preinst
-
- dobin webalizer
- dosym webalizer /usr/bin/webazolver
- doman webalizer.1
-
- insinto /etc
- doins "${WORKDIR}"/${PN}.conf
- dosed "s/apache/apache2/g" /etc/webalizer.conf
-
- dodoc CHANGES *README* INSTALL sample.conf "${FILESDIR}"/apache.webalizer
-
- webapp_src_install
-}
-
-pkg_postinst() {
- elog
- elog "It is suggested that you restart apache before using webalizer"
- elog "You may want to review /etc/webalizer.conf and ensure that"
- elog "OutputDir is set correctly"
- elog
- elog "Then just type webalizer to generate your stats."
- elog "You can also use cron to generate them e.g. every day."
- elog "They can be accessed via http://localhost/webalizer"
- elog
- elog "A sample Apache config file has been installed into"
- elog "/usr/share/doc/${PF}/apache.webalizer"
- elog "Please edit and install it as necessary"
- elog
-
- if [[ ${#LINGUAS} -gt 2 ]] && use nls; then
- ewarn
- ewarn "You have more than one language in LINGUAS"
- ewarn "Due to the limitations of this packge, it was built"
- ewarn "only with ${LINGUAS:0:2} support. If this is not what"
- ewarn "you intended, please place the language you desire"
- ewarn "_first_ in the list of LINGUAS in /etc/make.conf"
- ewarn
- fi
-
- webapp_pkg_postinst
-}
diff --git a/app-admin/webalizer/webalizer-2.23.08.ebuild b/app-admin/webalizer/webalizer-2.23.08.ebuild
index 866ea63eb74b..05466389ccdd 100644
--- a/app-admin/webalizer/webalizer-2.23.08.ebuild
+++ b/app-admin/webalizer/webalizer-2.23.08.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/webalizer/webalizer-2.23.08.ebuild,v 1.2 2014/06/30 00:46:02 blueness Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/webalizer/webalizer-2.23.08.ebuild,v 1.3 2015/03/20 19:15:47 blueness Exp $
# uses webapp.eclass to create directories with right permissions
# probably slight overkill but works well
@@ -10,6 +10,8 @@ EAPI="5"
inherit versionator eutils webapp db-use
WEBAPP_MANUAL_SLOT="yes"
+XTENDED_VER="RB30"
+XTENDED_URL="rb30"
MY_PV="$(get_version_component_range 1-2)-$(get_version_component_range 3)"
MY_P="${PN}-${MY_PV}"
@@ -21,12 +23,13 @@ GEODB_DIR="/usr/share/webalizer/geodb"
DESCRIPTION="Webserver log file analyzer"
HOMEPAGE="http://www.webalizer.org/"
SRC_URI="ftp://ftp.mrunix.net/pub/webalizer/${MY_P}-src.tar.bz2
+ xtended? ( http://patrickfrei.ch/webalizer/${XTENDED_URL}/${PN}-${MY_PV}-${XTENDED_VER}-patch.tar.gz )
http://dev.gentoo.org/~blueness/webalizer/webalizer.conf.gz
${GEODB_URL}/webalizer-geodb-${GEODB_DATE}.tgz"
LICENSE="GPL-2"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ppc ~ppc64 ~sparc ~x86"
-IUSE="bzip2 geoip nls"
+IUSE="bzip2 xtended geoip nls"
SLOT="0"
DEPEND=">=sys-libs/db-4.2
@@ -50,6 +53,12 @@ pkg_setup() {
fi
}
+src_prepare() {
+ if use xtended; then
+ epatch "${WORKDIR}"/${PN}-${MY_PV}-${XTENDED_VER}-patch
+ fi
+}
+
src_configure() {
# really dirty hack; necessary due to a really gross ./configure
# basically, it just sets the natural language the program uses
@@ -115,6 +124,17 @@ pkg_postinst() {
ewarn
fi
+ if use xtended; then
+ ewarn
+ ewarn "If you are upgrading webalizer from USE=-xtended to USE=xtended"
+ ewarn "you will need to delete webalizer.current and process all previous"
+ ewarn "days in the same month using 'webalizer /path/to/access_log.1'."
+ ewarn "For more information about using XTENDED webalizer, see:"
+ ewarn
+ ewarn " http://www.patrickfrei.ch/webalizer/rb30/INSTALL"
+ ewarn
+ fi
+
if use geoip; then
elog
elog "Note: we have installed the GeoDB.dat dated ${GEODB_DATE}."