summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-05-31 22:54:29 +0000
committerMike Frysinger <vapier@gentoo.org>2005-05-31 22:54:29 +0000
commit4d648188ba7203502512a48aeac506ea71ba524f (patch)
treea5d0504cbaf0ce28aa258b8288843cb946bfcdac /app-admin
parentmerge fixes from current ~arch ebuild (diff)
downloadgentoo-2-4d648188ba7203502512a48aeac506ea71ba524f.tar.gz
gentoo-2-4d648188ba7203502512a48aeac506ea71ba524f.tar.bz2
gentoo-2-4d648188ba7203502512a48aeac506ea71ba524f.zip
integrate blogd with baselayout
(Portage version: 2.0.51.22-r1)
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/showconsole/files/bootlogger.sh31
-rw-r--r--app-admin/showconsole/showconsole-1.07.ebuild15
2 files changed, 38 insertions, 8 deletions
diff --git a/app-admin/showconsole/files/bootlogger.sh b/app-admin/showconsole/files/bootlogger.sh
new file mode 100644
index 000000000000..250bcbf349e5
--- /dev/null
+++ b/app-admin/showconsole/files/bootlogger.sh
@@ -0,0 +1,31 @@
+# /lib/rcscripts/addons/bootlogger.sh: Handle logging of output at boot
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/showconsole/files/bootlogger.sh,v 1.1 2005/05/31 22:54:29 vapier Exp $
+
+if [[ -x /sbin/blogd ]] ; then
+
+bootlog() {
+ local opt=$1
+ shift
+ case ${opt} in
+ start) blogd_start "$@";;
+ sync) blogd_sync "$@";;
+ quit) blogd_quit "$@";;
+ esac
+}
+
+blogd_start() {
+ /sbin/blogd >/dev/null
+}
+
+blogd_sync() {
+ echo > /var/log/boot.msg
+ killall -IO blogd
+}
+
+blogd_quit() {
+ killall -QUIT blogd
+}
+
+fi
diff --git a/app-admin/showconsole/showconsole-1.07.ebuild b/app-admin/showconsole/showconsole-1.07.ebuild
index 20507ea852d4..95a63d1549f5 100644
--- a/app-admin/showconsole/showconsole-1.07.ebuild
+++ b/app-admin/showconsole/showconsole-1.07.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/showconsole/showconsole-1.07.ebuild,v 1.1 2005/03/05 00:38:39 ciaranm Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/showconsole/showconsole-1.07.ebuild,v 1.2 2005/05/31 22:54:29 vapier Exp $
inherit eutils toolchain-funcs
@@ -11,19 +11,16 @@ SRC_URI="mirror://gentoo/${P}.tar.bz2
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~x86"
+KEYWORDS="~amd64 ~x86"
IUSE=""
DEPEND=""
-#RDEPEND=""
-
-S=${WORKDIR}/${P}
src_unpack() {
unpack ${P}.tar.bz2
- cd ${S}
- epatch ${DISTDIR}/${P}-suse-update.patch.bz2
- epatch ${FILESDIR}/${PV}-no-TIOCGDEV.patch
+ cd "${S}"
+ epatch "${DISTDIR}"/${P}-suse-update.patch.bz2
+ epatch "${FILESDIR}"/${PV}-no-TIOCGDEV.patch
}
src_compile() {
@@ -32,6 +29,8 @@ src_compile() {
src_install() {
make install DESTDIR="${D}" || die "install failed"
+ insinto /$(get_libdir)/rcscripts/addons
+ doins "${FILESDIR}"/bootlogger.sh || die "rcscript addon"
rmdir "${D}"/usr/lib/lsb
dodoc showconsole-1.07.lsm README
}