summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Gryniewicz <dang@gentoo.org>2010-11-16 00:41:10 +0000
committerDaniel Gryniewicz <dang@gentoo.org>2010-11-16 00:41:10 +0000
commit3a4f763a546f496173d6badd404aeaa5342a1891 (patch)
tree60f136cd5a77bb752361427a18cb88f1b172a4d0 /app-admin
parentStable x86 wrt bug 345483. (diff)
downloadgentoo-2-3a4f763a546f496173d6badd404aeaa5342a1891.tar.gz
gentoo-2-3a4f763a546f496173d6badd404aeaa5342a1891.tar.bz2
gentoo-2-3a4f763a546f496173d6badd404aeaa5342a1891.zip
Bump to logrotate-3.7.9; bug #345199
(Portage version: 2.2.0_alpha4/cvs/Linux x86_64)
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/logrotate/ChangeLog9
-rw-r--r--app-admin/logrotate/logrotate-3.7.9.ebuild72
2 files changed, 79 insertions, 2 deletions
diff --git a/app-admin/logrotate/ChangeLog b/app-admin/logrotate/ChangeLog
index 187a72274d81..aa5ab9a73722 100644
--- a/app-admin/logrotate/ChangeLog
+++ b/app-admin/logrotate/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-admin/logrotate
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/logrotate/ChangeLog,v 1.88 2009/11/03 22:18:36 dang Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/logrotate/ChangeLog,v 1.89 2010/11/16 00:41:09 dang Exp $
+
+*logrotate-3.7.9 (16 Nov 2010)
+
+ 16 Nov 2010; Daniel Gryniewicz <dang@gentoo.org> +logrotate-3.7.9.ebuild:
+ Bump to logrotate-3.7.9; bug #345199
03 Nov 2009; Daniel Gryniewicz <dang@gentoo.org> logrotate-3.7.8.ebuild:
Move selinux-logroate to RDEPEND; bug #287481
diff --git a/app-admin/logrotate/logrotate-3.7.9.ebuild b/app-admin/logrotate/logrotate-3.7.9.ebuild
new file mode 100644
index 000000000000..851a710663af
--- /dev/null
+++ b/app-admin/logrotate/logrotate-3.7.9.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/logrotate/logrotate-3.7.9.ebuild,v 1.1 2010/11/16 00:41:10 dang Exp $
+
+EAPI="2"
+
+inherit eutils toolchain-funcs flag-o-matic
+
+DESCRIPTION="Rotates, compresses, and mails system logs"
+HOMEPAGE="https://fedorahosted.org/logrotate/"
+SRC_URI="https://fedorahosted.org/releases/l/o/logrotate/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="selinux"
+
+RDEPEND="
+ >=dev-libs/popt-1.5
+ selinux? (
+ sys-libs/libselinux
+ sec-policy/selinux-logrotate
+ )"
+
+DEPEND="${RDEPEND}
+ >=sys-apps/sed-4"
+
+src_prepare() {
+ strip-flags
+
+ epatch \
+ "${FILESDIR}"/${PN}-3.7.7-datehack.patch \
+ "${FILESDIR}"/${PN}-3.7.7-ignore-hidden.patch \
+ "${FILESDIR}"/${PN}-3.7.7-weekly.patch \
+ "${FILESDIR}"/${PN}-3.7.7-fbsd.patch
+}
+
+src_configure() {
+ return
+}
+
+src_compile() {
+ local myconf
+ myconf="CC=$(tc-getCC)"
+ useq selinux && myconf="${myconf} WITH_SELINUX=yes"
+ use elibc_FreeBSD && append-flags -DNO_ALLOCA_H
+ emake ${myconf} RPM_OPT_FLAGS="${CFLAGS}" || die "emake failed"
+}
+
+src_install() {
+ insinto /usr
+ dosbin logrotate
+ doman logrotate.8
+ dodoc examples/logrotate*
+
+ exeinto /etc/cron.daily
+ doexe "${FILESDIR}"/logrotate.cron
+
+ insinto /etc
+ doins "${FILESDIR}"/logrotate.conf
+
+ keepdir /etc/logrotate.d
+}
+
+pkg_postinst() {
+ elog "If you wish to have logrotate e-mail you updates, please"
+ elog "emerge virtual/mailx and configure logrotate in"
+ elog "/etc/logrotate.conf appropriately"
+ elog
+ elog "Additionally, /etc/logrotate.conf may need to be modified"
+ elog "for your particular needs. See man logrotate for details."
+}