summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDevan Franchini <twitch153@gentoo.org>2015-07-11 03:17:24 +0000
committerDevan Franchini <twitch153@gentoo.org>2015-07-11 03:17:24 +0000
commit26ccdd69a1dd91e9be74b3ba8c7dc7dc84fe9181 (patch)
treef644868a30a31935ae4b70bb3272883728e25efd /app-admin
parentversion bump (bug #553916) and formatting (diff)
downloadgentoo-2-26ccdd69a1dd91e9be74b3ba8c7dc7dc84fe9181.tar.gz
gentoo-2-26ccdd69a1dd91e9be74b3ba8c7dc7dc84fe9181.tar.bz2
gentoo-2-26ccdd69a1dd91e9be74b3ba8c7dc7dc84fe9181.zip
Adds patch to fix regression in checking for pvr
(Portage version: 2.2.20/cvs/Linux x86_64, signed Manifest commit with key A8C8FBCF)
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/webapp-config/ChangeLog9
-rw-r--r--app-admin/webapp-config/files/webapp-config-1.54-pvr-check.patch49
-rw-r--r--app-admin/webapp-config/webapp-config-1.54-r1.ebuild (renamed from app-admin/webapp-config/webapp-config-1.54.ebuild)5
3 files changed, 61 insertions, 2 deletions
diff --git a/app-admin/webapp-config/ChangeLog b/app-admin/webapp-config/ChangeLog
index bb6752cddab3..fc79b52375ce 100644
--- a/app-admin/webapp-config/ChangeLog
+++ b/app-admin/webapp-config/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-admin/webapp-config
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/webapp-config/ChangeLog,v 1.135 2015/07/03 20:29:17 twitch153 Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/webapp-config/ChangeLog,v 1.136 2015/07/11 03:17:24 twitch153 Exp $
+
+*webapp-config-1.54-r1 (11 Jul 2015)
+
+ 11 Jul 2015; Devan Franchini <twitch153@gentoo.org>
+ +files/webapp-config-1.54-pvr-check.patch, +webapp-config-1.54-r1.ebuild,
+ -webapp-config-1.54.ebuild:
+ Adds patch to fix regression in checking for pvr
*webapp-config-1.54 (03 Jul 2015)
diff --git a/app-admin/webapp-config/files/webapp-config-1.54-pvr-check.patch b/app-admin/webapp-config/files/webapp-config-1.54-pvr-check.patch
new file mode 100644
index 000000000000..9a35ad70cafb
--- /dev/null
+++ b/app-admin/webapp-config/files/webapp-config-1.54-pvr-check.patch
@@ -0,0 +1,49 @@
+commit 9e251c7574d074e424ea19024f743c754f321979
+Author: Devan Franchini <twitch153@gentoo.org>
+Date: Fri Jul 10 21:25:17 2015 -0400
+
+ config.py: Fixes package version checking regression
+
+ Previously webapp-config would not do any sanity checks when
+ setting the package version. After adding a sanity check in 1.54
+ I made the mistake of not being flexible enough and this caused
+ a regression that prevented web apps with versions such as
+ "20140929d"[1] to be installed. This commit fixes that while still
+ allowing for some sanity checking.
+
+ [1]: https://github.com/gentoo/webapp-config/issues/2
+
+diff --git a/WebappConfig/config.py b/WebappConfig/config.py
+index 6c915c3..3a176a0 100644
+--- a/WebappConfig/config.py
++++ b/WebappConfig/config.py
+@@ -996,17 +996,20 @@ class Config:
+ OUT.die('Invalid package name')
+
+ if len(args) > 1:
+- argsvr = args[1].split('.')
+- if len(argsvr) == 1:
+- OUT.die('Invalid package version: %(pvr)s'
++ pvr = args[1]
++ has_int = False # A package version should have at least one
++ # numerical value, but we want to allow for
++ # the flexibility of having any alphanumeric
++ # value while checking to make sure it's sane.
++
++ for char in pvr:
++ if char.isdigit():
++ has_int = True
++
++ if not has_int:
++ OUT.die('Invalid package version: "%(pvr)s"'
+ % {'pvr': args[1]})
+
+- pvr = ''
+- for i in range(0, len(argsvr)):
+- if not i == len(argsvr) - 1:
+- pvr += argsvr[i] + '.'
+- else:
+- pvr += argsvr[i]
+ self.config.set('USER', 'pvr', pvr)
+
+ if (not options['dir'] and
diff --git a/app-admin/webapp-config/webapp-config-1.54.ebuild b/app-admin/webapp-config/webapp-config-1.54-r1.ebuild
index d5fb8f0854ac..be963a8c5afb 100644
--- a/app-admin/webapp-config/webapp-config-1.54.ebuild
+++ b/app-admin/webapp-config/webapp-config-1.54-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/webapp-config/webapp-config-1.54.ebuild,v 1.1 2015/07/03 20:29:17 twitch153 Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/webapp-config/webapp-config-1.54-r1.ebuild,v 1.1 2015/07/11 03:17:24 twitch153 Exp $
EAPI="5"
@@ -22,6 +22,9 @@ DEPEND="app-text/xmlto
sys-apps/gentoo-functions"
RDEPEND="portage? ( sys-apps/portage[${PYTHON_USEDEP}] )"
+python_prepare() {
+ epatch "${FILESDIR}/${P}-pvr-check.patch"
+}
python_compile_all() {
emake -C doc/
}