summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeremy Huddleston <eradicator@gentoo.org>2004-06-16 18:10:36 +0000
committerJeremy Huddleston <eradicator@gentoo.org>2004-06-16 18:10:36 +0000
commit2626b45ba1a11c3977b822f0f7ee7cacd110aa0c (patch)
treec81c117080e7e78e3607baad5b0f3c4a65ba63b4 /app-admin
parentFixed port to be usermin default. (Manifest recommit) (diff)
downloadgentoo-2-2626b45ba1a11c3977b822f0f7ee7cacd110aa0c.tar.gz
gentoo-2-2626b45ba1a11c3977b822f0f7ee7cacd110aa0c.tar.bz2
gentoo-2-2626b45ba1a11c3977b822f0f7ee7cacd110aa0c.zip
Revbump to use better init script like usermin does. Pam file now installs correctly.
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/webmin/ChangeLog9
-rw-r--r--app-admin/webmin/Manifest3
-rw-r--r--app-admin/webmin/files/digest-webmin-1.150-r11
-rw-r--r--app-admin/webmin/files/init.d.webmin39
-rw-r--r--app-admin/webmin/webmin-1.150-r1.ebuild96
5 files changed, 147 insertions, 1 deletions
diff --git a/app-admin/webmin/ChangeLog b/app-admin/webmin/ChangeLog
index f096840c6fba..efd7ba2efb13 100644
--- a/app-admin/webmin/ChangeLog
+++ b/app-admin/webmin/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-admin/webmin
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/webmin/ChangeLog,v 1.52 2004/06/16 17:16:11 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/webmin/ChangeLog,v 1.53 2004/06/16 18:10:36 eradicator Exp $
+
+*webmin-1.150-r1 (16 Jun 2004)
+
+ 16 Jun 2004; Jeremy Huddleston <eradicator@gentoo.org> +files/init.d.webmin,
+ +webmin-1.150-r1.ebuild:
+ Revbump to use better init script like usermin does.
+ Pam file now installs correctly.
16 Jun 2004; Jeremy Huddleston <eradicator@gentoo.org> -webmin-1.080.ebuild,
-webmin-1.140-r1.ebuild:
diff --git a/app-admin/webmin/Manifest b/app-admin/webmin/Manifest
index 8b967b5ccc69..b23f1c9c2d1e 100644
--- a/app-admin/webmin/Manifest
+++ b/app-admin/webmin/Manifest
@@ -1,6 +1,9 @@
MD5 2d798dde808dad8ee5f9e74aea93b6f1 ChangeLog 7737
MD5 3923b6ae9bc25fc124e24e7747c8a802 metadata.xml 226
+MD5 91365b8469e6ac1cf283a76646c4d081 webmin-1.150-r1.ebuild 2352
MD5 e12fa04bc2452c08f58eade22e168779 webmin-1.150.ebuild 2271
+MD5 21e2927f87f79474473cd5a151666602 files/init.d.webmin 871
+MD5 03f188f36a9989ff035a883155a82e0b files/digest-webmin-1.150-r1 65
MD5 bc8eb1c9de103599fc00b140b0ed1f9f files/uninstall.sh 260
MD5 bb2acab90ada721c723d91a5a97c193c files/webmin-1.130-webalizer.patch 615
MD5 a01d77a867d5469c7211685bfd04f6f6 files/webmin-1.140-apache2.patch 1227
diff --git a/app-admin/webmin/files/digest-webmin-1.150-r1 b/app-admin/webmin/files/digest-webmin-1.150-r1
new file mode 100644
index 000000000000..c79b69d9cf6e
--- /dev/null
+++ b/app-admin/webmin/files/digest-webmin-1.150-r1
@@ -0,0 +1 @@
+MD5 5566f3b761b5e9498b3da7c7587f9f75 webmin-1.150.tar.gz 7153367
diff --git a/app-admin/webmin/files/init.d.webmin b/app-admin/webmin/files/init.d.webmin
new file mode 100644
index 000000000000..6a85fabecf27
--- /dev/null
+++ b/app-admin/webmin/files/init.d.webmin
@@ -0,0 +1,39 @@
+#!/sbin/runscript
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/webmin/files/init.d.webmin,v 1.1 2004/06/16 18:10:36 eradicator Exp $
+
+depend() {
+ need net logger
+}
+
+
+checkconfig() {
+ if [ -f /etc/webmin/config ]; then
+ return 0;
+ else
+ eerror "Error starting usermin. /etc/webmin/config is not present."
+ eerror "Please report this on http://bugs.gentoo.org."
+ return 1;
+ fi
+}
+
+start() { # copied from /etc/usermin/start
+ checkconfig || return 1
+ ebegin "Starting Webmin"
+
+ LANG=
+ export LANG
+
+ unset PERLIO
+ export PERLIO
+ start-stop-daemon --start --quiet \
+ --exec /usr/libexec/webmin/miniserv.pl /etc/webmin/miniserv.conf
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping Webmin"
+ start-stop-daemon --stop --pidfile /var/run/webmin.pid --quiet
+ eend $?
+}
diff --git a/app-admin/webmin/webmin-1.150-r1.ebuild b/app-admin/webmin/webmin-1.150-r1.ebuild
new file mode 100644
index 000000000000..069e835be2c7
--- /dev/null
+++ b/app-admin/webmin/webmin-1.150-r1.ebuild
@@ -0,0 +1,96 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/webmin/webmin-1.150-r1.ebuild,v 1.1 2004/06/16 18:10:36 eradicator Exp $
+
+inherit eutils
+
+IUSE="ssl apache2"
+
+DESCRIPTION="Webmin, a web-based system administration interface"
+SRC_URI="mirror://sourceforge/webadmin/${P}.tar.gz"
+RESTRICT="nomirror"
+HOMEPAGE="http://www.webmin.com/"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="~x86 ~ppc ~sparc ~amd64 ~s390 ~hppa"
+
+DEPEND=""
+RDEPEND="dev-lang/perl
+ ssl? ( dev-perl/Net-SSLeay )
+ dev-perl/XML-Generator"
+
+src_unpack() {
+ unpack ${A}
+
+ cd ${S}
+ # Bug #47020
+ epatch ${FILESDIR}/${PN}-1.130-webalizer.patch
+
+ # Bug #50810, #51943
+ if use apache2; then
+ epatch ${FILESDIR}/${PN}-1.140-apache2.patch
+ fi
+}
+
+src_install() {
+ rm -f mount/freebsd-mounts*
+ rm -f mount/openbsd-mounts*
+ rm -f mount/macos-mounts*
+ (find . -name '*.cgi' ; find . -name '*.pl') | perl perlpath.pl /usr/bin/perl -
+ dodir /usr/libexec/webmin
+ dodir /etc/init.d
+ dodir /var
+ dodir /etc/pam.d
+ cp -rp * ${D}/usr/libexec/webmin
+ mv ${D}/usr/libexec/webmin/openslp/config \
+ ${D}/usr/libexec/webmin/openslp/config-gentoo-linux
+
+ exeinto /etc/init.d
+ newexe ${FILESDIR}/init.d.webmin webmin
+
+ insinto /etc/pam.d/
+ newins ${FILESDIR}/webmin-pam webmin
+ echo gentoo > ${D}/usr/libexec/webmin/install-type
+
+ exeinto /etc/webmin
+ doexe ${FILESDIR}/uninstall.sh
+}
+
+pkg_postinst() {
+ /etc/init.d/webmin stop >/dev/null 2>&1
+ stopstatus=$?
+ cd /usr/libexec/webmin
+ config_dir=/etc/webmin
+ var_dir=/var/log/webmin
+ perl=/usr/bin/perl
+ autoos=1
+ port=10000
+ login=root
+ crypt=`grep "^root:" /etc/shadow | cut -f 2 -d :`
+ host=`hostname`
+ use ssl && ssl=1 || ssl=0
+ atboot=0
+ nostart=1
+ nochown=1
+ autothird=1
+ nouninstall=1
+ noperlpath=1
+ export config_dir var_dir perl autoos port login crypt host ssl nochown autothird nouninstall nostart noperlpath
+ perl /usr/libexec/webmin/maketemp.pl
+ ./setup.sh >/tmp/.webmin/webmin-setup.out 2>&1
+
+ if [ "$stopstatus" = "0" ]; then
+ # Start if it was running before
+ /etc/init.d/webmin start
+ fi
+
+ sed -i 's:^pidfile=.*$:pidfile=/var/run/webmin.pid:' /etc/webmin/miniserv.conf
+
+ einfo "Add webmin to your boot-time services with 'rc-update add webmin'."
+ einfo "Point your web browser to http://localhost:10000 to use webmin."
+}
+
+pkg_prerm() {
+ /etc/init.d/webmin stop >& /dev/null
+}