summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Mrozowski <reavertm@gentoo.org>2010-10-19 21:21:27 +0000
committerMaciej Mrozowski <reavertm@gentoo.org>2010-10-19 21:21:27 +0000
commit1bcee3b053f75542275378bbfd52201fc3a2e0e7 (patch)
treea389383af8e811741dc6d44b5883d49649f4b7de /app-admin
parentMarking qt-demo-4.6.3 ~ppc for bug 341703 (diff)
downloadgentoo-2-1bcee3b053f75542275378bbfd52201fc3a2e0e7.tar.gz
gentoo-2-1bcee3b053f75542275378bbfd52201fc3a2e0e7.tar.bz2
gentoo-2-1bcee3b053f75542275378bbfd52201fc3a2e0e7.zip
Version bump
(Portage version: 2.2_rc98/cvs/Linux x86_64)
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/system-config-printer-common/ChangeLog8
-rw-r--r--app-admin/system-config-printer-common/system-config-printer-common-1.2.5.ebuild91
2 files changed, 98 insertions, 1 deletions
diff --git a/app-admin/system-config-printer-common/ChangeLog b/app-admin/system-config-printer-common/ChangeLog
index 2b18a847b2ae..10f4ba8b7518 100644
--- a/app-admin/system-config-printer-common/ChangeLog
+++ b/app-admin/system-config-printer-common/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-admin/system-config-printer-common
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/system-config-printer-common/ChangeLog,v 1.24 2010/09/19 17:00:03 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/system-config-printer-common/ChangeLog,v 1.25 2010/10/19 21:21:27 reavertm Exp $
+
+*system-config-printer-common-1.2.5 (19 Oct 2010)
+
+ 19 Oct 2010; Maciej Mrozowski <reavertm@gentoo.org>
+ +system-config-printer-common-1.2.5.ebuild:
+ Version bump
19 Sep 2010; Raúl Porcel <armin76@gentoo.org>
system-config-printer-common-1.1.13.ebuild,
diff --git a/app-admin/system-config-printer-common/system-config-printer-common-1.2.5.ebuild b/app-admin/system-config-printer-common/system-config-printer-common-1.2.5.ebuild
new file mode 100644
index 000000000000..a1af014d14c6
--- /dev/null
+++ b/app-admin/system-config-printer-common/system-config-printer-common-1.2.5.ebuild
@@ -0,0 +1,91 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/system-config-printer-common/system-config-printer-common-1.2.5.ebuild,v 1.1 2010/10/19 21:21:27 reavertm Exp $
+
+EAPI="3"
+
+PYTHON_DEPEND="2"
+WANT_AUTOMAKE="1.11"
+inherit python autotools
+
+MY_P="${PN%-common}-${PV}"
+
+DESCRIPTION="Common modules of Red Hat's printer administration tool"
+HOMEPAGE="http://cyberelk.net/tim/software/system-config-printer/"
+SRC_URI="http://cyberelk.net/tim/data/system-config-printer/1.2/${MY_P}.tar.xz"
+
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86"
+SLOT="0"
+IUSE="doc policykit"
+
+# Needs cups running, bug 284005
+RESTRICT="test"
+
+# system-config-printer split since 1.1.3
+COMMON_DEPEND="
+ dev-libs/glib:2
+ dev-libs/libusb
+ dev-libs/libxml2[python]
+ dev-python/dbus-python
+ dev-python/pycups
+ dev-python/pygobject
+ net-print/cups[dbus]
+ sys-fs/udev
+"
+DEPEND="${COMMON_DEPEND}
+ dev-util/intltool
+ doc? ( dev-python/epydoc )
+"
+RDEPEND="${COMMON_DEPEND}
+ !app-admin/system-config-printer:0
+ policykit? ( sys-auth/polkit )
+"
+
+S="${WORKDIR}/${MY_P}"
+
+pkg_setup() {
+ python_set_active_version 2
+}
+
+src_prepare() {
+ epatch "${FILESDIR}/${PN}-1.2.2-split.patch"
+
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --disable-nls \
+ --with-udev-rules
+}
+
+src_compile() {
+ emake || die "emake failed"
+ if use doc; then
+ emake html || die "emake html failed"
+ fi
+}
+
+src_install() {
+ dodoc AUTHORS ChangeLog README || die "dodoc failed"
+
+ if use doc; then
+ dohtml -r html/ || die "installing html docs failed"
+ fi
+
+ emake DESTDIR="${D}" install \
+ udevrulesdir=/lib/udev/rules.d \
+ udevhelperdir=/lib/udev \
+ || die "emake install failed"
+
+ python_convert_shebangs -q -r $(python_get_version) "${D}"
+}
+
+pkg_postinst() {
+ python_mod_optimize cupshelpers
+}
+
+pkg_postrm() {
+ python_mod_cleanup cupshelpers /usr/share/system-config-printer
+}