summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron Walker <ka0ttic@gentoo.org>2005-08-25 05:50:30 +0000
committerAaron Walker <ka0ttic@gentoo.org>2005-08-25 05:50:30 +0000
commit4e80b9d1c86190426009d4a7888e9c60b8e9f040 (patch)
treea057968336361b0838c8409b8a49e7d502d78f30 /app-admin/sysstat/sysstat-5.0.5-r2.ebuild
parent#100512: fixed alsa dependency (diff)
downloadgentoo-2-4e80b9d1c86190426009d4a7888e9c60b8e9f040.tar.gz
gentoo-2-4e80b9d1c86190426009d4a7888e9c60b8e9f040.tar.bz2
gentoo-2-4e80b9d1c86190426009d4a7888e9c60b8e9f040.zip
Revision bump; provide our own crontab that's not broken; make sure SA_LIB_DIR gets passed to make otherwise sa{1,2,dc} will be installed to /usr/local/lib. Keeping keywords. Tidy old ebuilds.
(Portage version: 1.589-cvs)
Diffstat (limited to 'app-admin/sysstat/sysstat-5.0.5-r2.ebuild')
-rw-r--r--app-admin/sysstat/sysstat-5.0.5-r2.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/app-admin/sysstat/sysstat-5.0.5-r2.ebuild b/app-admin/sysstat/sysstat-5.0.5-r2.ebuild
new file mode 100644
index 000000000000..be1b2d47df64
--- /dev/null
+++ b/app-admin/sysstat/sysstat-5.0.5-r2.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/sysstat/sysstat-5.0.5-r2.ebuild,v 1.1 2005/08/25 05:50:30 ka0ttic Exp $
+
+inherit eutils
+
+DESCRIPTION="System performance tools for Linux"
+HOMEPAGE="http://perso.wanadoo.fr/sebastien.godard/"
+SRC_URI="http://perso.wanadoo.fr/sebastien.godard/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha amd64 hppa ~mips ppc ppc64 sparc x86"
+IUSE="nls"
+
+RDEPEND="nls? ( sys-devel/gettext )"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ sed -i -e "s:-O2:${CFLAGS}:" Makefile || die "sed Makefile failed"
+ epatch ${FILESDIR}/${P}-gcc4.diff
+}
+
+src_compile() {
+ # ick. interactive makefile rule
+ yes '' | make config
+
+ if ! use nls ; then
+ sed -i 's/\(ENABLE_NLS\ =\ \)y/\1n/g' build/CONFIG || \
+ die "sed CONFIG failed"
+ fi
+
+ make PREFIX=/usr SA_LIB_DIR=/usr/lib/sa || die "make failed"
+}
+
+src_install() {
+ keepdir /var/log/sa
+ newdoc ${FILESDIR}/crontab crontab.example
+
+ make \
+ DESTDIR=${D} \
+ PREFIX=/usr \
+ MAN_DIR=/usr/share/man \
+ DOC_DIR=/usr/share/doc/${PF} \
+ SA_LIB_DIR=/usr/lib/sa \
+ install || die "make install failed"
+}