summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2014-08-02 01:38:30 +0000
committerIan Delaney <idella4@gentoo.org>2014-08-02 01:38:30 +0000
commit94a36fe6e0db805b5ff88e3333c21ae7aed1a5bc (patch)
tree49e183d4f7d931691fb3e9cd1f2aa5f5d5fc87d1 /app-admin/supervisor
parentAdd ruby21 support. (diff)
downloadgentoo-2-94a36fe6e0db805b5ff88e3333c21ae7aed1a5bc.tar.gz
gentoo-2-94a36fe6e0db805b5ff88e3333c21ae7aed1a5bc.tar.bz2
gentoo-2-94a36fe6e0db805b5ff88e3333c21ae7aed1a5bc.zip
drop py2.6, unrestrict workable test phase, tidy
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'app-admin/supervisor')
-rw-r--r--app-admin/supervisor/ChangeLog5
-rw-r--r--app-admin/supervisor/supervisor-3.1.0.ebuild11
2 files changed, 8 insertions, 8 deletions
diff --git a/app-admin/supervisor/ChangeLog b/app-admin/supervisor/ChangeLog
index 4d31757b1d1f..c536a4dcbff5 100644
--- a/app-admin/supervisor/ChangeLog
+++ b/app-admin/supervisor/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for app-admin/supervisor
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/supervisor/ChangeLog,v 1.14 2014/08/01 05:35:39 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/supervisor/ChangeLog,v 1.15 2014/08/02 01:38:30 idella4 Exp $
+
+ 02 Aug 2014; Ian Delaney <idella4@gentoo.org> supervisor-3.1.0.ebuild:
+ drop py2.6, unrestrict workable test phase, tidy
*supervisor-3.1.0 (01 Aug 2014)
diff --git a/app-admin/supervisor/supervisor-3.1.0.ebuild b/app-admin/supervisor/supervisor-3.1.0.ebuild
index ec32e23ea144..cd833e24b526 100644
--- a/app-admin/supervisor/supervisor-3.1.0.ebuild
+++ b/app-admin/supervisor/supervisor-3.1.0.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/supervisor/supervisor-3.1.0.ebuild,v 1.1 2014/08/01 05:35:39 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/supervisor/supervisor-3.1.0.ebuild,v 1.2 2014/08/02 01:38:30 idella4 Exp $
EAPI="5"
-PYTHON_COMPAT=( python{2_6,2_7} )
+PYTHON_COMPAT=( python2_7 )
# xml.etree.ElementTree module required.
PYTHON_REQ_USE="xml"
@@ -26,13 +26,8 @@ RDEPEND=">=dev-python/meld3-0.6.10-r1[${PYTHON_USEDEP}]
DEPEND="${RDEPEND}
test? ( dev-python/mock[${PYTHON_USEDEP}] )"
-# package uses namespaces which makes tests use installed packages
-RESTRICT="test"
-
S="${WORKDIR}/${PN}-${MY_PV}"
-DOCS=( CHANGES.txt TODO.txt )
-
python_prepare_all() {
# write missing MANIFEST.in file, otherwise required files get lost due to
# egg_info being passed to setup.py
@@ -42,6 +37,7 @@ recursive-include supervisor/skel *.conf
recursive-include supervisor/ui *.html *.css *.gif *.png
recursive-include supervisor/tests *.conf *.txt
EOF
+ distutils-r1_python_prepare_all
}
python_test() {
@@ -51,4 +47,5 @@ python_test() {
python_install_all() {
newinitd "${FILESDIR}/init.d-r1" supervisord
newconfd "${FILESDIR}/conf.d" supervisord
+ distutils-r1_python_install_all
}