summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabio Erculiani <lxnay@gentoo.org>2013-03-14 18:09:19 +0000
committerFabio Erculiani <lxnay@gentoo.org>2013-03-14 18:09:19 +0000
commitde09c3c21ee27560880a9515d2db6e429c5d24fb (patch)
tree7c2d009a277059321bef116bf1561454484c45be /app-admin/equo
parentversion bump (diff)
downloadgentoo-2-de09c3c21ee27560880a9515d2db6e429c5d24fb.tar.gz
gentoo-2-de09c3c21ee27560880a9515d2db6e429c5d24fb.tar.bz2
gentoo-2-de09c3c21ee27560880a9515d2db6e429c5d24fb.zip
version bump
(Portage version: 2.2.0_alpha166/cvs/Linux x86_64, signed Manifest commit with key ADC916E5)
Diffstat (limited to 'app-admin/equo')
-rw-r--r--app-admin/equo/ChangeLog9
-rw-r--r--app-admin/equo/equo-183.ebuild45
2 files changed, 52 insertions, 2 deletions
diff --git a/app-admin/equo/ChangeLog b/app-admin/equo/ChangeLog
index 66695537531e..f230a8b6f3a5 100644
--- a/app-admin/equo/ChangeLog
+++ b/app-admin/equo/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-admin/equo
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/equo/ChangeLog,v 1.23 2012/09/27 10:59:44 lxnay Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/equo/ChangeLog,v 1.24 2013/03/14 18:09:19 lxnay Exp $
+
+*equo-183 (14 Mar 2013)
+
+ 14 Mar 2013; Fabio Erculiani <lxnay@gentoo.org> +equo-183.ebuild:
+ version bump
*equo-144 (27 Sep 2012)
diff --git a/app-admin/equo/equo-183.ebuild b/app-admin/equo/equo-183.ebuild
new file mode 100644
index 000000000000..f1d3155a7af9
--- /dev/null
+++ b/app-admin/equo/equo-183.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/equo/equo-183.ebuild,v 1.1 2013/03/14 18:09:19 lxnay Exp $
+
+EAPI=3
+PYTHON_DEPEND="2"
+inherit eutils python bash-completion-r1
+
+DESCRIPTION="Entropy Package Manager text-based client"
+HOMEPAGE="http://www.sabayon.org"
+LICENSE="GPL-2"
+
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE=""
+SRC_URI="mirror://sabayon/sys-apps/entropy-${PV}.tar.bz2"
+
+S="${WORKDIR}/entropy-${PV}"
+
+DEPEND="~sys-apps/entropy-${PV}"
+RDEPEND="${DEPEND} sys-apps/file[python]"
+
+src_compile() {
+ cd "${S}"/client || die
+ emake || die "make failed"
+}
+
+src_install() {
+ cd "${S}"/client || die
+ emake DESTDIR="${D}" LIBDIR="usr/lib" install || die "make install failed"
+ newbashcomp "${S}/misc/equo-completion.bash" equo
+}
+
+pkg_postinst() {
+ python_mod_optimize "/usr/lib/entropy/client"
+ echo
+ elog "If you would like to allow users in the 'entropy' group"
+ elog "to update available package repositories, please consider"
+ elog "to install sys-apps/rigo-daemon"
+ echo
+}
+
+pkg_postrm() {
+ python_mod_cleanup "/usr/lib/entropy/client"
+}