summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Volkov <pva@gentoo.org>2011-09-01 07:58:39 +0000
committerPeter Volkov <pva@gentoo.org>2011-09-01 07:58:39 +0000
commit48528e4b3bfe8bbc8ca759b20ca238587be8c8fc (patch)
tree4f5c3d895c5cad2b89c637cb32efa1302fa1dcc1 /app-admin/apache-tools
parentMarked stable on AMD64 based on arch testing by Ian "idella" Delaney in bug #... (diff)
downloadgentoo-2-48528e4b3bfe8bbc8ca759b20ca238587be8c8fc.tar.gz
gentoo-2-48528e4b3bfe8bbc8ca759b20ca238587be8c8fc.tar.bz2
gentoo-2-48528e4b3bfe8bbc8ca759b20ca238587be8c8fc.zip
Version bump, bug #368743 wrt Max Nokhrin and Denis Kaganovich
(Portage version: 2.1.10.11/cvs/Linux x86_64)
Diffstat (limited to 'app-admin/apache-tools')
-rw-r--r--app-admin/apache-tools/ChangeLog8
-rw-r--r--app-admin/apache-tools/apache-tools-2.2.20.ebuild88
-rw-r--r--app-admin/apache-tools/files/apache-tools-2.2.20-Makefile.patch41
3 files changed, 136 insertions, 1 deletions
diff --git a/app-admin/apache-tools/ChangeLog b/app-admin/apache-tools/ChangeLog
index eeccc32809ef..5beb6e9bbdd5 100644
--- a/app-admin/apache-tools/ChangeLog
+++ b/app-admin/apache-tools/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-admin/apache-tools
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/apache-tools/ChangeLog,v 1.92 2011/07/22 13:40:17 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/apache-tools/ChangeLog,v 1.93 2011/09/01 07:58:39 pva Exp $
+
+*apache-tools-2.2.20 (01 Sep 2011)
+
+ 01 Sep 2011; Peter Volkov <pva@gentoo.org> +apache-tools-2.2.20.ebuild,
+ +files/apache-tools-2.2.20-Makefile.patch:
+ Version bump, bug #368743 wrt Max Nokhrin and Denis Kaganovich
22 Jul 2011; Jeroen Roovers <jer@gentoo.org> apache-tools-2.2.17.ebuild:
Stable for HPPA (bug #360625).
diff --git a/app-admin/apache-tools/apache-tools-2.2.20.ebuild b/app-admin/apache-tools/apache-tools-2.2.20.ebuild
new file mode 100644
index 000000000000..a19c708cceeb
--- /dev/null
+++ b/app-admin/apache-tools/apache-tools-2.2.20.ebuild
@@ -0,0 +1,88 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/apache-tools/apache-tools-2.2.20.ebuild,v 1.1 2011/09/01 07:58:39 pva Exp $
+
+EAPI="4"
+inherit flag-o-matic eutils
+
+DESCRIPTION="Useful Apache tools - htdigest, htpasswd, ab, htdbm"
+HOMEPAGE="http://httpd.apache.org/"
+SRC_URI="mirror://apache/httpd/httpd-${PV}.tar.bz2"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~sparc-fbsd ~x86-fbsd"
+IUSE="ssl"
+RESTRICT="test"
+
+RDEPEND="=dev-libs/apr-1*
+ =dev-libs/apr-util-1*
+ dev-libs/libpcre
+ ssl? ( dev-libs/openssl )
+ !<www-servers/apache-2.2.4"
+
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/httpd-${PV}"
+
+src_prepare() {
+ # Apply these patches:
+ # (1) apache-tools-2.2.20-Makefile.patch:
+ # - fix up the `make install' for support/
+ # - remove envvars from `make install'
+ epatch "${FILESDIR}"/${PN}-2.2.20-Makefile.patch
+}
+
+src_configure() {
+ local myconf=""
+
+ # Instead of filtering --as-needed (bug #128505), append --no-as-needed
+ append-ldflags $(no-as-needed)
+
+ use ssl && myconf+=" --with-ssl=/usr --enable-ssl"
+
+ # econf overwrites the stuff from config.layout, so we have to put them into
+ # our myconf line too
+ econf \
+ --sbindir=/usr/sbin \
+ --with-z=/usr \
+ --with-apr=/usr \
+ --with-apr-util=/usr \
+ --with-pcre=/usr \
+ ${myconf}
+}
+
+src_compile() {
+ cd support || die
+ emake
+}
+
+src_install () {
+ cd support || die
+
+ make DESTDIR="${D}" install
+
+ # install manpages
+ doman "${S}"/docs/man/{dbmmanage,htdigest,htpasswd,htdbm}.1 \
+ "${S}"/docs/man/{ab,htcacheclean,logresolve,rotatelogs}.8
+
+ # Providing compatiblity symlinks for #177697 (which we'll stop to install
+ # at some point).
+ pushd "${D}"/usr/sbin/ >/dev/null
+ for i in *; do
+ dosym /usr/sbin/${i} /usr/sbin/${i}2
+ done
+ popd "${D}"/usr/sbin/ >/dev/null
+
+ # Provide a symlink for ab-ssl
+ if use ssl; then
+ dosym /usr/sbin/ab /usr/sbin/ab-ssl
+ dosym /usr/sbin/ab /usr/sbin/ab2-ssl
+ fi
+
+ # make htpasswd accessible for non-root users
+ dosym /usr/sbin/htpasswd /usr/bin/htpasswd
+ dosym /usr/sbin/htdigest /usr/bin/htdigest
+
+ dodoc "${S}"/CHANGES
+}
diff --git a/app-admin/apache-tools/files/apache-tools-2.2.20-Makefile.patch b/app-admin/apache-tools/files/apache-tools-2.2.20-Makefile.patch
new file mode 100644
index 000000000000..0ac4885feed6
--- /dev/null
+++ b/app-admin/apache-tools/files/apache-tools-2.2.20-Makefile.patch
@@ -0,0 +1,41 @@
+=== modified file 'support/Makefile.in'
+--- support/Makefile.in 2011-09-01 06:33:22 +0000
++++ support/Makefile.in 2011-09-01 06:43:51 +0000
+@@ -1,9 +1,10 @@
+ DISTCLEAN_TARGETS = apxs apachectl dbmmanage log_server_status \
+- logresolve.pl phf_abuse_log.cgi split-logfile envvars-std
++ logresolve.pl phf_abuse_log.cgi split-logfile
+
+ CLEAN_TARGETS = suexec
+
+-PROGRAMS = htpasswd htdigest rotatelogs logresolve ab htdbm htcacheclean httxt2dbm $(NONPORTABLE_SUPPORT)
++PROGRAMS = htpasswd htdigest rotatelogs logresolve ab htdbm htcacheclean httxt2dbm \
++ $(NONPORTABLE_SUPPORT) log_server_status split-logfile dbmmanage
+ TARGETS = $(PROGRAMS)
+
+ PROGRAM_LDADD = $(UTIL_LDFLAGS) $(PROGRAM_DEPENDENCIES) $(EXTRA_LIBS) $(AP_LIBS)
+@@ -12,22 +13,13 @@
+ include $(top_builddir)/build/rules.mk
+
+ install:
+- @test -d $(DESTDIR)$(bindir) || $(MKINSTALLDIRS) $(DESTDIR)$(bindir)
+ @test -d $(DESTDIR)$(sbindir) || $(MKINSTALLDIRS) $(DESTDIR)$(sbindir)
+- @test -d $(DESTDIR)$(libexecdir) || $(MKINSTALLDIRS) $(DESTDIR)$(libexecdir)
+- @cp -p $(top_builddir)/server/httpd.exp $(DESTDIR)$(libexecdir)
+- @for i in apxs apachectl dbmmanage; do \
++ @for i in $(PROGRAMS) ; do \
+ if test -f "$(builddir)/$$i"; then \
+ cp -p $$i $(DESTDIR)$(sbindir); \
+ chmod 755 $(DESTDIR)$(sbindir)/$$i; \
+ fi ; \
+ done
+- @if test -f "$(builddir)/envvars-std"; then \
+- cp -p envvars-std $(DESTDIR)$(sbindir); \
+- if test ! -f $(DESTDIR)$(sbindir)/envvars; then \
+- cp -p envvars-std $(DESTDIR)$(sbindir)/envvars ; \
+- fi ; \
+- fi
+
+ htpasswd_OBJECTS = htpasswd.lo
+ htpasswd: $(htpasswd_OBJECTS)
+