summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexandre Rostovtsev <tetromino@gentoo.org>2012-12-09 21:51:42 +0000
committerAlexandre Rostovtsev <tetromino@gentoo.org>2012-12-09 21:51:42 +0000
commit5b500d164998943661e8e4d84b6b0dea330caf03 (patch)
tree31e360852ec7b0d8f500b574793008856b154dce /app-accessibility
parentVersion bump. (diff)
downloadgentoo-2-5b500d164998943661e8e4d84b6b0dea330caf03.tar.gz
gentoo-2-5b500d164998943661e8e4d84b6b0dea330caf03.tar.bz2
gentoo-2-5b500d164998943661e8e4d84b6b0dea330caf03.zip
Add patches fixing potential crashes, drop old.
(Portage version: 2.2.0_alpha145/cvs/Linux x86_64, signed Manifest commit with key CF0ADD61)
Diffstat (limited to 'app-accessibility')
-rw-r--r--app-accessibility/at-spi2-core/ChangeLog11
-rw-r--r--app-accessibility/at-spi2-core/at-spi2-core-2.6.2-r1.ebuild (renamed from app-accessibility/at-spi2-core/at-spi2-core-2.6.1.ebuild)8
-rw-r--r--app-accessibility/at-spi2-core/files/at-spi2-core-2.6.2-deregister.patch28
-rw-r--r--app-accessibility/at-spi2-core/files/at-spi2-core-2.6.2-hung-crash-1.patch28
-rw-r--r--app-accessibility/at-spi2-core/files/at-spi2-core-2.6.2-hung-crash-2.patch26
5 files changed, 98 insertions, 3 deletions
diff --git a/app-accessibility/at-spi2-core/ChangeLog b/app-accessibility/at-spi2-core/ChangeLog
index b227bfffc9a6..558e4c8bf02e 100644
--- a/app-accessibility/at-spi2-core/ChangeLog
+++ b/app-accessibility/at-spi2-core/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for app-accessibility/at-spi2-core
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-accessibility/at-spi2-core/ChangeLog,v 1.23 2012/12/08 21:41:13 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-accessibility/at-spi2-core/ChangeLog,v 1.24 2012/12/09 21:51:42 tetromino Exp $
+
+*at-spi2-core-2.6.2-r1 (09 Dec 2012)
+
+ 09 Dec 2012; Alexandre Rostovtsev <tetromino@gentoo.org>
+ -at-spi2-core-2.6.1.ebuild, +at-spi2-core-2.6.2-r1.ebuild,
+ +files/at-spi2-core-2.6.2-deregister.patch,
+ +files/at-spi2-core-2.6.2-hung-crash-1.patch,
+ +files/at-spi2-core-2.6.2-hung-crash-2.patch:
+ Add patches fixing potential crashes, drop old.
08 Dec 2012; Agostino Sarubbo <ago@gentoo.org> at-spi2-core-2.4.2.ebuild:
Stable for ppc, wrt bug #427546
diff --git a/app-accessibility/at-spi2-core/at-spi2-core-2.6.1.ebuild b/app-accessibility/at-spi2-core/at-spi2-core-2.6.2-r1.ebuild
index 1a5bf74b7a9b..7bbd7f4b0f46 100644
--- a/app-accessibility/at-spi2-core/at-spi2-core-2.6.1.ebuild
+++ b/app-accessibility/at-spi2-core/at-spi2-core-2.6.2-r1.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-accessibility/at-spi2-core/at-spi2-core-2.6.1.ebuild,v 1.2 2012/11/12 12:40:28 blueness Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-accessibility/at-spi2-core/at-spi2-core-2.6.2-r1.ebuild,v 1.1 2012/12/09 21:51:42 tetromino Exp $
-EAPI="4"
+EAPI="5"
GCONF_DEBUG="no"
GNOME2_LA_PUNT="yes"
@@ -37,5 +37,9 @@ src_prepare() {
# disable teamspaces test since that requires Novell.ICEDesktop.Daemon
epatch "${FILESDIR}/${PN}-2.0.2-disable-teamspaces-test.patch"
+ # important patches from 2.6.3
+ epatch "${FILESDIR}/${P}-hung-crash-"{1,2}.patch
+ epatch "${FILESDIR}/${P}-deregister.patch"
+
gnome2_src_prepare
}
diff --git a/app-accessibility/at-spi2-core/files/at-spi2-core-2.6.2-deregister.patch b/app-accessibility/at-spi2-core/files/at-spi2-core-2.6.2-deregister.patch
new file mode 100644
index 000000000000..c5618b10895c
--- /dev/null
+++ b/app-accessibility/at-spi2-core/files/at-spi2-core-2.6.2-deregister.patch
@@ -0,0 +1,28 @@
+From ca6778ba2a6c4fed24d5468213f8ed918f3dcbe4 Mon Sep 17 00:00:00 2001
+From: Mike Gorse <mgorse@suse.com>
+Date: Fri, 7 Dec 2012 11:21:19 -0600
+Subject: [PATCH 3/3] Fix deregistering of applications
+
+---
+ registryd/registry.c | 3 ++-
+ 1 file changed, 2 insertions(+), 1 deletion(-)
+
+diff --git a/registryd/registry.c b/registryd/registry.c
+index a64e094..e283a90 100644
+--- a/registryd/registry.c
++++ b/registryd/registry.c
+@@ -290,9 +290,10 @@ handle_disconnection (DBusConnection *bus, DBusMessage *message, void *user_data
+ for (i = 0; i < reg->apps->len; i++)
+ {
+ SpiReference *ref = g_ptr_array_index (reg->apps, i);
+- while (!g_strcmp0 (old, ref->name))
++ if (!g_strcmp0 (old, ref->name))
+ {
+ remove_application (reg, bus, i);
++ i--;
+ }
+ }
+
+--
+1.8.0
+
diff --git a/app-accessibility/at-spi2-core/files/at-spi2-core-2.6.2-hung-crash-1.patch b/app-accessibility/at-spi2-core/files/at-spi2-core-2.6.2-hung-crash-1.patch
new file mode 100644
index 000000000000..46d79ca757ad
--- /dev/null
+++ b/app-accessibility/at-spi2-core/files/at-spi2-core-2.6.2-hung-crash-1.patch
@@ -0,0 +1,28 @@
+From 860ccecf3de3fdca6742060174cab1f90d708fb3 Mon Sep 17 00:00:00 2001
+From: Mike Gorse <mgorse@suse.com>
+Date: Thu, 6 Dec 2012 09:50:18 -0600
+Subject: [PATCH 1/3] Remove the correct datum when clearing a hung process
+
+When clearing hung processes, we were passing the wrong variable to
+g_list_remove, meaning that the datum would never be removed from the
+list, even though it had been freed, resulting in a crash.
+---
+ registryd/deviceeventcontroller.c | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/registryd/deviceeventcontroller.c b/registryd/deviceeventcontroller.c
+index b8c1bc7..101dc6f 100644
+--- a/registryd/deviceeventcontroller.c
++++ b/registryd/deviceeventcontroller.c
+@@ -1205,7 +1205,7 @@ reset_hung_process_from_ping (DBusPendingCall *pending, void *data)
+ if (!strcmp (l->data, data))
+ {
+ g_free (l->data);
+- hung_processes = g_slist_remove (hung_processes, data);
++ hung_processes = g_slist_remove (hung_processes, l->data);
+ break;
+ }
+ }
+--
+1.8.0
+
diff --git a/app-accessibility/at-spi2-core/files/at-spi2-core-2.6.2-hung-crash-2.patch b/app-accessibility/at-spi2-core/files/at-spi2-core-2.6.2-hung-crash-2.patch
new file mode 100644
index 000000000000..09234ac61578
--- /dev/null
+++ b/app-accessibility/at-spi2-core/files/at-spi2-core-2.6.2-hung-crash-2.patch
@@ -0,0 +1,26 @@
+From 00c94530c0d57808ac1f9e9b1525341654278ba3 Mon Sep 17 00:00:00 2001
+From: Mike Gorse <mgorse@suse.com>
+Date: Fri, 7 Dec 2012 10:27:58 -0600
+Subject: [PATCH 2/3] Fix another crash when removing hung processes
+
+There was another instance where we were freeing the wrong data.
+---
+ registryd/deviceeventcontroller.c | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/registryd/deviceeventcontroller.c b/registryd/deviceeventcontroller.c
+index 101dc6f..b14cd1e 100644
+--- a/registryd/deviceeventcontroller.c
++++ b/registryd/deviceeventcontroller.c
+@@ -1179,7 +1179,7 @@ reset_hung_process (DBusPendingCall *pending, void *data)
+ if (!strcmp (l->data, dest))
+ {
+ g_free (l->data);
+- hung_processes = g_slist_remove (hung_processes, data);
++ hung_processes = g_slist_remove (hung_processes, l->data);
+ break;
+ }
+ }
+--
+1.8.0
+