summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2011-11-20 15:23:04 +0000
committerPacho Ramos <pacho@gentoo.org>2011-11-20 15:23:04 +0000
commit55d88304c1ea6a79289a7ebe5d0aa67aefdc8f25 (patch)
treeca4b9e57ac7a6648abf7d098d25d7f2dc4ce6ac9 /app-accessibility
parentmask mail-filter/libdomainkeys for removal (diff)
downloadgentoo-2-55d88304c1ea6a79289a7ebe5d0aa67aefdc8f25.tar.gz
gentoo-2-55d88304c1ea6a79289a7ebe5d0aa67aefdc8f25.tar.bz2
gentoo-2-55d88304c1ea6a79289a7ebe5d0aa67aefdc8f25.zip
Version bump.
(Portage version: 2.1.10.36/cvs/Linux x86_64)
Diffstat (limited to 'app-accessibility')
-rw-r--r--app-accessibility/at-spi2-core/ChangeLog7
-rw-r--r--app-accessibility/at-spi2-core/at-spi2-core-2.2.2.ebuild42
2 files changed, 48 insertions, 1 deletions
diff --git a/app-accessibility/at-spi2-core/ChangeLog b/app-accessibility/at-spi2-core/ChangeLog
index 613dd235aa00..b83779866f20 100644
--- a/app-accessibility/at-spi2-core/ChangeLog
+++ b/app-accessibility/at-spi2-core/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-accessibility/at-spi2-core
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-accessibility/at-spi2-core/ChangeLog,v 1.2 2011/11/05 04:50:26 tetromino Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-accessibility/at-spi2-core/ChangeLog,v 1.3 2011/11/20 15:23:04 pacho Exp $
+
+*at-spi2-core-2.2.2 (20 Nov 2011)
+
+ 20 Nov 2011; Pacho Ramos <pacho@gentoo.org> +at-spi2-core-2.2.2.ebuild:
+ Version bump.
*at-spi2-core-2.2.1-r1 (05 Nov 2011)
diff --git a/app-accessibility/at-spi2-core/at-spi2-core-2.2.2.ebuild b/app-accessibility/at-spi2-core/at-spi2-core-2.2.2.ebuild
new file mode 100644
index 000000000000..60fa93b94c86
--- /dev/null
+++ b/app-accessibility/at-spi2-core/at-spi2-core-2.2.2.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-accessibility/at-spi2-core/at-spi2-core-2.2.2.ebuild,v 1.1 2011/11/20 15:23:04 pacho Exp $
+
+EAPI="4"
+GCONF_DEBUG="no"
+GNOME2_LA_PUNT="yes"
+
+inherit eutils gnome2
+
+DESCRIPTION="D-Bus accessibility specifications and registration daemon"
+HOMEPAGE="http://live.gnome.org/Accessibility"
+
+LICENSE="LGPL-2"
+SLOT="2"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc +introspection"
+
+RDEPEND=">=dev-libs/glib-2.28:2
+ >=sys-apps/dbus-1
+ x11-libs/libX11
+ x11-libs/libXi
+ x11-libs/libXtst
+ introspection? ( >=dev-libs/gobject-introspection-0.9.6 )
+"
+DEPEND="${RDEPEND}
+ >=dev-util/intltool-0.40
+ doc? ( >=dev-util/gtk-doc-1.9 )
+"
+
+pkg_setup() {
+ DOCS="AUTHORS ChangeLog NEWS README"
+ # xevie is deprecated/broken since xorg-1.6/1.7
+ G2CONF="${G2CONF} --disable-xevie"
+}
+
+src_prepare() {
+ # disable teamspaces test since that requires Novell.ICEDesktop.Daemon
+ epatch "${FILESDIR}/${PN}-2.0.2-disable-teamspaces-test.patch"
+
+ gnome2_src_prepare
+}