summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2006-08-08 23:54:38 +0000
committerWilliam Hubbs <williamh@gentoo.org>2006-08-08 23:54:38 +0000
commitf18b9c2a6a44a45d94af0f93a4e8544b98267e68 (patch)
tree76947057ac991eda6685a505bbe18a6a28a864f2 /app-accessibility/festival/festival-1.95_beta.ebuild
parent mac-fdisk and mac-pdisk got swapped in -r5, put them back to normal (diff)
downloadgentoo-2-f18b9c2a6a44a45d94af0f93a4e8544b98267e68.tar.gz
gentoo-2-f18b9c2a6a44a45d94af0f93a4e8544b98267e68.tar.bz2
gentoo-2-f18b9c2a6a44a45d94af0f93a4e8544b98267e68.zip
Another fix for gcc 4.1 on amd64.
(Portage version: 2.1.1_pre4-r4)
Diffstat (limited to 'app-accessibility/festival/festival-1.95_beta.ebuild')
-rw-r--r--app-accessibility/festival/festival-1.95_beta.ebuild7
1 files changed, 5 insertions, 2 deletions
diff --git a/app-accessibility/festival/festival-1.95_beta.ebuild b/app-accessibility/festival/festival-1.95_beta.ebuild
index 6d7ede031cff..9f9340dec613 100644
--- a/app-accessibility/festival/festival-1.95_beta.ebuild
+++ b/app-accessibility/festival/festival-1.95_beta.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-accessibility/festival/festival-1.95_beta.ebuild,v 1.3 2006/07/20 03:51:27 williamh Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-accessibility/festival/festival-1.95_beta.ebuild,v 1.4 2006/08/08 23:54:38 williamh Exp $
inherit eutils toolchain-funcs
@@ -58,7 +58,10 @@ src_unpack() {
# gcc 4.1 compatibility patches
epatch ${FILESDIR}/${P}-gcc41.patch
- use amd64 && epatch ${FILESDIR}/${P}-gcc41-amd64.patch
+ if use amd64; then
+ epatch ${FILESDIR}/${P}-gcc41-amd64.patch
+ epatch ${FILESDIR}/${P}-gcc41-amd64-int-pointer.patch
+ fi
}
src_compile() {