summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2011-03-30 18:05:22 +0000
committerWilliam Hubbs <williamh@gentoo.org>2011-03-30 18:05:22 +0000
commit6a4eb8b80b5f02056beb8cd9104e26cc6feecac2 (patch)
treedfa656343278dd012d234b4f3c4678c4383fbd12 /app-accessibility/brltty
parentwrong dies (diff)
downloadgentoo-2-6a4eb8b80b5f02056beb8cd9104e26cc6feecac2.tar.gz
gentoo-2-6a4eb8b80b5f02056beb8cd9104e26cc6feecac2.tar.bz2
gentoo-2-6a4eb8b80b5f02056beb8cd9104e26cc6feecac2.zip
Migrate to eapi 4, remove the static use flag, and fix #361327.
(Portage version: 2.2.0_alpha29/cvs/Linux i686)
Diffstat (limited to 'app-accessibility/brltty')
-rw-r--r--app-accessibility/brltty/ChangeLog5
-rw-r--r--app-accessibility/brltty/brltty-4.2.ebuild14
2 files changed, 13 insertions, 6 deletions
diff --git a/app-accessibility/brltty/ChangeLog b/app-accessibility/brltty/ChangeLog
index 99976d4a6d82..edcd18c4a290 100644
--- a/app-accessibility/brltty/ChangeLog
+++ b/app-accessibility/brltty/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for app-accessibility/brltty
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-accessibility/brltty/ChangeLog,v 1.111 2011/03/29 22:37:28 williamh Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-accessibility/brltty/ChangeLog,v 1.112 2011/03/30 18:05:22 williamh Exp $
+
+ 30 Mar 2011; William Hubbs <williamh@gentoo.org> brltty-4.2.ebuild:
+ Migrate to eapi 4, remove the static use flag, and fix #361327.
29 Mar 2011; William Hubbs <williamh@gentoo.org> brltty-4.2.ebuild:
work around parallel build failure, bug #340903.
diff --git a/app-accessibility/brltty/brltty-4.2.ebuild b/app-accessibility/brltty/brltty-4.2.ebuild
index 044f3324d9dc..51bd2bddd5e2 100644
--- a/app-accessibility/brltty/brltty-4.2.ebuild
+++ b/app-accessibility/brltty/brltty-4.2.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-accessibility/brltty/brltty-4.2.ebuild,v 1.6 2011/03/29 22:37:28 williamh Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-accessibility/brltty/brltty-4.2.ebuild,v 1.7 2011/03/30 18:05:22 williamh Exp $
-EAPI="2"
+EAPI="4"
FINDLIB_USE="ocaml"
inherit findlib eutils multilib toolchain-funcs java-pkg-opt-2 flag-o-matic \
@@ -17,7 +17,12 @@ SLOT="0"
KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~x86"
IUSE="+api +beeper bluetooth +contracted-braille doc +fm gpm iconv icu
java +learn-mode +midi nls ocaml +pcm python usb +speech
- static tcl X"
+ tcl X"
+REQUIRED_USE="doc? ( api )
+ java? ( api )
+ ocaml? ( api )
+ python? ( api )
+ tcl? ( api )"
COMMON_DEP="bluetooth? ( net-wireless/bluez )
gpm? ( >=sys-libs/gpm-1.20 )
@@ -75,7 +80,6 @@ src_configure() {
$(use_enable pcm pcm-support) \
$(use_enable python python-bindings) \
$(use_enable speech speech-support) \
- $(use_enable static standalone-programs) \
$(use_enable tcl tcl-bindings) \
$(use_enable X x) \
$(use_with bluetooth bluetooth-package) \
@@ -126,7 +130,7 @@ src_install() {
dodoc CONTRIBUTORS ChangeLog HISTORY README* TODO BRLTTY-*.txt
dohtml -r Manual-BRLTTY
if use doc; then
- dohtml -r Manual-BRLAPI
+ dohtml -r Manual-BrlAPI
dodoc BrlAPI-*.txt
fi
}