summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2014-07-22 23:26:51 +0000
committerMatthew Thode <prometheanfire@gentoo.org>2014-07-22 23:26:51 +0000
commitfbcac27b0bbe751fc4cbe2141a14e8d540580e26 (patch)
tree1ef06a4fc2c1eff1cfb334d370468d82d27bf825
parentImprove dependencies (diff)
downloadgentoo-2-fbcac27b0bbe751fc4cbe2141a14e8d540580e26.tar.gz
gentoo-2-fbcac27b0bbe751fc4cbe2141a14e8d540580e26.tar.bz2
gentoo-2-fbcac27b0bbe751fc4cbe2141a14e8d540580e26.zip
bup
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 0x2471eb3e40ac5ac3)
-rw-r--r--dev-python/python-swiftclient/ChangeLog8
-rw-r--r--dev-python/python-swiftclient/python-swiftclient-2.2.0.ebuild57
2 files changed, 64 insertions, 1 deletions
diff --git a/dev-python/python-swiftclient/ChangeLog b/dev-python/python-swiftclient/ChangeLog
index 4771f41c1471..0d06afde450d 100644
--- a/dev-python/python-swiftclient/ChangeLog
+++ b/dev-python/python-swiftclient/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/python-swiftclient
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/python-swiftclient/ChangeLog,v 1.15 2014/07/08 16:20:08 prometheanfire Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-swiftclient/ChangeLog,v 1.16 2014/07/22 23:26:51 prometheanfire Exp $
+
+*python-swiftclient-2.2.0 (22 Jul 2014)
+
+ 22 Jul 2014; Matthew Thode <prometheanfire@gentoo.org>
+ +python-swiftclient-2.2.0.ebuild:
+ bup
*python-swiftclient-2.1.0 (08 Jul 2014)
diff --git a/dev-python/python-swiftclient/python-swiftclient-2.2.0.ebuild b/dev-python/python-swiftclient/python-swiftclient-2.2.0.ebuild
new file mode 100644
index 000000000000..f153d3e5700a
--- /dev/null
+++ b/dev-python/python-swiftclient/python-swiftclient-2.2.0.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-swiftclient/python-swiftclient-2.2.0.ebuild,v 1.1 2014/07/22 23:26:51 prometheanfire Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Python bindings to the OpenStack Object Storage API"
+HOMEPAGE="https://launchpad.net/python-swiftclient"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc test"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/pbr[${PYTHON_USEDEP}]
+ test? ( >=dev-python/coverage-3.6[${PYTHON_USEDEP}]
+ >=dev-python/mock-1.0[${PYTHON_USEDEP}]
+ >=dev-python/python-keystoneclient-0.7.0[${PYTHON_USEDEP}]
+ >=dev-python/sphinx-1.1.2[${PYTHON_USEDEP}]
+ <dev-python/sphinx-1.2[${PYTHON_USEDEP}]
+ >=dev-python/testrepository-0.0.18[${PYTHON_USEDEP}]
+ >=dev-python/testtools-0.9.34[${PYTHON_USEDEP}]
+ >=dev-python/hacking-0.8.0[${PYTHON_USEDEP}]
+ <dev-python/hacking-0.9[${PYTHON_USEDEP}]
+ doc? ( >=dev-python/sphinx-1.1.2[${PYTHON_USEDEP}]
+ <dev-python/sphinx-1.2[${PYTHON_USEDEP}] ) )"
+RDEPEND=">=dev-python/simplejson-2.0.9[${PYTHON_USEDEP}]
+ >=dev-python/requests-1.1[${PYTHON_USEDEP}]
+ >=dev-python/six-1.5.2[${PYTHON_USEDEP}]"
+
+#PATCHES=( "${FILESDIR}/CVE-2013-6396.patch" )
+
+python_prepare() {
+ sed -i '/discover/d' "${S}/test-requirements.txt" || die "sed failed"
+ distutils-r1_python_prepare
+}
+
+python_compile_all() {
+ use doc && emake -C doc html
+}
+
+python_test() {
+ testr init
+ testr run || die "tests failed under python2_7"
+ flake8 tests && einfo "run of tests folder by flake8 passed"
+ flake8 bin/swift && einfo "run of ./bin/swift by flake8 passed"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( ../${P}-python2_7/doc/build/html/. )
+ distutils-r1_python_install_all
+}