summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2011-02-11 08:38:21 +0000
committerHans de Graaff <graaff@gentoo.org>2011-02-11 08:38:21 +0000
commitf839bf568dd00ddb6647165a97154310c2de9d52 (patch)
tree2ec08c48644854910df285873d466f5c0ae6cfc9
parentVersion bump. Drop bones-extras which is now a no-op. Fix tests accordingly. (diff)
downloadgentoo-2-f839bf568dd00ddb6647165a97154310c2de9d52.tar.gz
gentoo-2-f839bf568dd00ddb6647165a97154310c2de9d52.tar.bz2
gentoo-2-f839bf568dd00ddb6647165a97154310c2de9d52.zip
Version bump.
(Portage version: 2.1.9.25/cvs/Linux x86_64)
-rw-r--r--dev-ruby/hoe/ChangeLog7
-rw-r--r--dev-ruby/hoe/hoe-2.9.1.ebuild34
2 files changed, 40 insertions, 1 deletions
diff --git a/dev-ruby/hoe/ChangeLog b/dev-ruby/hoe/ChangeLog
index a66f8c5f98bc..090693af5dd6 100644
--- a/dev-ruby/hoe/ChangeLog
+++ b/dev-ruby/hoe/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/hoe
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/hoe/ChangeLog,v 1.103 2011/02/02 07:06:15 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/hoe/ChangeLog,v 1.104 2011/02/11 08:38:21 graaff Exp $
+
+*hoe-2.9.1 (11 Feb 2011)
+
+ 11 Feb 2011; Hans de Graaff <graaff@gentoo.org> +hoe-2.9.1.ebuild:
+ Version bump.
*hoe-2.9.0 (02 Feb 2011)
diff --git a/dev-ruby/hoe/hoe-2.9.1.ebuild b/dev-ruby/hoe/hoe-2.9.1.ebuild
new file mode 100644
index 000000000000..ef1bab0eedda
--- /dev/null
+++ b/dev-ruby/hoe/hoe-2.9.1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/hoe/hoe-2.9.1.ebuild,v 1.1 2011/02/11 08:38:21 graaff Exp $
+
+EAPI=2
+USE_RUBY="ruby18 ree18 ruby19 jruby"
+
+RUBY_FAKEGEM_TASK_DOC="docs"
+
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="History.txt Manifest.txt README.txt"
+
+RUBY_FAKEGEM_EXTRAINSTALL="template"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Hoe extends rake to provide full project automation."
+HOMEPAGE="http://seattlerb.rubyforge.org/"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
+IUSE=""
+
+#RUBY_PATCHES=( "${P}-test-file-ordering.patch" )
+
+# - also requires dev-ruby/hoe-seattlerb for 1.9;
+# - dev-ruby/gemcutter is an optional dependency at both runtime and
+# test-time, at least for us;
+# - rubyforge is loaded at runtime when needed, so we don't strictly
+# depend on it at runtime, but we need it for tests (for now);
+ruby_add_bdepend "test? ( dev-ruby/minitest >=dev-ruby/rubyforge-2.0.4 )"
+
+ruby_add_rdepend ">=dev-ruby/rake-0.8.7"