summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-06-15 19:58:05 +0000
committerJustin Lecher <jlec@gentoo.org>2015-06-15 19:58:05 +0000
commitf42e47395e7278b374aff91bddb4c1c184ecfb89 (patch)
tree94c98ad2972f60f364ab6e6b3297b758fcf6380e
parentUpdating remote-id in metadata.xml (diff)
downloadgentoo-2-f42e47395e7278b374aff91bddb4c1c184ecfb89.tar.gz
gentoo-2-f42e47395e7278b374aff91bddb4c1c184ecfb89.tar.bz2
gentoo-2-f42e47395e7278b374aff91bddb4c1c184ecfb89.zip
Version Bump, bug #549776
(Portage version: 2.2.20/cvs/Linux x86_64, signed Manifest commit with key E9402A79B03529A2!)
-rw-r--r--dev-python/paste/ChangeLog8
-rw-r--r--dev-python/paste/files/paste-2.0.2-unbundle-tempita.patch36
-rw-r--r--dev-python/paste/metadata.xml2
-rw-r--r--dev-python/paste/paste-2.0.2.ebuild73
4 files changed, 117 insertions, 2 deletions
diff --git a/dev-python/paste/ChangeLog b/dev-python/paste/ChangeLog
index 022753c7ee32..06ff04fcaa1f 100644
--- a/dev-python/paste/ChangeLog
+++ b/dev-python/paste/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/paste
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/paste/ChangeLog,v 1.28 2015/04/08 08:05:09 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/paste/ChangeLog,v 1.29 2015/06/15 19:58:05 jlec Exp $
+
+*paste-2.0.2 (15 Jun 2015)
+
+ 15 Jun 2015; Justin Lecher <jlec@gentoo.org>
+ +files/paste-2.0.2-unbundle-tempita.patch, +paste-2.0.2.ebuild, metadata.xml:
+ Version Bump, bug #549776
08 Apr 2015; Michał Górny <mgorny@gentoo.org> paste-1.7.5.1-r1.ebuild,
paste-1.7.5.1-r2.ebuild:
diff --git a/dev-python/paste/files/paste-2.0.2-unbundle-tempita.patch b/dev-python/paste/files/paste-2.0.2-unbundle-tempita.patch
new file mode 100644
index 000000000000..eef7abb4108e
--- /dev/null
+++ b/dev-python/paste/files/paste-2.0.2-unbundle-tempita.patch
@@ -0,0 +1,36 @@
+ paste/util/looper/__init__.py | 4 ++++
+ paste/util/{looper.py => looper/_looper.py} | 0
+ paste/util/template/__init__.py | 6 ++++++
+ paste/util/{template.py => template/_template.py} | 0
+ 4 files changed, 10 insertions(+)
+
+diff --git a/paste/util/looper/__init__.py b/paste/util/looper/__init__.py
+new file mode 100644
+index 0000000..77d7e80
+--- /dev/null
++++ b/paste/util/looper/__init__.py
+@@ -0,0 +1,4 @@
++try:
++ from tempita._looper import *
++except ImportError:
++ from _looper import *
+diff --git a/paste/util/looper.py b/paste/util/looper/_looper.py
+similarity index 100%
+rename from paste/util/looper.py
+rename to paste/util/looper/_looper.py
+diff --git a/paste/util/template/__init__.py b/paste/util/template/__init__.py
+new file mode 100644
+index 0000000..a0a5730
+--- /dev/null
++++ b/paste/util/template/__init__.py
+@@ -0,0 +1,6 @@
++try:
++ from tempita import *
++ from tempita import paste_script_template_renderer
++except ImportError:
++ from _template import *
++ from _template import paste_script_template_renderer
+diff --git a/paste/util/template.py b/paste/util/template/_template.py
+similarity index 100%
+rename from paste/util/template.py
+rename to paste/util/template/_template.py
diff --git a/dev-python/paste/metadata.xml b/dev-python/paste/metadata.xml
index 7f517e87fb92..60a4c1835023 100644
--- a/dev-python/paste/metadata.xml
+++ b/dev-python/paste/metadata.xml
@@ -7,7 +7,7 @@
wgsi servers and middleware)</flag>
<flag name="openid">enable OpenID support</flag>
</use>
- <longdescription lang="en">This package provides several pieces of &quot;middleware&quot; (or filters) that can
+ <longdescription lang="en">This package provides several pieces of "middleware" (or filters) that can
be nested to build web applications. Each piece of middleware uses the WSGI
(PEP 333) interface, and should be compatible with other middleware based on
those interfaces.</longdescription>
diff --git a/dev-python/paste/paste-2.0.2.ebuild b/dev-python/paste/paste-2.0.2.ebuild
new file mode 100644
index 000000000000..7a45cc64a009
--- /dev/null
+++ b/dev-python/paste/paste-2.0.2.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/paste/paste-2.0.2.ebuild,v 1.1 2015/06/15 19:58:05 jlec Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{3,4} )
+
+inherit distutils-r1
+
+MY_PN="Paste"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Tools for using a Web Server Gateway Interface stack"
+HOMEPAGE="http://pythonpaste.org http://pypi.python.org/pypi/Paste"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~x86-interix ~amd64-linux ~x86-linux ~x64-macos ~x86-macos ~sparc-solaris"
+IUSE="doc flup openid"
+
+RDEPEND="
+ dev-python/six[${PYTHON_USEDEP}]
+ >=dev-python/tempita-0.5.2_pre20130828[${PYTHON_USEDEP}]
+ flup? ( dev-python/flup[$(python_gen_usedep 'python2*')] )
+ openid? ( dev-python/python-openid[$(python_gen_usedep 'python2*')] )"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
+
+S="${WORKDIR}/${MY_P}"
+
+python_prepare_all() {
+ # Disable failing tests.
+ rm -f tests/test_cgiapp.py || die
+ sed \
+ -e "s/test_find_file/_&/" \
+ -e "s/test_deep/_&/" \
+ -e "s/test_static_parser/_&/" \
+ -i tests/test_urlparser.py || die "sed failed"
+
+ # Remove a test that runs against the paste website.
+ rm -f tests/test_proxy.py || die
+
+ local PATCHES=(
+ "${FILESDIR}"/${PN}-1.7.5.1-fix-tests-for-pypy.patch
+ "${FILESDIR}"/${P}-unbundle-tempita.patch
+ )
+
+ distutils-r1_python_prepare_all
+}
+
+python_compile() {
+ distutils-r1_python_compile egg_info --egg-base "${BUILD_DIR}/lib"
+}
+
+python_compile_all() {
+ use doc && esetup.py build_sphinx
+}
+
+python_test() {
+ nosetests -P -v || die "Tests fail with ${EPYTHON}"
+}
+
+python_install() {
+ distutils-r1_python_install egg_info --egg-base "${BUILD_DIR}/lib"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( "${BUILD_DIR}"/sphinx/html/. )
+ distutils-r1_python_install_all
+}