summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2009-10-07 07:43:39 +0000
committerAlfredo Tupone <tupone@gentoo.org>2009-10-07 07:43:39 +0000
commitf061443b1cf91b1a614560446a8b22326ee631ff (patch)
tree085ade7f6b20f27c6a17ee40ab008ee6f356a934
parentDepend on sptk-3.5* specifically (diff)
downloadgentoo-2-f061443b1cf91b1a614560446a8b22326ee631ff.tar.gz
gentoo-2-f061443b1cf91b1a614560446a8b22326ee631ff.tar.bz2
gentoo-2-f061443b1cf91b1a614560446a8b22326ee631ff.zip
Fix build with glibc-2.10 Bug #286532
(Portage version: 2.1.6.13/cvs/Linux i686)
-rw-r--r--games-roguelike/nethack/ChangeLog6
-rw-r--r--games-roguelike/nethack/files/nethack-3.4.3-gibc210.patch13
-rw-r--r--games-roguelike/nethack/nethack-3.4.3-r1.ebuild14
3 files changed, 25 insertions, 8 deletions
diff --git a/games-roguelike/nethack/ChangeLog b/games-roguelike/nethack/ChangeLog
index 77788aaa301d..9b3480267bcf 100644
--- a/games-roguelike/nethack/ChangeLog
+++ b/games-roguelike/nethack/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-roguelike/nethack
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-roguelike/nethack/ChangeLog,v 1.31 2009/09/23 17:40:47 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-roguelike/nethack/ChangeLog,v 1.32 2009/10/07 07:43:39 tupone Exp $
+
+ 07 Oct 2009; Tupone Alfredo <tupone@gentoo.org>
+ +files/nethack-3.4.3-gibc210.patch, nethack-3.4.3-r1.ebuild:
+ Fix build with glibc-2.10 Bug #286532 by Andrew Savchenko
23 Sep 2009; Patrick Lauer <patrick@gentoo.org> nethack-3.4.3-r1.ebuild:
Remove virtual/libc
diff --git a/games-roguelike/nethack/files/nethack-3.4.3-gibc210.patch b/games-roguelike/nethack/files/nethack-3.4.3-gibc210.patch
new file mode 100644
index 000000000000..20675cabf4b4
--- /dev/null
+++ b/games-roguelike/nethack/files/nethack-3.4.3-gibc210.patch
@@ -0,0 +1,13 @@
+--- include/unixconf.h.old 2009-10-07 09:37:46.000000000 +0200
++++ include/unixconf.h 2009-10-07 09:38:05.000000000 +0200
+@@ -293,10 +293,8 @@
+ # endif
+ #else /* therefore SYSV */
+ # ifndef index /* some systems seem to do this for you */
+-#define index strchr
+ # endif
+ # ifndef rindex
+-#define rindex strrchr
+ # endif
+ #endif
+
diff --git a/games-roguelike/nethack/nethack-3.4.3-r1.ebuild b/games-roguelike/nethack/nethack-3.4.3-r1.ebuild
index 4a0c5feb1bca..ad205862b1cb 100644
--- a/games-roguelike/nethack/nethack-3.4.3-r1.ebuild
+++ b/games-roguelike/nethack/nethack-3.4.3-r1.ebuild
@@ -1,6 +1,7 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-roguelike/nethack/nethack-3.4.3-r1.ebuild,v 1.24 2009/09/23 17:40:47 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-roguelike/nethack/nethack-3.4.3-r1.ebuild,v 1.25 2009/10/07 07:43:39 tupone Exp $
+EAPI=2
inherit eutils toolchain-funcs flag-o-matic games
@@ -31,20 +32,19 @@ DEPEND="${RDEPEND}
HACKDIR="${GAMES_DATADIR}/${PN}"
-src_unpack() {
- unpack ${A}
-
+src_prepare() {
# This copies the /sys/unix Makefile.*s to their correct places for
# seding and compiling.
- cd "${S}/sys/unix"
+ cd "sys/unix"
source setup.sh || die
- cd "${S}"
+ cd ../..
epatch \
"${FILESDIR}"/${PV}-gentoo-paths.patch \
"${FILESDIR}"/${PV}-default-options.patch \
"${FILESDIR}"/${PV}-bison.patch \
- "${FILESDIR}"/${PV}-macos.patch
+ "${FILESDIR}"/${PV}-macos.patch \
+ "${FILESDIR}"/${P}-gibc210.patch
sed -i \
-e "s:GENTOO_STATEDIR:${GAMES_STATEDIR}/${PN}:" include/unixconf.h \