summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2004-07-22 00:10:31 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2004-07-22 00:10:31 +0000
commitcf480394b13e7c32c65d15fcad2dbb81f7b5eff3 (patch)
treea81fc14ae97857708af42a3c560603c033272cd8
parentstable on amd64 (Manifest recommit) (diff)
downloadgentoo-2-cf480394b13e7c32c65d15fcad2dbb81f7b5eff3.tar.gz
gentoo-2-cf480394b13e7c32c65d15fcad2dbb81f7b5eff3.tar.bz2
gentoo-2-cf480394b13e7c32c65d15fcad2dbb81f7b5eff3.zip
use fewer shells
-rw-r--r--sys-libs/glibc/ChangeLog6
-rw-r--r--sys-libs/glibc/glibc-2.3.3.20040420.ebuild6
2 files changed, 8 insertions, 4 deletions
diff --git a/sys-libs/glibc/ChangeLog b/sys-libs/glibc/ChangeLog
index ddbd0b1d4b1a..4a8edd492eb6 100644
--- a/sys-libs/glibc/ChangeLog
+++ b/sys-libs/glibc/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-libs/glibc
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/ChangeLog,v 1.211 2004/07/21 21:09:59 gmsoft Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/ChangeLog,v 1.212 2004/07/22 00:10:31 mr_bones_ Exp $
+
+ 21 Jul 2004; Michael Sterrett <mr_bones_@gentoo.org>
+ glibc-2.3.3.20040420.ebuild:
+ use fewer shells
21 Jul 2004; Guy Martin <gmsoft@gentoo.org> glibc-2.3.4.20040619:
Added patches for hppa.
diff --git a/sys-libs/glibc/glibc-2.3.3.20040420.ebuild b/sys-libs/glibc/glibc-2.3.3.20040420.ebuild
index 6cb1c22f3fdb..14453049ce1f 100644
--- a/sys-libs/glibc/glibc-2.3.3.20040420.ebuild
+++ b/sys-libs/glibc/glibc-2.3.3.20040420.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.3.20040420.ebuild,v 1.18 2004/07/20 10:59:02 pappy Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.3.20040420.ebuild,v 1.19 2004/07/22 00:10:31 mr_bones_ Exp $
inherit eutils flag-o-matic gcc
@@ -254,7 +254,7 @@ src_unpack() {
cd ${S}
# Extract our threads package ...
- if (! use_nptl) && [ -z "${BRANCH_UPDATE}" ]
+ if ! use_nptl && [ -z "${BRANCH_UPDATE}" ]
then
unpack glibc-linuxthreads-${MY_PV}.tar.bz2
fi
@@ -290,7 +290,7 @@ src_unpack() {
# sparc fails when building the components for the normal crt1.o
# with -K PIC automatically via hardened PIE and SSP specs files
- if ( use sparc && use hardened )
+ if use sparc && use hardened
then
einfo "adding crt1.o bugfix for hardened gcc on sparc glibc"
sed -i "s|CPPFLAGS += -DHAVE_INITFINI|CPPFLAGS += -DHAVE_INITFINI -fno-pie -fno-PIE|" \