summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2011-02-03 12:23:22 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2011-02-03 12:23:22 +0000
commitba5e64cf07f04f53191509be94423aa3b116988f (patch)
treebf659a12d68147cc3e1f72726bcfce32e2b5cee1
parentAdded ~ppc64 wrt #353129 (diff)
downloadgentoo-2-ba5e64cf07f04f53191509be94423aa3b116988f.tar.gz
gentoo-2-ba5e64cf07f04f53191509be94423aa3b116988f.tar.bz2
gentoo-2-ba5e64cf07f04f53191509be94423aa3b116988f.zip
Version bump by Pavel Stratil.
(Portage version: 2.2.0_alpha19/cvs/Linux x86_64)
-rw-r--r--dev-db/haildb/ChangeLog9
-rw-r--r--dev-db/haildb/haildb-2.3.2.ebuild54
2 files changed, 61 insertions, 2 deletions
diff --git a/dev-db/haildb/ChangeLog b/dev-db/haildb/ChangeLog
index e911ce72dd1f..6a17d6bf968a 100644
--- a/dev-db/haildb/ChangeLog
+++ b/dev-db/haildb/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-db/haildb
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/haildb/ChangeLog,v 1.3 2010/10/25 00:23:07 fauli Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/haildb/ChangeLog,v 1.4 2011/02/03 12:23:22 flameeyes Exp $
+
+*haildb-2.3.2 (03 Feb 2011)
+
+ 03 Feb 2011; Diego E. Pettenò <flameeyes@gentoo.org> +haildb-2.3.2.ebuild:
+ Version bump by Pavel Stratil.
25 Oct 2010; Christian Faulhammer <fauli@gentoo.org> haildb-2.3.1.ebuild:
add ~x86, bug 341633
diff --git a/dev-db/haildb/haildb-2.3.2.ebuild b/dev-db/haildb/haildb-2.3.2.ebuild
new file mode 100644
index 000000000000..0d2723239418
--- /dev/null
+++ b/dev-db/haildb/haildb-2.3.2.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $
+
+EAPI=2
+
+inherit versionator flag-o-matic
+
+DESCRIPTION="a relational database in shared library form"
+HOMEPAGE="http://www.haildb.com/"
+SRC_URI="http://launchpad.net/haildb/$(get_version_component_range 1-2)/cairo/+download/${P}.tar.gz"
+LICENSE="GPL-2 MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug tcmalloc zlib"
+
+RDEPEND="tcmalloc? ( dev-util/google-perftools )
+ zlib? ( sys-libs/zlib )"
+DEPEND="${RDEPEND}
+ sys-devel/bison"
+
+src_configure() {
+ local myconf
+
+ if use debug; then
+ # Since --with-debug would turn off optimisations as well as
+ # enabling debug, we just enable debug through the
+ # preprocessor then.
+ append-flags -DDEBUG
+ else
+ myconf="${myconf} --disable-assert"
+ fi
+
+ # never allow it to find valgrind, easier this way
+ export ac_cv_header_valgrind_memcheck_h=no
+
+ econf \
+ --disable-static \
+ --disable-dependency-tracking \
+ --enable-fast-install \
+ --disable-silent-rules \
+ --disable-mtmalloc \
+ $(use_enable zlib compression) \
+ $(use_enable tcmalloc) \
+ ${myconf} \
+ || die "econf failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "install failed"
+ dodoc ChangeLog README || die
+
+ find "${D}" -name '*.la' -delete || die
+}