summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Palimaka <kensington@gentoo.org>2012-08-04 14:21:04 +0000
committerMichael Palimaka <kensington@gentoo.org>2012-08-04 14:21:04 +0000
commitb726e473ebd4b02ac93988f962f4b30921b45de8 (patch)
treebb5efd54dfb875c94cb510865945d4f1c993f37d
parentx11-drivers/xf86-video-intel: Bump to 2.20.3 (diff)
downloadgentoo-2-b726e473ebd4b02ac93988f962f4b30921b45de8.tar.gz
gentoo-2-b726e473ebd4b02ac93988f962f4b30921b45de8.tar.bz2
gentoo-2-b726e473ebd4b02ac93988f962f4b30921b45de8.zip
Initial import for bug #371723. Ebuild by Alessandro Di Federico <ale@clearmind.me>.
(Portage version: 2.1.11.9/cvs/Linux x86_64)
-rw-r--r--app-admin/keepass/ChangeLog12
-rw-r--r--app-admin/keepass/files/keepass-2.19-skip-sgen-if-unix.patch18
-rw-r--r--app-admin/keepass/files/keepass-2.19-xsl-path-detection.patch43
-rw-r--r--app-admin/keepass/files/keepass.xml9
-rw-r--r--app-admin/keepass/keepass-2.19.ebuild100
-rw-r--r--app-admin/keepass/metadata.xml19
6 files changed, 201 insertions, 0 deletions
diff --git a/app-admin/keepass/ChangeLog b/app-admin/keepass/ChangeLog
new file mode 100644
index 000000000000..24cdd79dc85e
--- /dev/null
+++ b/app-admin/keepass/ChangeLog
@@ -0,0 +1,12 @@
+# ChangeLog for app-admin/keepass
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/keepass/ChangeLog,v 1.1 2012/08/04 14:21:04 kensington Exp $
+
+*keepass-2.19 (04 Aug 2012)
+
+ 04 Aug 2012; Michael Palimaka <kensington@gentoo.org>
+ +files/keepass-2.19-skip-sgen-if-unix.patch,
+ +files/keepass-2.19-xsl-path-detection.patch, +files/keepass.xml,
+ +keepass-2.19.ebuild, +metadata.xml:
+ Initial import for bug #371723. Ebuild by Alessandro Di Federico
+ <ale@clearmind.me>.
diff --git a/app-admin/keepass/files/keepass-2.19-skip-sgen-if-unix.patch b/app-admin/keepass/files/keepass-2.19-skip-sgen-if-unix.patch
new file mode 100644
index 000000000000..69abc95d1269
--- /dev/null
+++ b/app-admin/keepass/files/keepass-2.19-skip-sgen-if-unix.patch
@@ -0,0 +1,18 @@
+This patch is a workaround to disable the use of sgen.exe after the build,
+since sgen.exe is not available in Mono. The trick works because we use a
+syntax which is common to sh and cmd.exe, but we also use `true` which is part
+of UNIX coreutils.
+true || windows-part
+
+--- a/KeePass/KeePass.csproj
++++ b/KeePass/KeePass.csproj
+@@ -1249,6 +1249,6 @@
+ </Target>
+ -->
+ <PropertyGroup>
+- <PostBuildEvent>"$(FrameworkSDKDir)bin\sgen.exe" /assembly:"$(TargetPath)" /force /nologo /compiler:/keycontainer:VS_KEY_33430356D8D7D1B8 /compiler:/delaysign-</PostBuildEvent>
++ <PostBuildEvent>true || "$(FrameworkSDKDir)bin\sgen.exe" /assembly:"$(TargetPath)" /force /nologo /compiler:/keycontainer:VS_KEY_33430356D8D7D1B8 /compiler:/delaysign-</PostBuildEvent>
+ </PropertyGroup>
+-</Project>
+\ No newline at end of file
++</Project>
diff --git a/app-admin/keepass/files/keepass-2.19-xsl-path-detection.patch b/app-admin/keepass/files/keepass-2.19-xsl-path-detection.patch
new file mode 100644
index 000000000000..76b924111141
--- /dev/null
+++ b/app-admin/keepass/files/keepass-2.19-xsl-path-detection.patch
@@ -0,0 +1,43 @@
+KeePass looks for some resources (XSL files) in the executable directory,
+however under UNIX system this not a good idea, so we look into the
+CommonApplicationData SpecialFolder, which usually maps to "/usr/share/".
+So the final search path should be "/usr/share/KeePass/XSL/".
+
+--- a/KeePass/Forms/AboutForm.cs
++++ b/KeePass/Forms/AboutForm.cs
+@@ -31,9 +31,11 @@ using KeePass.UI;
+ using KeePass.Resources;
+ using KeePass.Util;
+ using KeePass.DataExchange;
++using KeePass.Native;
+
+ using KeePassLib;
+ using KeePassLib.Utility;
++using KeePassLib.Native;
+
+ namespace KeePass.Forms
+ {
+@@ -92,8 +94,21 @@ namespace KeePass.Forms
+ m_lvComponents.Items.Add(lvi);
+
+ lvi = new ListViewItem(KPRes.XslStylesheets);
+- string strPath = WinUtil.GetExecutable();
+- strPath = UrlUtil.GetFileDirectory(strPath, true, false);
++
++ string strPath;
++ if (NativeLib.IsUnix())
++ {
++ strPath = Environment.GetFolderPath(Environment.SpecialFolder.CommonApplicationData);
++ strPath = UrlUtil.EnsureTerminatingSeparator(strPath, false);
++ strPath += PwDefs.ShortProductName.ToLower();
++ strPath = UrlUtil.EnsureTerminatingSeparator(strPath, false);
++ }
++ else
++ {
++ strPath = WinUtil.GetExecutable();
++ strPath = UrlUtil.GetFileDirectory(strPath, true, false);
++ }
++
+ strPath += AppDefs.XslFilesDir;
+ strPath = UrlUtil.EnsureTerminatingSeparator(strPath, false);
+ bool bInstalled = File.Exists(strPath + AppDefs.XslFileHtmlLite);
diff --git a/app-admin/keepass/files/keepass.xml b/app-admin/keepass/files/keepass.xml
new file mode 100644
index 000000000000..5e3d80dcae7b
--- /dev/null
+++ b/app-admin/keepass/files/keepass.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<mime-info xmlns='http://www.freedesktop.org/standards/shared-mime-info'>
+ <mime-type type="application/x-keepass2">
+ <comment>KeePass database</comment>
+ <glob pattern="*.kdbx"/>
+ <icon name="keepass" />
+ </mime-type>
+</mime-info>
+
diff --git a/app-admin/keepass/keepass-2.19.ebuild b/app-admin/keepass/keepass-2.19.ebuild
new file mode 100644
index 000000000000..94d842392868
--- /dev/null
+++ b/app-admin/keepass/keepass-2.19.ebuild
@@ -0,0 +1,100 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/keepass/keepass-2.19.ebuild,v 1.1 2012/08/04 14:21:04 kensington Exp $
+
+EAPI=4
+
+inherit eutils fdo-mime gnome2-utils mono multilib
+
+MY_PN="KeePass"
+DESCRIPTION="A free, open source, light-weight and easy-to-use password manager"
+HOMEPAGE="http://keepass.info/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_PN}-${PV}-Source.zip"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="aot"
+
+RDEPEND=">=dev-lang/mono-2.10.5"
+DEPEND="${RDEPEND}
+ app-arch/unzip"
+
+S=${WORKDIR}
+
+src_prepare() {
+ # Remove Windows-specific things
+ pushd Build || die
+ . PrepMonoDev.sh || die
+ popd || die
+
+ # sgen not available on mono
+ epatch "${FILESDIR}/${PN}-2.19-skip-sgen-if-unix.patch"
+
+ # KeePass looks for some XSL files in the same folder as the executable,
+ # we prefer to have it in /usr/share/KeePass
+ epatch "${FILESDIR}/${PN}-2.19-xsl-path-detection.patch"
+}
+
+src_compile() {
+ # Build with Release target
+ xbuild /target:KeePass /property:Configuration=Release || die
+
+ # Run Ahead Of Time compiler on the binary
+ if use aot; then
+ mono --aot -O=all Build/KeePass/Release/KeePass.exe || die
+ fi
+}
+
+src_install() {
+ # Wrapper script to launch mono
+ make_wrapper ${PN} "mono /usr/$(get_libdir)/${PN}/KeePass.exe"
+
+ # Some XSL files
+ insinto /usr/share/${PN}/XSL
+ doins Ext/XSL/*
+
+ insinto /usr/$(get_libdir)/${PN}/
+ exeinto /usr/$(get_libdir)/${PN}/
+ doins Ext/KeePass.exe.config
+ # Default configuration, simply says to use user-specific configuration
+ doins Ext/KeePass.config.xml
+
+ # The actual executable
+ doexe Build/KeePass/Release/KeePass.exe
+
+ # Copy the AOT compilation result
+ if use aot; then
+ doexe Build/KeePass/Release/KeePass.exe.so
+ fi
+
+ # Prepare the icons
+ newicon -s 256 Ext/Icons/Finals/plockb.png "${PN}.png"
+ newicon -s 256 -t gnome -c mimetypes Ext/Icons/Finals/plockb.png "application-x-${PN}2.png"
+
+ # Create a desktop entry and associate it with the KeePass mime type
+ make_desktop_entry ${PN} ${MY_PN} ${PN} "System;Security" "MimeType=application/x-keepass2;"
+
+ # MIME descriptor for .kdbx files
+ insinto /usr/share/mime/packages/
+ doins "${FILESDIR}/${PN}.xml"
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+ fdo-mime_mime_database_update
+ fdo-mime_desktop_database_update
+
+ elog "Optional dependencies:"
+ elog " x11-misc/xdotool (enables autotype)"
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+ fdo-mime_mime_database_update
+ fdo-mime_desktop_database_update
+}
diff --git a/app-admin/keepass/metadata.xml b/app-admin/keepass/metadata.xml
new file mode 100644
index 000000000000..9db56bc586ef
--- /dev/null
+++ b/app-admin/keepass/metadata.xml
@@ -0,0 +1,19 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>ale@clearmind.me</email>
+ <description>Maintainer. Assign bugs to him.</description>
+ </maintainer>
+ <maintainer>
+ <email>kensington@gentoo.org</email>
+ <description>Proxy maintainer. CC him on bugs.</description>
+ </maintainer>
+ <use>
+ <flag name="aot">Generate native code at build time, rather than runtime.</flag>
+ </use>
+ <upstream>
+ <remote-id type="sourceforge">keepass</remote-id>
+ <bugs-to>http://sourceforge.net/tracker/?group_id=95013</bugs-to>
+ </upstream>
+</pkgmetadata>