summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexandre Rostovtsev <tetromino@gentoo.org>2012-04-21 07:59:04 +0000
committerAlexandre Rostovtsev <tetromino@gentoo.org>2012-04-21 07:59:04 +0000
commitb1e3524dabc454eec0bd76d142be543850c45cb1 (patch)
treea82ee3721db24a149284f506f8f5660974f978e4
parentVersion bump. (diff)
downloadgentoo-2-b1e3524dabc454eec0bd76d142be543850c45cb1.tar.gz
gentoo-2-b1e3524dabc454eec0bd76d142be543850c45cb1.tar.bz2
gentoo-2-b1e3524dabc454eec0bd76d142be543850c45cb1.zip
Add seahorse's key sharing daemon; part of app-crypt/seahorse before 3.2.0.
(Portage version: 2.2.0_alpha100/cvs/Linux x86_64)
-rw-r--r--app-crypt/seahorse-sharing/ChangeLog10
-rw-r--r--app-crypt/seahorse-sharing/metadata.xml5
-rw-r--r--app-crypt/seahorse-sharing/seahorse-sharing-3.4.0.ebuild51
3 files changed, 66 insertions, 0 deletions
diff --git a/app-crypt/seahorse-sharing/ChangeLog b/app-crypt/seahorse-sharing/ChangeLog
new file mode 100644
index 000000000000..2a9c5caa4772
--- /dev/null
+++ b/app-crypt/seahorse-sharing/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for app-crypt/seahorse-sharing
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/seahorse-sharing/ChangeLog,v 1.1 2012/04/21 07:59:04 tetromino Exp $
+
+*seahorse-sharing-3.4.0 (21 Apr 2012)
+
+ 21 Apr 2012; Alexandre Rostovtsev <tetromino@gentoo.org>
+ +seahorse-sharing-3.4.0.ebuild, +metadata.xml:
+ Add seahorse's key sharing daemon; part of app-crypt/seahorse before 3.2.0.
+
diff --git a/app-crypt/seahorse-sharing/metadata.xml b/app-crypt/seahorse-sharing/metadata.xml
new file mode 100644
index 000000000000..da6fd63d0085
--- /dev/null
+++ b/app-crypt/seahorse-sharing/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>gnome</herd>
+</pkgmetadata>
diff --git a/app-crypt/seahorse-sharing/seahorse-sharing-3.4.0.ebuild b/app-crypt/seahorse-sharing/seahorse-sharing-3.4.0.ebuild
new file mode 100644
index 000000000000..95838a8f3e36
--- /dev/null
+++ b/app-crypt/seahorse-sharing/seahorse-sharing-3.4.0.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/seahorse-sharing/seahorse-sharing-3.4.0.ebuild,v 1.1 2012/04/21 07:59:04 tetromino Exp $
+
+EAPI="4"
+
+inherit gnome2
+
+DESCRIPTION="Daemon for PGP public key sharing using DNS-SD and HKP"
+HOMEPAGE="http://projects.gnome.org/seahorse/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+COMMON_DEPEND="dev-libs/glib:2
+ >=net-dns/avahi-0.6
+ net-libs/libsoup:2.4
+ >=x11-libs/gtk+-3:3
+
+ >=app-crypt/gpgme-1
+ || (
+ =app-crypt/gnupg-2.0*
+ =app-crypt/gnupg-1.4* )"
+RDEPEND="${COMMON_DEPEND}
+ !<app-crypt/seahorse-3.2"
+# ${PN} was part of seahorse before 3.2
+DEPEND="${COMMON_DEPEND}
+ >=dev-util/intltool-0.35
+ dev-util/pkgconfig
+ sys-devel/gettext"
+
+pkg_setup() {
+ DOCS="AUTHORS MAINTAINERS NEWS" # ChangeLog has nothing useful
+ # Do not pass --enable-tests to configure - package has no tests
+}
+
+src_prepare() {
+ gnome2_src_prepare
+ # Avoid eautoreconf
+ sed -e 's:$CFLAGS -g -O0:$CFLAGS:' -i configure || die "sed failed"
+}
+
+pkg_postinst() {
+ elog "To use ${PN}, the Avahi daemon must be running. On an OpenRC"
+ elog "system, you can start the Avahi daemon by"
+ elog "# /etc/init.d/avahi-daemon start"
+ elog "To start Avahi automatically, add it to the default runlevel:"
+ elog "# rc-update add avahi-daemon default"
+}