summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Holzer <mholzer@gentoo.org>2003-01-18 19:12:04 +0000
committerMartin Holzer <mholzer@gentoo.org>2003-01-18 19:12:04 +0000
commitaf62cdebc1bd62502a6df10b4e014649468e3b6a (patch)
treed9b95c6d9f154ac7a0da0c5331b3237cc13ee3e2
parentAdded mips to keywords (diff)
downloadgentoo-2-af62cdebc1bd62502a6df10b4e014649468e3b6a.tar.gz
gentoo-2-af62cdebc1bd62502a6df10b4e014649468e3b6a.tar.bz2
gentoo-2-af62cdebc1bd62502a6df10b4e014649468e3b6a.zip
Version bumped.
-rw-r--r--net-analyzer/rrdtool/ChangeLog8
-rw-r--r--net-analyzer/rrdtool/files/digest-rrdtool-1.0.401
-rw-r--r--net-analyzer/rrdtool/rrdtool-1.0.40.ebuild111
3 files changed, 119 insertions, 1 deletions
diff --git a/net-analyzer/rrdtool/ChangeLog b/net-analyzer/rrdtool/ChangeLog
index 7a5df0be9d5d..88e47ef79303 100644
--- a/net-analyzer/rrdtool/ChangeLog
+++ b/net-analyzer/rrdtool/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-analyzer/rrdtool
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/rrdtool/ChangeLog,v 1.9 2002/12/13 10:59:47 blizzy Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/rrdtool/ChangeLog,v 1.10 2003/01/18 19:12:04 mholzer Exp $
+
+*rrdtool-1.0.40 (18 Jan 2003)
+
+ 18 Jan 2003; Martin Holzer <mholzer@gentoo.org> rrdtool-1.0.40.ebuild
+ files/digest-rrdtool-1.0.40 ChangeLog :
+ Version bumped. Closes #10703.
06 Dec 2002; Rodney Rees <manson@gentoo.org> : changed sparc ~sparc keywords
diff --git a/net-analyzer/rrdtool/files/digest-rrdtool-1.0.40 b/net-analyzer/rrdtool/files/digest-rrdtool-1.0.40
new file mode 100644
index 000000000000..ce8b68765603
--- /dev/null
+++ b/net-analyzer/rrdtool/files/digest-rrdtool-1.0.40
@@ -0,0 +1 @@
+MD5 6754a550c788e9cea626dec4a3a25219 rrdtool-1.0.40.tar.gz 1148458
diff --git a/net-analyzer/rrdtool/rrdtool-1.0.40.ebuild b/net-analyzer/rrdtool/rrdtool-1.0.40.ebuild
new file mode 100644
index 000000000000..8eea8ce123dd
--- /dev/null
+++ b/net-analyzer/rrdtool/rrdtool-1.0.40.ebuild
@@ -0,0 +1,111 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/rrdtool/rrdtool-1.0.40.ebuild,v 1.1 2003/01/18 19:12:04 mholzer Exp $
+
+inherit perl-module
+
+DESCRIPTION="A system to store and display time-series data"
+SRC_URI="http://people.ee.ethz.ch/%7Eoetiker/webtools/rrdtool/pub/${P}.tar.gz"
+HOMEPAGE="http://ee-staff.ethz.ca/~oetiker/webtools/rrdtool/"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~sparc"
+IUSE="tcltk perl"
+
+DEPEND="perl? ( sys-devel/perl )
+ sys-apps/gawk
+ >=media-libs/libgd-1.8.3"
+RDEPEND="tcltk? ( dev-lang/tcl )"
+
+TCLVER=""
+
+pkg_setup() {
+ use tcltk && \
+ TCLVER=`awk -F\' '/TCL_VERSION/ {print $2}' /usr/lib/tclConfig.sh`
+
+ use perl && ( \
+ perl-post_pkg_setup
+ )
+}
+
+src_compile() {
+
+ local myconf
+ use tcltk \
+ && myconf="${myconf} --with-tcllib=/usr/lib" \
+ || myconf="${myconf} --without-tcllib"
+
+ econf \
+ --datadir=/usr/share \
+ --enable-shared \
+ --with-perl-options='INSTALLMAN1DIR=/usr/share/man/man1 INSTALLMAN3DIR=/usr/share/man/man3 PREFIX=${D}/usr' \
+ ${myconf} || die
+
+
+ make || die
+}
+
+src_install () {
+
+ einstall || die
+
+ # this package completely ignores mandir settings
+
+ doman doc/*.1
+ dohtml doc/*.html
+ dodoc doc/*.pod
+ dodoc doc/*.txt
+
+ rm -rf ${D}/usr/doc
+ rm -rf ${D}/usr/html
+ rm -rf ${D}/usr/man
+ rm -rf ${D}/usr/contrib
+ rm -rf ${D}/usr/examples
+
+ insinto /usr/share/doc/${PF}/examples
+ doins examples/*
+ insinto /usr/share/doc/${PF}/contrib
+ doins contrib/*
+
+ use perl && ( \
+ perl-post_perlinfo
+ mytargets="site-perl-install"
+ perl-module_src_install || die
+ )
+
+ use tcltk && ( \
+ mv ${S}/tcl/tclrrd.so ${S}/tcl/tclrrd${PV}.so
+ insinto /usr/lib/tcl${TCL_VER}/tclrrd${PV}
+ doins ${S}/tcl/tclrrd${PV}.so
+ echo "package ifneeded Rrd ${PV} [list load [file join \$$dir .. tclrrd${PV}.so]]" \
+ >> ${D}/usr/lib/tcl${TCL_VER}/tclrrd${PV}/pkgIndex.tcl
+ )
+
+ dodoc CHANGES COPY* CONTR* README TODO
+
+}
+
+
+pkg_preinst() {
+
+ use perl && perl-post_pkg_preinst
+}
+
+pkg_postinst() {
+
+ use perl && perl-post_pkg_postinst
+}
+
+
+pkg_prerm() {
+
+ use perl && perl-post_pkg_prerm
+}
+
+
+pkg_postrm() {
+
+ use perl && perl-post_pkg_postrm
+}
+