summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOlivier Fisette <ribosome@gentoo.org>2004-12-23 21:19:57 +0000
committerOlivier Fisette <ribosome@gentoo.org>2004-12-23 21:19:57 +0000
commitadc87d2313a3231396e37fd7a7a78fca209f0053 (patch)
tree02c6f0c8844f25c6b1ef884d6331eda2fd9c6646
parentBig endian patch by Yuta Satoh <gentoo@0x100.com> from bug #68223, stable on ... (diff)
downloadgentoo-2-adc87d2313a3231396e37fd7a7a78fca209f0053.tar.gz
gentoo-2-adc87d2313a3231396e37fd7a7a78fca209f0053.tar.bz2
gentoo-2-adc87d2313a3231396e37fd7a7a78fca209f0053.zip
Moved from app-sci/cutg to sci-biology/cutg.
-rw-r--r--sci-biology/cutg/ChangeLog43
-rw-r--r--sci-biology/cutg/Manifest6
-rw-r--r--sci-biology/cutg/cutg-143.ebuild40
-rw-r--r--sci-biology/cutg/cutg-144.ebuild40
-rw-r--r--sci-biology/cutg/files/digest-cutg-1431
-rw-r--r--sci-biology/cutg/files/digest-cutg-1441
-rw-r--r--sci-biology/cutg/metadata.xml16
7 files changed, 147 insertions, 0 deletions
diff --git a/sci-biology/cutg/ChangeLog b/sci-biology/cutg/ChangeLog
new file mode 100644
index 000000000000..99f12437ffbd
--- /dev/null
+++ b/sci-biology/cutg/ChangeLog
@@ -0,0 +1,43 @@
+# ChangeLog for app-sci/cutg
+# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/cutg/ChangeLog,v 1.1 2004/12/23 21:19:57 ribosome Exp $
+
+*cutg-143 (23 Dec 2004)
+
+ 23 Dec 2004; Olivier Fisette <ribosome@gentoo.org> +metadata.xml,
+ +cutg-143.ebuild, +cutg-144.ebuild:
+ Moved from app-sci/cutg to sci-biology/cutg.
+
+*cutg-144 (23 Nov 2004)
+
+ 23 Nov 2004; Olivier Fisette <ribosome@gentoo.org> +cutg-144.ebuild:
+ New version.
+
+ 31 Oct 2004; Olivier Fisette <ribosome@gentoo.org> -cutg-142.ebuild,
+ cutg-143.ebuild:
+ Removed old version. Added 143 to x86.
+
+*cutg-143 (29 Sep 2004)
+
+ 29 Sep 2004; Olivier Fisette <ribosome@gentoo.org> -cutg-141.0.ebuild,
+ cutg-142.ebuild, +cutg-143.ebuild:
+ Added 142 to x86. Added new version 142. Removed old version.
+
+*cutg-142 (10 Aug 2004)
+
+ 10 Aug 2004; Olivier Fisette <ribosome@gentoo.org>
+ cutg-141.0.ebuild:
+ Added to x86.
+ cutg-142.ebuild:
+ Updated package.
+
+ 26 Jun 2004; David Holm <dholm@gentoo.org> cutg-141.0.ebuild:
+ Added to ~ppc.
+
+*cutg-141.0 (24 Jun 2004)
+
+ 24 Jun 2004; Olivier Fisette <ribosome@gentoo.org>
+ cutg-141.0.ebuild, metadata.xml :
+ Initial import. Ebuild submitted by Olivier Fisette <ribosome@gentoo.org>.
+ Reference: Gentoo Bugzilla, bug #54322
+
diff --git a/sci-biology/cutg/Manifest b/sci-biology/cutg/Manifest
new file mode 100644
index 000000000000..d81a49b14c73
--- /dev/null
+++ b/sci-biology/cutg/Manifest
@@ -0,0 +1,6 @@
+MD5 e4a9cb7a750c45b5f064e0791a6db623 cutg-143.ebuild 1178
+MD5 2bb31e68b962982d6890f9636a4bac63 ChangeLog 1115
+MD5 d14f29edef39d8d89b39a5787c3d141c metadata.xml 594
+MD5 3e219869a7440d22d1a3e3b6605429f4 cutg-144.ebuild 1179
+MD5 94ad06877dbe9065273a7ee15904c7ec files/digest-cutg-143 63
+MD5 e35ab30eae79e0600feabc028e0db162 files/digest-cutg-144 63
diff --git a/sci-biology/cutg/cutg-143.ebuild b/sci-biology/cutg/cutg-143.ebuild
new file mode 100644
index 000000000000..8dbbe5af181a
--- /dev/null
+++ b/sci-biology/cutg/cutg-143.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/cutg/cutg-143.ebuild,v 1.1 2004/12/23 21:19:57 ribosome Exp $
+
+DESCRIPTION="Codon usage tables calculated from GenBank"
+HOMEPAGE="http://www.kazusa.or.jp/codon/"
+SRC_URI="ftp://ftp.kazusa.or.jp/pub/codon/current/compressed/CUTG.${PV}.tar.gz"
+LICENSE="public-domain"
+
+SLOT="0"
+KEYWORDS="x86 ~ppc"
+IUSE="no-emboss no-rawdb"
+
+S=${WORKDIR}
+
+src_compile() {
+ # Index the database for use with emboss if emboss is installed and
+ # the user did not explicitly request not to index the database.
+ if [ -e /usr/bin/cutgextract ] && ! use no-emboss; then
+ mkdir CODONS
+ einfo "Indexing CUTG for usage with EMBOSS."
+ EMBOSS_DATA=. cutgextract -auto -directory ${S} || die \
+ "Indexing CUTG failed."
+ fi
+}
+
+src_install() {
+ if ! use no-rawdb; then
+ mkdir -p ${D}/usr/share/${PN}
+ mv *.codon *.spsum ${D}/usr/share/${PN}
+ fi
+ dodoc README
+ if [ -e /usr/bin/cutgextract ] && ! use no-emboss; then
+ mkdir -p ${D}/usr/share/EMBOSS/data/CODONS
+ cd CODONS
+ for file in *; do
+ mv ${file} ${D}/usr/share/EMBOSS/data/CODONS
+ done
+ fi
+}
diff --git a/sci-biology/cutg/cutg-144.ebuild b/sci-biology/cutg/cutg-144.ebuild
new file mode 100644
index 000000000000..46b0aaceef27
--- /dev/null
+++ b/sci-biology/cutg/cutg-144.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/cutg/cutg-144.ebuild,v 1.1 2004/12/23 21:19:57 ribosome Exp $
+
+DESCRIPTION="Codon usage tables calculated from GenBank"
+HOMEPAGE="http://www.kazusa.or.jp/codon/"
+SRC_URI="ftp://ftp.kazusa.or.jp/pub/codon/current/compressed/CUTG.${PV}.tar.gz"
+LICENSE="public-domain"
+
+SLOT="0"
+KEYWORDS="~x86 ~ppc"
+IUSE="no-emboss no-rawdb"
+
+S=${WORKDIR}
+
+src_compile() {
+ # Index the database for use with emboss if emboss is installed and
+ # the user did not explicitly request not to index the database.
+ if [ -e /usr/bin/cutgextract ] && ! use no-emboss; then
+ mkdir CODONS
+ einfo "Indexing CUTG for usage with EMBOSS."
+ EMBOSS_DATA=. cutgextract -auto -directory ${S} || die \
+ "Indexing CUTG failed."
+ fi
+}
+
+src_install() {
+ if ! use no-rawdb; then
+ mkdir -p ${D}/usr/share/${PN}
+ mv *.codon *.spsum ${D}/usr/share/${PN}
+ fi
+ dodoc README
+ if [ -e /usr/bin/cutgextract ] && ! use no-emboss; then
+ mkdir -p ${D}/usr/share/EMBOSS/data/CODONS
+ cd CODONS
+ for file in *; do
+ mv ${file} ${D}/usr/share/EMBOSS/data/CODONS
+ done
+ fi
+}
diff --git a/sci-biology/cutg/files/digest-cutg-143 b/sci-biology/cutg/files/digest-cutg-143
new file mode 100644
index 000000000000..55572f7df18e
--- /dev/null
+++ b/sci-biology/cutg/files/digest-cutg-143
@@ -0,0 +1 @@
+MD5 8f3ccb3c31e1383ac987d8e46c9f5610 CUTG.143.tar.gz 117357602
diff --git a/sci-biology/cutg/files/digest-cutg-144 b/sci-biology/cutg/files/digest-cutg-144
new file mode 100644
index 000000000000..f79c6a6dc995
--- /dev/null
+++ b/sci-biology/cutg/files/digest-cutg-144
@@ -0,0 +1 @@
+MD5 2bea63f0124ef7cb360bddeb0465e548 CUTG.144.tar.gz 124856915
diff --git a/sci-biology/cutg/metadata.xml b/sci-biology/cutg/metadata.xml
new file mode 100644
index 000000000000..b89e0f65dac4
--- /dev/null
+++ b/sci-biology/cutg/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>ribosome@gentoo.org</email>
+ <name>Olivier Fisette</name>
+ </maintainer>
+ <herd>sci</herd>
+ <longdescription>
+ Codon usage tables maintained at the Kazusa DNA Research Institute.
+ Codon usage in individual genes has been calculated using the
+ nucleotide sequence data obtained from the GenBank Genetic Sequence
+ Database. The compilation of codon usage is synchronized with each
+ major release of GenBank.
+ </longdescription>
+</pkgmetadata>