summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCaleb Tennis <caleb@gentoo.org>2007-05-10 15:39:08 +0000
committerCaleb Tennis <caleb@gentoo.org>2007-05-10 15:39:08 +0000
commitaad1b542d18266f3efd6524e97b752a620f3144f (patch)
treece44632a6d50435479f7291a0e7e989c0bff11b7
parentversion bump (diff)
downloadgentoo-2-aad1b542d18266f3efd6524e97b752a620f3144f.tar.gz
gentoo-2-aad1b542d18266f3efd6524e97b752a620f3144f.tar.bz2
gentoo-2-aad1b542d18266f3efd6524e97b752a620f3144f.zip
version bump
(Portage version: 2.1.2.4)
-rw-r--r--dev-python/PyQt4/ChangeLog9
-rw-r--r--dev-python/PyQt4/PyQt4-4.2.ebuild57
-rw-r--r--dev-python/PyQt4/files/digest-PyQt4-4.23
3 files changed, 67 insertions, 2 deletions
diff --git a/dev-python/PyQt4/ChangeLog b/dev-python/PyQt4/ChangeLog
index e97998a58601..a72e246a97de 100644
--- a/dev-python/PyQt4/ChangeLog
+++ b/dev-python/PyQt4/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/PyQt4
-# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/PyQt4/ChangeLog,v 1.7 2006/12/20 14:33:50 jokey Exp $
+# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/PyQt4/ChangeLog,v 1.8 2007/05/10 15:39:08 caleb Exp $
+
+*PyQt4-4.2 (10 May 2007)
+
+ 10 May 2007; Caleb Tennis <caleb@gentoo.org> +PyQt4-4.2.ebuild:
+ version bump
*PyQt4-4.1.1 (20 Dec 2006)
diff --git a/dev-python/PyQt4/PyQt4-4.2.ebuild b/dev-python/PyQt4/PyQt4-4.2.ebuild
new file mode 100644
index 000000000000..602b32b3fb2a
--- /dev/null
+++ b/dev-python/PyQt4/PyQt4-4.2.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/PyQt4/PyQt4-4.2.ebuild,v 1.1 2007/05/10 15:39:08 caleb Exp $
+
+inherit distutils
+
+MY_P="PyQt-x11-gpl-${PV}"
+S="${WORKDIR}/${MY_P}"
+
+DESCRIPTION="PyQt is a set of Python bindings for the Qt toolkit."
+HOMEPAGE="http://www.riverbankcomputing.co.uk/pyqt/"
+SRC_URI="http://www.riverbankcomputing.com/Downloads/PyQt4/GPL/${MY_P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug doc examples"
+
+RDEPEND="=x11-libs/qt-4*
+ >=dev-python/sip-4.6"
+DEPEND="${RDEPEND}
+ sys-devel/libtool"
+
+
+src_unpack() {
+ unpack ${A}
+ sed -i -e "s:^[ \t]*check_license():# check_license():" ${S}/configure.py
+ sed -i -e "s:join(qt_dir, \"mkspecs\":join(\"/usr/share/qt4\", \"mkspecs\":g" ${S}/configure.py
+ sed -i -e "s:\"QT_INSTALL_HEADERS\"\: os.path.join(qt_dir, \"include\":\"QT_INSTALL_HEADERS\"\: os.path.join(qt_dir, \"include/qt4\":g" ${S}/configure.py
+ sed -i -e "s:\"QT_INSTALL_LIBS\"\: os.path.join(qt_dir, \"lib\":\"QT_INSTALL_LIBS\"\: os.path.join(qt_dir, \"lib/qt4\":g" ${S}/configure.py
+}
+
+src_compile() {
+ distutils_python_version
+ addpredict ${QTDIR}/etc/settings
+
+ local myconf="-d ${ROOT}/usr/$(get_libdir)/python${PYVER}/site-packages/PyQt4 \
+ -b ${ROOT}/usr/bin \
+ -v ${ROOT}/usr/share/sip" #\
+# -n ${ROOT}/usr/include \
+# -o ${ROOT}/usr/$(get_libdir) \
+# -w -y qt-mt"
+ use debug && myconf="${myconf} -u"
+
+ python configure.py ${myconf}
+ emake || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR=${D} install || die "install failed"
+ dodoc ChangeLog LICENSE NEWS README README.Linux THANKS
+ use doc && dohtml doc/PyQt.html
+ if use examples ; then
+ dodir /usr/share/doc/${PF}/examples
+ cp -r examples/* ${D}/usr/share/doc/${PF}/examples
+ fi
+}
diff --git a/dev-python/PyQt4/files/digest-PyQt4-4.2 b/dev-python/PyQt4/files/digest-PyQt4-4.2
new file mode 100644
index 000000000000..171539a70bd7
--- /dev/null
+++ b/dev-python/PyQt4/files/digest-PyQt4-4.2
@@ -0,0 +1,3 @@
+MD5 af4baa7f7441914f9a527ef3cf788fef PyQt-x11-gpl-4.2.tar.gz 5661258
+RMD160 0dad2de04f0943c0eb7f10a7f97e3e76d8f8279f PyQt-x11-gpl-4.2.tar.gz 5661258
+SHA256 6fa8a853a66ae500f36629793e7d4c54896c7ccf6337c2b90ea0175b28aa7ae6 PyQt-x11-gpl-4.2.tar.gz 5661258