summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2008-03-03 15:48:58 +0000
committerJeroen Roovers <jer@gentoo.org>2008-03-03 15:48:58 +0000
commita3879edce06f1fc7cf756b845b23752464151e5b (patch)
treee7bdb4247999726da7ae1f843566cf660db0c836
parentbump to latest beta (diff)
downloadgentoo-2-a3879edce06f1fc7cf756b845b23752464151e5b.tar.gz
gentoo-2-a3879edce06f1fc7cf756b845b23752464151e5b.tar.bz2
gentoo-2-a3879edce06f1fc7cf756b845b23752464151e5b.zip
Version bump with removed mailwrapper magic (bug #158501). Marked ~hppa.
(Portage version: 2.1.4.4)
-rw-r--r--net-mail/mailutils/ChangeLog9
-rw-r--r--net-mail/mailutils/mailutils-0.6-r3.ebuild24
-rw-r--r--net-mail/mailutils/mailutils-1.2.ebuild77
3 files changed, 95 insertions, 15 deletions
diff --git a/net-mail/mailutils/ChangeLog b/net-mail/mailutils/ChangeLog
index 16317f493c9f..2efaba2aba00 100644
--- a/net-mail/mailutils/ChangeLog
+++ b/net-mail/mailutils/ChangeLog
@@ -1,9 +1,12 @@
# ChangeLog for net-mail/mailutils
# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/mailutils/ChangeLog,v 1.32 2008/03/03 04:13:04 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/mailutils/ChangeLog,v 1.33 2008/03/03 15:48:58 jer Exp $
- 03 Mar 2008; Jeroen Roovers <jer@gentoo.org> ChangeLog:
- Fix name in ChangeLog entry.
+*mailutils-1.2 (03 Mar 2008)
+
+ 03 Mar 2008; Jeroen Roovers <jer@gentoo.org> mailutils-0.6-r3.ebuild,
+ +mailutils-1.2.ebuild:
+ Version bump with removed mailwrapper magic (bug #158501). Marked ~hppa.
27 Jan 2007; Olivier Crête <tester@gentoo.org> mailutils-0.6-r3.ebuild:
Added ~amd64 keyword for bug #158295
diff --git a/net-mail/mailutils/mailutils-0.6-r3.ebuild b/net-mail/mailutils/mailutils-0.6-r3.ebuild
index bee17d2c8dfa..00290c80b93f 100644
--- a/net-mail/mailutils/mailutils-0.6-r3.ebuild
+++ b/net-mail/mailutils/mailutils-0.6-r3.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/mailutils/mailutils-0.6-r3.ebuild,v 1.6 2007/01/27 04:36:03 tester Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/mailutils/mailutils-0.6-r3.ebuild,v 1.7 2008/03/03 15:48:58 jer Exp $
inherit eutils
DESCRIPTION="A useful collection of mail servers, clients, and filters."
@@ -38,16 +38,16 @@ pkg_setup() {
}
src_unpack() {
unpack ${A}
- cd ${S}
+ cd "${S}"
- epatch ${FILESDIR}/${P}-mh-Makefile.in.patch
- epatch ${FILESDIR}/${PN}-IDEF0954-IDEF0955.patch
- epatch ${FILESDIR}/${PN}-IDEF0956.patch
- epatch ${FILESDIR}/${PN}-IDEF0957.patch
- epatch ${FILESDIR}/${PN}-getline.diff
- epatch ${FILESDIR}/${PN}-SQLinjection.patch
- epatch ${FILESDIR}/${P}-imap4d-format-string.patch
- epatch ${FILESDIR}/${P}-imap4d-gcc4.0-ftbfs.patch
+ epatch "${FILESDIR}"/${P}-mh-Makefile.in.patch
+ epatch "${FILESDIR}"/${PN}-IDEF0954-IDEF0955.patch
+ epatch "${FILESDIR}"/${PN}-IDEF0956.patch
+ epatch "${FILESDIR}"/${PN}-IDEF0957.patch
+ epatch "${FILESDIR}"/${PN}-getline.diff
+ epatch "${FILESDIR}"/${PN}-SQLinjection.patch
+ epatch "${FILESDIR}"/${P}-imap4d-format-string.patch
+ epatch "${FILESDIR}"/${P}-imap4d-gcc4.0-ftbfs.patch
}
src_compile() {
@@ -92,7 +92,7 @@ src_compile() {
}
src_install() {
- make DESTDIR=${D} install || die
+ make DESTDIR="${D}" install || die
# mail.rc stolen from mailx, resolve bug #37302.
insinto /etc
doins "${FILESDIR}/mail.rc"
diff --git a/net-mail/mailutils/mailutils-1.2.ebuild b/net-mail/mailutils/mailutils-1.2.ebuild
new file mode 100644
index 000000000000..34a85b23e485
--- /dev/null
+++ b/net-mail/mailutils/mailutils-1.2.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/mailutils/mailutils-1.2.ebuild,v 1.1 2008/03/03 15:48:58 jer Exp $
+
+inherit eutils
+DESCRIPTION="A useful collection of mail servers, clients, and filters."
+HOMEPAGE="http://www.gnu.org/software/mailutils/mailutils.html"
+SRC_URI="http://ftp.gnu.org/gnu/mailutils/${P}.tar.bz2"
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~sparc ~x86"
+IUSE="nls pam mysql postgres gdbm"
+PROVIDE="virtual/mailx"
+DEPEND="!virtual/mailx
+ !mail-client/nmh
+ !mail-client/elm
+ dev-scheme/guile
+ gdbm? ( sys-libs/gdbm )
+ mysql? ( virtual/mysql )
+ postgres? ( dev-db/libpq )
+ nls? ( sys-devel/gettext )
+ virtual/mta"
+
+pkg_setup() {
+ # Default to MySQL if USE="mysql postgres', bug #58162.
+ if use mysql && use postgres; then
+ echo
+ ewarn "You have both 'mysql' and 'postgres' in your USE flags."
+ ewarn "Portage will build this package with MySQL support."
+ echo
+ ewarn "If this is not what you want, then change your"
+ ewarn "USE flags and emerge this package again."
+ fi
+}
+
+src_compile() {
+
+ local myconf="--localstatedir=/var --sharedstatedir=/var --enable-mh-utils"
+
+ # bug in autoconf logic treats both --with and --without as set,
+ # so we cannot do use_with
+ # use mysql && myconf="${myconf} --with-mysql"
+ # use postgres && myconf="${myconf} --with-postgres"
+ if use mysql && use postgres; then
+ einfo "build with MySQL support."
+ myconf="${myconf} --with-mysql"
+ elif use mysql; then
+ einfo "build with MySQL support."
+ myconf="${myconf} --with-mysql"
+ elif use postgres; then
+ einfo "build with PotsgreSQL support."
+ myconf="${myconf} --with-postgres"
+ fi
+
+ # do not disable-sendmail for postfix user, bug #44249.
+ has_postfix=$(best_version mail-mta/postfix)
+ has_postfix=${has_postfix%-[0-9]*}
+ has_postfix=${has_postfix##*\/}
+
+ if [ "$has_postfix" == "postfix" ]; then
+ einfo "postfix detected - enabling sendmail"
+ else
+ myconf="${myconf} --disable-sendmail"
+ einfo "disabling sendmail"
+ fi
+
+ myconf="${myconf} $(use_enable nls) $(use_enable pam) $(use_enable gdbm)"
+ econf ${myconf} || die "configure failed"
+ emake || die "compile failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die
+ # mail.rc stolen from mailx, resolve bug #37302.
+ insinto /etc
+ doins "${FILESDIR}/mail.rc"
+}