summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-07-30 03:53:31 +0000
committerMike Frysinger <vapier@gentoo.org>2004-07-30 03:53:31 +0000
commita1efb5fe6a4a1a29077fbfae7bbe713011cabea4 (patch)
tree4d58fb024ce54bcaf9bafdb7c4f807667d58d07c
parentStable on ppc. (Manifest recommit) (diff)
downloadgentoo-2-a1efb5fe6a4a1a29077fbfae7bbe713011cabea4.tar.gz
gentoo-2-a1efb5fe6a4a1a29077fbfae7bbe713011cabea4.tar.bz2
gentoo-2-a1efb5fe6a4a1a29077fbfae7bbe713011cabea4.zip
ver bump for uclibc
-rw-r--r--dev-util/strace/files/digest-strace-4.5.61
-rw-r--r--dev-util/strace/strace-4.5.6.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/dev-util/strace/files/digest-strace-4.5.6 b/dev-util/strace/files/digest-strace-4.5.6
new file mode 100644
index 000000000000..66d5dd68a63a
--- /dev/null
+++ b/dev-util/strace/files/digest-strace-4.5.6
@@ -0,0 +1 @@
+MD5 2dd9d23430957a7ee0221efb28c66d1e strace-4.5.6.tar.bz2 407633
diff --git a/dev-util/strace/strace-4.5.6.ebuild b/dev-util/strace/strace-4.5.6.ebuild
new file mode 100644
index 000000000000..90c30747cfd6
--- /dev/null
+++ b/dev-util/strace/strace-4.5.6.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/strace/strace-4.5.6.ebuild,v 1.1 2004/07/30 03:53:31 vapier Exp $
+
+inherit flag-o-matic gnuconfig
+
+DESCRIPTION="A useful diagnostic, instructional, and debugging tool"
+HOMEPAGE="http://sourceforge.net/projects/strace/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~sparc ~mips ~alpha ~arm ~hppa ~amd64 ~ia64 ~ppc64"
+IUSE=""
+
+DEPEND="virtual/libc"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ gnuconfig_update
+
+ # Compile fails with -O3 on sparc but works on x86
+ if [ "${ARCH}" == "sparc" -o "${ARCH}" == "" ]; then
+ replace-flags -O[3-9] -O2
+ fi
+ filter-lfs-flags
+}
+
+src_install() {
+ # Can't use make install because it is stupid and
+ # doesn't make leading directories before trying to
+ # install. Thus, one would have to make /usr/bin
+ # and /usr/man/man1 (at least).
+ # So, we do it by hand.
+ doman strace.1
+ dobin strace strace-graph || die
+ dodoc ChangeLog CREDITS NEWS PORTING README* TODO
+}