summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2013-04-05 09:40:16 +0000
committerTim Harder <radhermit@gentoo.org>2013-04-05 09:40:16 +0000
commita026c0e22d5d35228ef5177d96b8190359e0cc6a (patch)
tree2e6193983145f17c57267059ccc16517ec025d33
parentUnmask www-client/opera-12.15. (diff)
downloadgentoo-2-a026c0e22d5d35228ef5177d96b8190359e0cc6a.tar.gz
gentoo-2-a026c0e22d5d35228ef5177d96b8190359e0cc6a.tar.bz2
gentoo-2-a026c0e22d5d35228ef5177d96b8190359e0cc6a.zip
Version bump. Add debug, openmp, and sse2 use flags.
(Portage version: 2.2.0_alpha171/cvs/Linux x86_64, signed Manifest commit with key 4AB3E85B4F064CA3)
-rw-r--r--media-gfx/pngquant/ChangeLog7
-rw-r--r--media-gfx/pngquant/pngquant-1.8.3.ebuild53
2 files changed, 59 insertions, 1 deletions
diff --git a/media-gfx/pngquant/ChangeLog b/media-gfx/pngquant/ChangeLog
index bcf3db2c82ce..e16496c1f2ce 100644
--- a/media-gfx/pngquant/ChangeLog
+++ b/media-gfx/pngquant/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-gfx/pngquant
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/pngquant/ChangeLog,v 1.2 2013/02/21 09:55:42 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/pngquant/ChangeLog,v 1.3 2013/04/05 09:40:16 radhermit Exp $
+
+*pngquant-1.8.3 (05 Apr 2013)
+
+ 05 Apr 2013; Tim Harder <radhermit@gentoo.org> +pngquant-1.8.3.ebuild:
+ Version bump. Add debug, openmp, and sse2 use flags.
21 Feb 2013; Samuli Suominen <ssuominen@gentoo.org> pngquant-1.8.2.ebuild:
Change license from own "pngquant" to new separate "rwpng" (+ "HPND")
diff --git a/media-gfx/pngquant/pngquant-1.8.3.ebuild b/media-gfx/pngquant/pngquant-1.8.3.ebuild
new file mode 100644
index 000000000000..af7ccaa3129e
--- /dev/null
+++ b/media-gfx/pngquant/pngquant-1.8.3.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/pngquant/pngquant-1.8.3.ebuild,v 1.1 2013/04/05 09:40:16 radhermit Exp $
+
+EAPI=5
+inherit toolchain-funcs flag-o-matic
+
+DESCRIPTION="a command-line utility for converting 24/32-bit PNG images to paletted (8-bit) PNGs"
+HOMEPAGE="http://pngquant.org/"
+SRC_URI="http://pngquant.org/${P}-src.tar.bz2"
+
+LICENSE="HPND rwpng"
+SLOT=0
+KEYWORDS="~amd64 ~x86"
+IUSE="debug openmp sse2"
+
+RDEPEND="media-libs/libpng:0=
+ sys-libs/zlib:="
+DEPEND=${RDEPEND}
+
+pkg_pretend() {
+ if use openmp ; then
+ tc-has-openmp || die "Please switch to an openmp compatible compiler"
+ fi
+}
+
+src_prepare() {
+ # Failure in upstream logic. Otherwise we lose the -I and -L flags
+ # from Makefile.
+ sed -i \
+ -e 's:CFLAGS ?=:CFLAGS +=:' \
+ -e 's:LDFLAGS ?=:LDFLAGS +=:' \
+ Makefile || die
+}
+
+src_compile() {
+ use debug || append-cflags -DNDEBUG
+ use sse2 && append-cflags -DUSE_SSE=1
+
+ local openmp
+ if use openmp ; then
+ append-cflags -fopenmp
+ openmp="-lgomp"
+ fi
+
+ tc-export CC
+ emake CFLAGSOPT="" OPENMPFLAGS="${openmp}"
+}
+
+src_install() {
+ emake CFLAGSOPT="" DESTDIR="${D}" PREFIX=/usr install
+ dodoc CHANGELOG README.md
+}