summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2011-04-09 23:48:26 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2011-04-09 23:48:26 +0000
commit9f384889d7452b716a6894cc0aa8c2a8a96e96ef (patch)
tree68e9cd492acd26aca49725943b47324da8a851b5
parentBug #358847 - Remove virtual/portage PROVIDE since it's been replaced by (diff)
downloadgentoo-2-9f384889d7452b716a6894cc0aa8c2a8a96e96ef.tar.gz
gentoo-2-9f384889d7452b716a6894cc0aa8c2a8a96e96ef.tar.bz2
gentoo-2-9f384889d7452b716a6894cc0aa8c2a8a96e96ef.zip
Bug #361429: Use pkg-config libudev to get libudev libraries, so that -lrt is brought in for linking correctly with new udev.
(Portage version: 2.2.0_alpha26/cvs/Linux x86_64)
-rw-r--r--sys-fs/lvm2/ChangeLog7
-rw-r--r--sys-fs/lvm2/files/lvm2-2.02.84-udev-pkgconfig.patch25
-rw-r--r--sys-fs/lvm2/lvm2-2.02.84.ebuild4
3 files changed, 34 insertions, 2 deletions
diff --git a/sys-fs/lvm2/ChangeLog b/sys-fs/lvm2/ChangeLog
index 0955846f06e6..85f3600b78cf 100644
--- a/sys-fs/lvm2/ChangeLog
+++ b/sys-fs/lvm2/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-fs/lvm2
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/lvm2/ChangeLog,v 1.242 2011/02/09 20:38:39 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/lvm2/ChangeLog,v 1.243 2011/04/09 23:48:26 robbat2 Exp $
+
+ 09 Apr 2011; Robin H. Johnson <robbat2@gentoo.org> lvm2-2.02.84.ebuild,
+ +files/lvm2-2.02.84-udev-pkgconfig.patch:
+ Bug #361429: Use pkg-config libudev to get libudev libraries, so that -lrt is
+ brought in for linking correctly with new udev.
*lvm2-2.02.84 (09 Feb 2011)
diff --git a/sys-fs/lvm2/files/lvm2-2.02.84-udev-pkgconfig.patch b/sys-fs/lvm2/files/lvm2-2.02.84-udev-pkgconfig.patch
new file mode 100644
index 000000000000..d371ddd343f6
--- /dev/null
+++ b/sys-fs/lvm2/files/lvm2-2.02.84-udev-pkgconfig.patch
@@ -0,0 +1,25 @@
+diff -Nuar LVM2.2.02.84.orig/configure.in LVM2.2.02.84/configure.in
+--- LVM2.2.02.84.orig/configure.in 2011-02-04 22:17:54.000000000 +0000
++++ LVM2.2.02.84/configure.in 2011-04-09 23:42:27.134617541 +0000
+@@ -803,9 +803,18 @@
+ AC_MSG_RESULT($UDEV_SYNC)
+
+ if test x$UDEV_SYNC = xyes; then
+- AC_CHECK_LIB(udev, udev_queue_get_udev_is_active,
+- [UDEV_PC="libudev"; UDEV_LIBS="-ludev"],
+- [AC_MSG_ERROR([bailing out... libudev library is required])])
++ if test x$PKGCONFIG_INIT != x1; then
++ pkg_config_init
++ fi
++ PKG_CHECK_MODULES(UDEV, libudev, [UDEV_PC="libudev" HAVE_UDEV=yes],
++ [NOTFOUND=0
++ AC_CHECK_HEADERS(libudev.h,,$bailout)
++ check_lib_no_libs udev udev_queue_get_udev_is_active
++ if test $NOTFOUND = 0; then
++ AC_CHECK_LIB(udev, udev_queue_get_udev_is_active,
++ [UDEV_PC="libudev"; UDEV_LIBS="-ludev"],
++ [AC_MSG_ERROR([bailing out... libudev library is required])])
++ fi])
+ AC_DEFINE([UDEV_SYNC_SUPPORT], 1, [Define to 1 to enable synchronisation with udev processing.])
+ fi
+
diff --git a/sys-fs/lvm2/lvm2-2.02.84.ebuild b/sys-fs/lvm2/lvm2-2.02.84.ebuild
index 4f88c4e81074..e15da1994a4a 100644
--- a/sys-fs/lvm2/lvm2-2.02.84.ebuild
+++ b/sys-fs/lvm2/lvm2-2.02.84.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/lvm2/lvm2-2.02.84.ebuild,v 1.1 2011/02/09 20:38:39 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/lvm2/lvm2-2.02.84.ebuild,v 1.2 2011/04/09 23:48:26 robbat2 Exp $
EAPI=2
inherit eutils multilib toolchain-funcs autotools linux-info
@@ -83,6 +83,8 @@ src_prepare() {
epatch "${FILESDIR}"/${PN}-2.02.70-asneeded.patch
# bug 332905
epatch "${FILESDIR}"/${PN}-2.02.72-dynamic-static-ldflags.patch
+ # bug 361429
+ epatch "${FILESDIR}"/${PN}-2.02.84-udev-pkgconfig.patch
# Merged upstream
#epatch "${FILESDIR}"/${PN}-2.02.73-asneeded.patch