summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2015-05-27 00:48:43 +0000
committerAnthony G. Basile <blueness@gentoo.org>2015-05-27 00:48:43 +0000
commit915d044bd950a3be642059eb4f302e0f00d8ff9a (patch)
treee8c101163bea67bb34453219032631022c2a631f
parentUpdate bitcoincore eclass. (diff)
downloadgentoo-2-915d044bd950a3be642059eb4f302e0f00d8ff9a.tar.gz
gentoo-2-915d044bd950a3be642059eb4f302e0f00d8ff9a.tar.bz2
gentoo-2-915d044bd950a3be642059eb4f302e0f00d8ff9a.zip
Version bump.
(Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key 0xF52D4BBA)
-rw-r--r--dev-util/bitcoin-tx/ChangeLog8
-rw-r--r--dev-util/bitcoin-tx/bitcoin-tx-0.10.1.ebuild26
2 files changed, 33 insertions, 1 deletions
diff --git a/dev-util/bitcoin-tx/ChangeLog b/dev-util/bitcoin-tx/ChangeLog
index 6f8798aba8dd..78f6b2eda7ec 100644
--- a/dev-util/bitcoin-tx/ChangeLog
+++ b/dev-util/bitcoin-tx/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-util/bitcoin-tx
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/bitcoin-tx/ChangeLog,v 1.3 2015/03/14 19:19:16 blueness Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/bitcoin-tx/ChangeLog,v 1.4 2015/05/27 00:48:43 blueness Exp $
+
+*bitcoin-tx-0.10.1 (27 May 2015)
+
+ 27 May 2015; Anthony G. Basile <blueness@gentoo.org>
+ +bitcoin-tx-0.10.1.ebuild:
+ Version bump.
14 Mar 2015; Anthony G. Basile <blueness@gentoo.org> bitcoin-tx-0.10.0.ebuild:
Update BITCOINCORE_LJR_DATE. Keyword ~arm64 ~amd64-linux ~x86-linux
diff --git a/dev-util/bitcoin-tx/bitcoin-tx-0.10.1.ebuild b/dev-util/bitcoin-tx/bitcoin-tx-0.10.1.ebuild
new file mode 100644
index 000000000000..86eab0fd6e5c
--- /dev/null
+++ b/dev-util/bitcoin-tx/bitcoin-tx-0.10.1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 2010-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/bitcoin-tx/bitcoin-tx-0.10.1.ebuild,v 1.1 2015/05/27 00:48:43 blueness Exp $
+
+EAPI=5
+
+BITCOINCORE_COMMITHASH="d8ac90184254fea3a7f4991fd0529dfbd750aea0"
+BITCOINCORE_LJR_DATE="20150428"
+BITCOINCORE_IUSE=""
+BITCOINCORE_NEED_LIBSECP256K1=1
+inherit bitcoincore
+
+DESCRIPTION="Command-line Bitcoin transaction tool"
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86 ~amd64-linux ~x86-linux"
+
+src_prepare() {
+ bitcoincore_prepare
+ bitcoincore_autoreconf
+}
+
+src_configure() {
+ bitcoincore_conf \
+ --enable-util-tx
+}