summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey Popov <pinkbyte@gentoo.org>2012-09-07 12:10:52 +0000
committerSergey Popov <pinkbyte@gentoo.org>2012-09-07 12:10:52 +0000
commit8c298ae8cd9f03ed739e9c37e3a003b5d578d073 (patch)
tree74885fac21d4625f94c9a89f88f1a49d00027bdb
parentAdd missing dependencies wrt bug #430804. (diff)
downloadgentoo-2-8c298ae8cd9f03ed739e9c37e3a003b5d578d073.tar.gz
gentoo-2-8c298ae8cd9f03ed739e9c37e3a003b5d578d073.tar.bz2
gentoo-2-8c298ae8cd9f03ed739e9c37e3a003b5d578d073.zip
Version
(Portage version: 2.2.0_alpha124/cvs/Linux x86_64)
-rw-r--r--net-analyzer/fail2ban/ChangeLog8
-rw-r--r--net-analyzer/fail2ban/fail2ban-0.8.7.1.ebuild65
2 files changed, 72 insertions, 1 deletions
diff --git a/net-analyzer/fail2ban/ChangeLog b/net-analyzer/fail2ban/ChangeLog
index fa10b974bcae..fccb29c7140a 100644
--- a/net-analyzer/fail2ban/ChangeLog
+++ b/net-analyzer/fail2ban/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-analyzer/fail2ban
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/fail2ban/ChangeLog,v 1.85 2012/09/07 12:01:41 pinkbyte Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/fail2ban/ChangeLog,v 1.86 2012/09/07 12:10:52 pinkbyte Exp $
+
+*fail2ban-0.8.7.1 (07 Sep 2012)
+
+ 07 Sep 2012; Sergey Popov <pinkbyte@gentoo.org> +fail2ban-0.8.7.1.ebuild:
+ Version bump wrt bug #430304. Thanks to Michael Mair-Keimberger and Leho
+ Kraav
07 Sep 2012; Sergey Popov <pinkbyte@gentoo.org> fail2ban-0.8.6-r1.ebuild:
Use vcs-snapshot eclass
diff --git a/net-analyzer/fail2ban/fail2ban-0.8.7.1.ebuild b/net-analyzer/fail2ban/fail2ban-0.8.7.1.ebuild
new file mode 100644
index 000000000000..9cdcff03ae42
--- /dev/null
+++ b/net-analyzer/fail2ban/fail2ban-0.8.7.1.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/fail2ban/fail2ban-0.8.7.1.ebuild,v 1.1 2012/09/07 12:10:52 pinkbyte Exp $
+
+EAPI="4"
+PYTHON_DEPEND="2"
+
+inherit distutils eutils vcs-snapshot
+
+DESCRIPTION="Bans IP that make too many password failures"
+HOMEPAGE="http://www.fail2ban.org/"
+SRC_URI="https://github.com/${PN}/${PN}/tarball/${PV} -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="selinux"
+
+DEPEND="selinux? ( sec-policy/selinux-fail2ban )"
+RDEPEND="net-misc/whois
+ virtual/mta
+ virtual/logger
+ net-firewall/iptables
+ selinux? ( sec-policy/selinux-fail2ban )"
+
+pkg_setup() {
+ python_set_active_version 2
+ python_pkg_setup
+}
+
+src_install() {
+ distutils_src_install
+
+ newconfd files/gentoo-confd fail2ban
+ newinitd files/gentoo-initd fail2ban
+ dodoc ChangeLog README TODO
+ doman man/*.1
+
+ # Use INSTALL_MASK if you do not want to touch /etc/logrotate.d.
+ # See http://thread.gmane.org/gmane.linux.gentoo.devel/35675
+ insinto /etc/logrotate.d
+ newins "${FILESDIR}"/${PN}-logrotate ${PN}
+}
+
+pkg_preinst() {
+ has_version "<${CATEGORY}/${PN}-0.7"
+ previous_less_than_0_7=$?
+}
+
+pkg_postinst() {
+ distutils_pkg_postinst
+
+ if [[ $previous_less_than_0_7 = 0 ]] ; then
+ elog
+ elog "Configuration files are now in /etc/fail2ban/"
+ elog "You probably have to manually update your configuration"
+ elog "files before restarting Fail2ban!"
+ elog
+ elog "Fail2ban is not installed under /usr/lib anymore. The"
+ elog "new location is under /usr/share."
+ elog
+ elog "You are upgrading from version 0.6.x, please see:"
+ elog "http://www.fail2ban.org/wiki/index.php/HOWTO_Upgrade_from_0.6_to_0.8"
+ fi
+}