summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2012-07-19 11:49:38 +0000
committerAlfredo Tupone <tupone@gentoo.org>2012-07-19 11:49:38 +0000
commit82329069eb2fb31d6ffe140e33877c37c141a952 (patch)
treee73a7aa4b6c79c34392bdbae728842ac1740e3b6
parentsci-biology/vcftools: Version BUmp, fix build system (diff)
downloadgentoo-2-82329069eb2fb31d6ffe140e33877c37c141a952.tar.gz
gentoo-2-82329069eb2fb31d6ffe140e33877c37c141a952.tar.bz2
gentoo-2-82329069eb2fb31d6ffe140e33877c37c141a952.zip
Build with gcc-4.7 Bug #425286
(Portage version: 2.1.11.8/cvs/Linux i686)
-rw-r--r--games-action/rafkill/ChangeLog8
-rw-r--r--games-action/rafkill/files/rafkill-1.2.3-gcc47.patch11
-rw-r--r--games-action/rafkill/rafkill-1.2.3.ebuild5
3 files changed, 20 insertions, 4 deletions
diff --git a/games-action/rafkill/ChangeLog b/games-action/rafkill/ChangeLog
index 62888d90c1ad..262edd845a7f 100644
--- a/games-action/rafkill/ChangeLog
+++ b/games-action/rafkill/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-action/rafkill
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/rafkill/ChangeLog,v 1.10 2011/08/07 17:06:40 armin76 Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-action/rafkill/ChangeLog,v 1.11 2012/07/19 11:49:38 tupone Exp $
+
+ 19 Jul 2012; Tupone Alfredo <tupone@gentoo.org> rafkill-1.2.3.ebuild,
+ +files/rafkill-1.2.3-gcc47.patch:
+ Build with gcc-4.7 Bug #425286 by flameeyes@gentoo.org
07 Aug 2011; Raúl Porcel <armin76@gentoo.org> rafkill-1.2.3.ebuild:
Drop alpha keyword
diff --git a/games-action/rafkill/files/rafkill-1.2.3-gcc47.patch b/games-action/rafkill/files/rafkill-1.2.3-gcc47.patch
new file mode 100644
index 000000000000..1a06ae67e94c
--- /dev/null
+++ b/games-action/rafkill/files/rafkill-1.2.3-gcc47.patch
@@ -0,0 +1,11 @@
+--- src/system.cpp.old 2012-07-19 13:37:12.324303303 +0200
++++ src/system.cpp 2012-07-19 13:38:05.451584273 +0200
+@@ -2,6 +2,8 @@
+ #include <strings.h>
+ #include <string>
+ #include <cstring>
++#include <unistd.h>
++#include <sys/types.h>
+
+ #ifdef WINDOWS
+ static const char * type(){
diff --git a/games-action/rafkill/rafkill-1.2.3.ebuild b/games-action/rafkill/rafkill-1.2.3.ebuild
index d96a014868c0..c453d2bb4011 100644
--- a/games-action/rafkill/rafkill-1.2.3.ebuild
+++ b/games-action/rafkill/rafkill-1.2.3.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/rafkill/rafkill-1.2.3.ebuild,v 1.9 2011/08/07 17:06:40 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-action/rafkill/rafkill-1.2.3.ebuild,v 1.10 2012/07/19 11:49:38 tupone Exp $
EAPI=2
inherit eutils scons-utils games
@@ -22,6 +22,7 @@ src_prepare() {
epatch \
"${FILESDIR}"/${P}-build.patch \
"${FILESDIR}"/${P}-gcc43.patch \
+ "${FILESDIR}"/${P}-gcc47.patch \
"${FILESDIR}"/${P}-ldflags.patch
sed -i \
-e "/^#define INSTALL_DIR/s:\.:${GAMES_DATADIR}:" \