summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrad Teaford Cowan <bcowan@gentoo.org>2002-12-27 03:12:47 +0000
committerBrad Teaford Cowan <bcowan@gentoo.org>2002-12-27 03:12:47 +0000
commit81e034ca60b44405c0c3a54e17c9e2c267befa5f (patch)
treede958d51e3559d1ae9fc5ad6e0aa394696a66a2e
parentVersion bump. (diff)
downloadgentoo-2-81e034ca60b44405c0c3a54e17c9e2c267befa5f.tar.gz
gentoo-2-81e034ca60b44405c0c3a54e17c9e2c267befa5f.tar.bz2
gentoo-2-81e034ca60b44405c0c3a54e17c9e2c267befa5f.zip
version bump
-rw-r--r--app-misc/mc/ChangeLog8
-rw-r--r--app-misc/mc/files/digest-mc-4.6.0_pre21
-rw-r--r--app-misc/mc/mc-4.6.0_pre2.ebuild73
3 files changed, 81 insertions, 1 deletions
diff --git a/app-misc/mc/ChangeLog b/app-misc/mc/ChangeLog
index 0fc269d708c7..32af470e2812 100644
--- a/app-misc/mc/ChangeLog
+++ b/app-misc/mc/ChangeLog
@@ -1,7 +1,13 @@
# ChangeLog for app-misc/mc
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/app-misc/mc/ChangeLog,v 1.3 2002/12/17 19:16:26 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/mc/ChangeLog,v 1.4 2002/12/27 03:12:47 bcowan Exp $
+*mc-4.6.0_pre2 (26 Dec 2002)
+
+ 26 Dec 2002; Brad Cowan <bcowan@gentoo.org> mc-4.6.0_pre2.ebuild,
+ files/digest-mc-4.6.0_pre2:
+ Version bump with many bugfixes and feature additions.
+
06 Dec 2002; Rodney Rees <manson@gentoo.org> : changed sparc ~sparc keywords
*mc-4.5.55-r7 (06 Dec 2002)
diff --git a/app-misc/mc/files/digest-mc-4.6.0_pre2 b/app-misc/mc/files/digest-mc-4.6.0_pre2
new file mode 100644
index 000000000000..a608fb2f1be7
--- /dev/null
+++ b/app-misc/mc/files/digest-mc-4.6.0_pre2
@@ -0,0 +1 @@
+MD5 72832bdd6969c3ff5a73afeebc8388b7 mc-4.6.0-pre2.tar.gz 3708746
diff --git a/app-misc/mc/mc-4.6.0_pre2.ebuild b/app-misc/mc/mc-4.6.0_pre2.ebuild
new file mode 100644
index 000000000000..5c99f3490e81
--- /dev/null
+++ b/app-misc/mc/mc-4.6.0_pre2.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/mc/mc-4.6.0_pre2.ebuild,v 1.1 2002/12/27 03:12:47 bcowan Exp $
+
+IUSE="gpm nls samba ncurses X slang"
+
+MY_P=${P/_/-}
+S=${WORKDIR}/${MY_P}
+
+DESCRIPTION="GNU Midnight Commander cli-based file manager"
+
+HOMEPAGE="http://www.ibiblio.org/mc/"
+SRC_URI="http://www.ibiblio.org/pub/Linux/utils/file/managers/${PN}/${MY_P}.tar.gz"
+
+DEPEND=">=sys-apps/e2fsprogs-1.19
+ ncurses? ( >=sys-libs/ncurses-5.2-r5 )
+ =dev-libs/glib-2*
+ >=sys-libs/pam-0.72
+ gpm? ( >=sys-libs/gpm-1.19.3 )
+ slang? ( >=sys-libs/slang-1.4.2 )
+ samba? ( >=net-fs/samba-2.2.3a-r1 )
+ X? ( virtual/x11 )"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86"
+
+src_compile() {
+ local myconf=""
+
+ if ! use slang && ! use ncurses
+ then
+ myconf="${myconf} --with-screen=mcslang"
+ elif
+ use ncurses && ! use slang
+ then
+ myconf="${myconf} --with-screen=ncurses"
+ else
+ use slang && myconf="${myconf} --with-screen=slang"
+ fi
+
+ use gpm \
+ && myconf="${myconf} --with-gpm-mouse" \
+ || myconf="${myconf} --without-gpm-mouse"
+
+ use nls \
+ && myconf="${myconf} --with-included-gettext" \
+ || myconf="${myconf} --disable-nls"
+
+ use X \
+ && myconf="${myconf} --with-x" \
+ || myconf="${myconf} --without-x"
+
+ use samba \
+ && myconf="${myconf} --with-samba --with-configdir=/etc/samba
+ --with-codepagedir=/var/lib/samba/codepages" \
+ || myconf="${myconf} --without-samba"
+
+ econf \
+ --with-vfs \
+ --with-gnu-ld \
+ --with-ext2undel \
+ --with-edit \
+ ${myconf} || die
+ emake || die
+}
+
+src_install() {
+ einstall
+
+ dodoc ABOUT-NLS COPYING* ChangeLog AUTHORS MAINTAINERS FAQ INSTALL* NEWS README*
+}
+