summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2013-06-25 17:07:11 +0000
committerPacho Ramos <pacho@gentoo.org>2013-06-25 17:07:11 +0000
commit8079813d2c9532bcd9c02ee644117a79ab7fcee9 (patch)
treeaa05621c987a6cbac1b4f198ecf828fd49c1ebda
parentdrop debug useflag that only adds -g and doesnt (diff)
downloadgentoo-2-8079813d2c9532bcd9c02ee644117a79ab7fcee9.tar.gz
gentoo-2-8079813d2c9532bcd9c02ee644117a79ab7fcee9.tar.bz2
gentoo-2-8079813d2c9532bcd9c02ee644117a79ab7fcee9.zip
Fix 'ip' path (#474700 by Lorand Kelemen)
(Portage version: 2.1.12.10/cvs/Linux x86_64, signed Manifest commit with key A188FBD4)
-rw-r--r--net-misc/htbinit/ChangeLog7
-rw-r--r--net-misc/htbinit/htbinit-0.8.5-r6.ebuild61
2 files changed, 67 insertions, 1 deletions
diff --git a/net-misc/htbinit/ChangeLog b/net-misc/htbinit/ChangeLog
index 7a8a59f157d8..29bb538c069a 100644
--- a/net-misc/htbinit/ChangeLog
+++ b/net-misc/htbinit/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-misc/htbinit
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/htbinit/ChangeLog,v 1.22 2013/05/04 13:40:21 tomwij Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/htbinit/ChangeLog,v 1.23 2013/06/25 17:07:11 pacho Exp $
+
+*htbinit-0.8.5-r6 (25 Jun 2013)
+
+ 25 Jun 2013; Pacho Ramos <pacho@gentoo.org> +htbinit-0.8.5-r6.ebuild:
+ Fix 'ip' path (#474700 by Lorand Kelemen)
04 May 2013; Tom Wijsman <TomWij@gentoo.org> htbinit-0.8.5-r5.ebuild,
metadata.xml:
diff --git a/net-misc/htbinit/htbinit-0.8.5-r6.ebuild b/net-misc/htbinit/htbinit-0.8.5-r6.ebuild
new file mode 100644
index 000000000000..ce2237ffee4e
--- /dev/null
+++ b/net-misc/htbinit/htbinit-0.8.5-r6.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/htbinit/htbinit-0.8.5-r6.ebuild,v 1.1 2013/06/25 17:07:11 pacho Exp $
+
+EAPI=5
+inherit eutils linux-info
+
+DESCRIPTION="Sets up Hierachical Token Bucket based traffic control (QoS) with iproute2"
+HOMEPAGE="http://www.sourceforge.net/projects/htbinit"
+SRC_URI="mirror://sourceforge/htbinit/htb.init-v${PV}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="ipv6 esfq"
+
+DEPEND="sys-apps/iproute2"
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}
+
+pkg_setup() {
+ for i in NET_SCH_HTB NET_SCH_SFQ NET_CLS_FW NET_CLS_U32 NET_CLS_ROUTE ; do
+ CONFIG_CHECK="${CONFIG_CHECK} ~${i}"
+ done
+ use esfq && CONFIG_CHECK="${CONFIG_CHECK} ~NET_SCH_ESFQ"
+ linux-info_pkg_setup
+}
+
+src_unpack() {
+ cp "${DISTDIR}"/htb.init-v${PV} "${S}"/htb.init || die
+}
+
+src_prepare() {
+ sed -i 's|/etc/sysconfig/htb|/etc/htb|g' "${S}"/htb.init
+ epatch "${FILESDIR}"/htb.init-v0.8.5_tos.patch
+ use ipv6 && epatch "${FILESDIR}"/htb_0.8.5_ipv6.diff
+ use esfq && epatch "${FILESDIR}"/htb_0.8.5_esfq.diff
+ epatch "${FILESDIR}"/prio_rule.patch
+ epatch "${FILESDIR}"/timecheck_fix.patch
+ epatch "${FILESDIR}"/htb.init_find_fix.patch
+ sed -i -e 's:/sbin/ip:/bin/ip:g' "${S}"/htb.init # bug #474700
+}
+
+src_compile() {
+ :
+}
+
+src_install() {
+ dosbin htb.init
+ newinitd "${FILESDIR}"/htbinit.rc htbinit
+ keepdir /etc/htb
+}
+
+pkg_postinst() {
+ if [[ -z ${REPLACING_VERSIONS} ]] ; then
+ elog 'Run "rc-update add htbinit default" to run htb.init at startup.'
+ elog 'Please, read carefully the htb.init documentation.'
+ elog 'New directory to store configuration is /etc/htb.'
+ fi
+}