summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2013-05-05 11:34:19 +0000
committerAnthony G. Basile <blueness@gentoo.org>2013-05-05 11:34:19 +0000
commit5c6e83264732c6443b9789977f7e2e7e22c01971 (patch)
treee658f117fdb74bace188c179edd0df06c7a6f53d
parentvanilla-2.6.32.60 + genpatches-2.6.32-48 + grsecurity-2.9.1-2.6.32.60-2013042... (diff)
downloadgentoo-2-5c6e83264732c6443b9789977f7e2e7e22c01971.tar.gz
gentoo-2-5c6e83264732c6443b9789977f7e2e7e22c01971.tar.bz2
gentoo-2-5c6e83264732c6443b9789977f7e2e7e22c01971.zip
vanilla-3.2.44 + genpatches-3.2-16 + grsecurity-2.9.1-3.2.44-201304292055
(Portage version: 2.1.11.62/cvs/Linux x86_64, signed Manifest commit with key 0xF52D4BBA)
-rw-r--r--sys-kernel/hardened-sources/ChangeLog8
-rw-r--r--sys-kernel/hardened-sources/hardened-sources-3.2.44-r1.ebuild43
2 files changed, 50 insertions, 1 deletions
diff --git a/sys-kernel/hardened-sources/ChangeLog b/sys-kernel/hardened-sources/ChangeLog
index c6ef1739644b..a126044f1da0 100644
--- a/sys-kernel/hardened-sources/ChangeLog
+++ b/sys-kernel/hardened-sources/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-kernel/hardened-sources
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/hardened-sources/ChangeLog,v 1.820 2013/05/05 11:32:00 blueness Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/hardened-sources/ChangeLog,v 1.821 2013/05/05 11:34:19 blueness Exp $
+
+*hardened-sources-3.2.44-r1 (05 May 2013)
+
+ 05 May 2013; Anthony G. Basile <blueness@gentoo.org>
+ +hardened-sources-3.2.44-r1.ebuild:
+ vanilla-3.2.44 + genpatches-3.2-16 + grsecurity-2.9.1-3.2.44-201304292055
*hardened-sources-2.6.32-r164 (05 May 2013)
diff --git a/sys-kernel/hardened-sources/hardened-sources-3.2.44-r1.ebuild b/sys-kernel/hardened-sources/hardened-sources-3.2.44-r1.ebuild
new file mode 100644
index 000000000000..63464d407b97
--- /dev/null
+++ b/sys-kernel/hardened-sources/hardened-sources-3.2.44-r1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/hardened-sources/hardened-sources-3.2.44-r1.ebuild,v 1.1 2013/05/05 11:34:19 blueness Exp $
+
+EAPI="5"
+
+ETYPE="sources"
+K_WANT_GENPATCHES="base extras"
+K_GENPATCHES_VER="16"
+K_DEBLOB_AVAILABLE="1"
+
+inherit kernel-2
+detect_version
+
+HGPV="${KV_MAJOR}.${KV_MINOR}.${KV_PATCH}-2"
+HGPV_URI="http://dev.gentoo.org/~blueness/hardened-sources/hardened-patches/hardened-patches-${HGPV}.extras.tar.bz2"
+SRC_URI="${KERNEL_URI} ${HGPV_URI} ${GENPATCHES_URI} ${ARCH_URI}"
+
+UNIPATCH_LIST="${DISTDIR}/hardened-patches-${HGPV}.extras.tar.bz2"
+UNIPATCH_EXCLUDE="4200_fbcondecor-0.9.6.patch"
+
+DESCRIPTION="Hardened kernel sources (kernel series ${KV_MAJOR}.${KV_MINOR})"
+HOMEPAGE="http://www.gentoo.org/proj/en/hardened/"
+IUSE="deblob"
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+RDEPEND=">=sys-devel/gcc-4.5"
+
+pkg_postinst() {
+ kernel-2_pkg_postinst
+
+ local GRADM_COMPAT="sys-apps/gradm-2.9.1*"
+
+ ewarn
+ ewarn "Users of grsecurity's RBAC system must ensure they are using"
+ ewarn "${GRADM_COMPAT}, which is compatible with ${PF}."
+ ewarn "It is strongly recommended that the following command is issued"
+ ewarn "prior to booting a ${PF} kernel for the first time:"
+ ewarn
+ ewarn "emerge -na =${GRADM_COMPAT}"
+ ewarn
+}