summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDoug Goldstein <cardoe@gentoo.org>2008-01-04 23:26:38 +0000
committerDoug Goldstein <cardoe@gentoo.org>2008-01-04 23:26:38 +0000
commit4c23c73a6e25f558eb5c847a6efa5400c5163d38 (patch)
treeac8aaff5acb4f9419d2955fcc09f935f51a9d13c
parentFix patch for bug #203777 for an off by one. Straight-to-stable commit. (diff)
downloadgentoo-2-4c23c73a6e25f558eb5c847a6efa5400c5163d38.tar.gz
gentoo-2-4c23c73a6e25f558eb5c847a6efa5400c5163d38.tar.bz2
gentoo-2-4c23c73a6e25f558eb5c847a6efa5400c5163d38.zip
version bump
(Portage version: 2.1.4_rc14)
-rw-r--r--dev-python/dbus-python/ChangeLog9
-rw-r--r--dev-python/dbus-python/dbus-python-0.82.4.ebuild51
-rw-r--r--dev-python/dbus-python/files/digest-dbus-python-0.82.43
3 files changed, 61 insertions, 2 deletions
diff --git a/dev-python/dbus-python/ChangeLog b/dev-python/dbus-python/ChangeLog
index 8dfa885d492e..b8e4f41d42d8 100644
--- a/dev-python/dbus-python/ChangeLog
+++ b/dev-python/dbus-python/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/dbus-python
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/dbus-python/ChangeLog,v 1.30 2007/12/08 03:55:44 cardoe Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/dbus-python/ChangeLog,v 1.31 2008/01/04 23:26:37 cardoe Exp $
+
+*dbus-python-0.82.4 (04 Jan 2008)
+
+ 04 Jan 2008; Doug Klima <cardoe@gentoo.org> +dbus-python-0.82.4.ebuild:
+ version bump
*dbus-python-0.82.3 (08 Dec 2007)
diff --git a/dev-python/dbus-python/dbus-python-0.82.4.ebuild b/dev-python/dbus-python/dbus-python-0.82.4.ebuild
new file mode 100644
index 000000000000..5feca4a41904
--- /dev/null
+++ b/dev-python/dbus-python/dbus-python-0.82.4.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/dbus-python/dbus-python-0.82.4.ebuild,v 1.1 2008/01/04 23:26:37 cardoe Exp $
+
+inherit python multilib
+
+DESCRIPTION="Python bindings for the D-Bus messagebus."
+HOMEPAGE="http://www.freedesktop.org/wiki/Software/DBusBindings \
+http://dbus.freedesktop.org/doc/dbus-python/"
+SRC_URI="http://dbus.freedesktop.org/releases/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="|| ( GPL-2 AFL-2.1 )"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="test"
+
+RDEPEND=">=dev-lang/python-2.4.4-r5
+ >=dev-python/pyrex-0.9.3-r2
+ >=dev-libs/dbus-glib-0.71
+ >=sys-apps/dbus-0.91"
+
+DEPEND="${RDEPEND}
+ test? ( dev-python/pygobject )
+ dev-util/pkgconfig"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # don't run py-compile
+ sed -i \
+ -e '/if test -n "$$dlist"; then/,/else :; fi/d' \
+ dbus/Makefile.in Makefile.in || die "sed in Makefile.in failed"
+}
+
+src_compile() {
+ econf --docdir=/usr/share/doc/dbus-python-${PV} || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "make install failed"
+}
+
+pkg_postinst() {
+ python_mod_optimize ${ROOT}usr/$(get_libdir)/python*/site-packages/dbus
+}
+
+pkg_postrm() {
+ python_mod_cleanup
+}
diff --git a/dev-python/dbus-python/files/digest-dbus-python-0.82.4 b/dev-python/dbus-python/files/digest-dbus-python-0.82.4
new file mode 100644
index 000000000000..0b73a93627cc
--- /dev/null
+++ b/dev-python/dbus-python/files/digest-dbus-python-0.82.4
@@ -0,0 +1,3 @@
+MD5 f491e0372128a6d1178b210a8b1a842f dbus-python-0.82.4.tar.gz 473346
+RMD160 c934c38c7b6681aa419d005a4a73ab05ffdddac1 dbus-python-0.82.4.tar.gz 473346
+SHA256 e34e30a4c0ea405f9e830aa0026e9c0632f526f242e90526ff0a7da8dd7f5e2e dbus-python-0.82.4.tar.gz 473346