summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2014-01-18 07:33:11 +0000
committerMatthew Thode <prometheanfire@gentoo.org>2014-01-18 07:33:11 +0000
commit4bad5ce12b18f4063058d4740a2f8d8898072165 (patch)
tree195680cdce9070eda1873ed35422df4c12df34bf
parentMove old ebuilds to toolchain overlay and drop unused patches. (diff)
downloadgentoo-2-4bad5ce12b18f4063058d4740a2f8d8898072165.tar.gz
gentoo-2-4bad5ce12b18f4063058d4740a2f8d8898072165.tar.bz2
gentoo-2-4bad5ce12b18f4063058d4740a2f8d8898072165.zip
removing the old and janky (vulnerable)
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key 0x2471eb3e40ac5ac3)
-rw-r--r--app-admin/puppet/ChangeLog6
-rw-r--r--app-admin/puppet/puppet-2.7.23.ebuild181
-rw-r--r--app-admin/puppet/puppet-3.2.4.ebuild160
3 files changed, 5 insertions, 342 deletions
diff --git a/app-admin/puppet/ChangeLog b/app-admin/puppet/ChangeLog
index 94aec9665bdb..5af5c6a896f0 100644
--- a/app-admin/puppet/ChangeLog
+++ b/app-admin/puppet/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-admin/puppet
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/puppet/ChangeLog,v 1.191 2014/01/15 19:07:03 prometheanfire Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/puppet/ChangeLog,v 1.192 2014/01/18 07:33:11 prometheanfire Exp $
+
+ 18 Jan 2014; Matthew Thode <prometheanfire@gentoo.org> -puppet-2.7.23.ebuild,
+ -puppet-3.2.4.ebuild:
+ removing the old and janky (vulnerable)
*puppet-3.4.2-r1 (15 Jan 2014)
diff --git a/app-admin/puppet/puppet-2.7.23.ebuild b/app-admin/puppet/puppet-2.7.23.ebuild
deleted file mode 100644
index 67f6f8dc5b27..000000000000
--- a/app-admin/puppet/puppet-2.7.23.ebuild
+++ /dev/null
@@ -1,181 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/puppet/puppet-2.7.23.ebuild,v 1.7 2014/01/01 17:53:29 patrick Exp $
-
-EAPI="4"
-USE_RUBY="ruby19"
-
-RUBY_FAKEGEM_TASK_DOC=""
-RUBY_FAKEGEM_TASK_TEST="test"
-RUBY_FAKEGEM_EXTRADOC="CHANGELOG* README*"
-
-inherit elisp-common xemacs-elisp-common eutils ruby-fakegem user
-
-DESCRIPTION="A system automation and configuration management software"
-HOMEPAGE="http://puppetlabs.com/"
-SRC_URI="http://www.puppetlabs.com/downloads/puppet/${P}.tar.gz"
-
-LICENSE="Apache-2.0 GPL-2"
-SLOT="0"
-IUSE="augeas diff doc emacs ldap minimal rrdtool selinux shadow sqlite3 vim-syntax xemacs"
-KEYWORDS="amd64 hppa ppc sparc x86"
-
-ruby_add_rdepend "
- >=dev-ruby/facter-1.5.6
- augeas? ( dev-ruby/ruby-augeas )
- diff? ( dev-ruby/diff-lcs )
- doc? ( dev-ruby/rdoc )
- ldap? ( dev-ruby/ruby-ldap )
- shadow? ( dev-ruby/ruby-shadow )
- sqlite3? ( dev-ruby/sqlite3 )
- virtual/ruby-ssl"
-# couchdb? ( dev-ruby/couchrest )
-# mongrel? ( www-servers/mongrel )
-# rack? ( >=dev-ruby/rack-1 )
-# rails? (
-# dev-ruby/rails
-# >=dev-ruby/activerecord-2.1
-# )
-# stomp? ( dev-ruby/stomp )
-
-DEPEND="${DEPEND}
- ruby_targets_ruby19? ( dev-lang/ruby:1.9[yaml] )
- emacs? ( virtual/emacs )
- xemacs? ( app-editors/xemacs )
- selinux? ( sec-policy/selinux-puppet )"
-RDEPEND="${RDEPEND}
- ruby_targets_ruby19? ( dev-lang/ruby:1.9[yaml] )
- emacs? ( virtual/emacs )
- xemacs? ( app-editors/xemacs )
- rrdtool? ( >=net-analyzer/rrdtool-1.2.23[ruby] )
- selinux? (
- sys-libs/libselinux[ruby]
- sec-policy/selinux-puppet
- )
- >=app-portage/eix-0.18.0"
-
-SITEFILE="50${PN}-mode-gentoo.el"
-
-RUBY_PATCHES=( )
-
-pkg_setup() {
- enewgroup puppet
- enewuser puppet -1 -1 /var/lib/puppet puppet
-}
-
-all_ruby_compile() {
- all_fakegem_compile
-
- if use emacs ; then
- elisp-compile ext/emacs/puppet-mode.el
- fi
-
- if use xemacs ; then
- # Create a separate version for xemacs to be able to install
- # emacs and xemacs in parallel.
- mkdir ext/xemacs
- cp ext/emacs/* ext/xemacs/
- xemacs-elisp-compile ext/xemacs/puppet-mode.el
- fi
-}
-
-each_fakegem_install() {
- ${RUBY} install.rb --destdir="${D}" install
-}
-
-all_ruby_install() {
- all_fakegem_install
-
- newinitd "${FILESDIR}"/puppet.init-r1 puppet
- doconfd conf/gentoo/conf.d/puppet
-
- # Initial configuration files
- insinto /etc/puppet
- # Bug #338439
- #doins conf/gentoo/puppet/*
- doins conf/redhat/puppet.conf
-
- # Location of log and data files
- keepdir /var/{run,log}/puppet
- fowners -R puppet:puppet /var/{run,log}/puppet
-
- if use minimal ; then
- rm "${ED}/usr/bin/puppetmasterd"
- rm "${ED}/etc/puppet/auth.conf"
- else
- newinitd "${FILESDIR}"/puppetmaster.init puppetmaster
- newconfd "${FILESDIR}"/puppetmaster.confd puppetmaster
-
- insinto /etc/puppet
- doins conf/redhat/fileserver.conf
-
- keepdir /etc/puppet/manifests
- keepdir /etc/puppet/modules
-
- keepdir /var/lib/puppet/ssl
- keepdir /var/lib/puppet/facts
- keepdir /var/lib/puppet/files
- fowners -R puppet:puppet /var/{run,log,lib}/puppet
- fi
-
- if use emacs ; then
- elisp-install ${PN} ext/emacs/puppet-mode.el*
- elisp-site-file-install "${FILESDIR}/${SITEFILE}"
- fi
-
- if use xemacs ; then
- xemacs-elisp-install ${PN} ext/xemacs/puppet-mode.el*
- xemacs-elisp-site-file-install "${FILESDIR}/${SITEFILE}"
- fi
-
- if use ldap ; then
- insinto /etc/openldap/schema; doins ext/ldap/puppet.schema
- fi
-
- if use vim-syntax ; then
- insinto /usr/share/vim/vimfiles/ftdetect; doins ext/vim/ftdetect/puppet.vim
- insinto /usr/share/vim/vimfiles/syntax; doins ext/vim/syntax/puppet.vim
- fi
-
- # ext and examples files
- for f in $(find ext examples -type f) ; do
- docinto "$(dirname ${f})"; dodoc "${f}"
- done
- docinto conf; dodoc conf/namespaceauth.conf
-}
-
-pkg_postinst() {
- elog
- elog "Please, *don't* include the --ask option in EMERGE_EXTRA_OPTS as this could"
- elog "cause puppet to hang while installing packages."
- elog
- elog "Puppet uses eix to get information about currently installed packages,"
- elog "so please keep the eix metadata cache updated so puppet is able to properly"
- elog "handle package installations."
- elog
- elog "Currently puppet only supports adding and removing services to the default"
- elog "runlevel, if you want to add/remove a service from another runlevel you may"
- elog "do so using symlinking."
- elog
-
- if [ \
- -f "${EPREFIX}/etc/puppet/puppetd.conf" -o \
- -f "${EPREFIX}/etc/puppet/puppetmaster.conf" -o \
- -f "${EPREFIX}/etc/puppet/puppetca.conf" \
- ] ; then
- elog
- elog "Please remove deprecated config files."
- elog " /etc/puppet/puppetca.conf"
- elog " /etc/puppet/puppetd.conf"
- elog " /etc/puppet/puppetmasterd.conf"
- elog
- fi
-
- use emacs && elisp-site-regen
- use xemacs && xemacs-elisp-site-regen
-}
-
-pkg_postrm() {
- use emacs && elisp-site-regen
- use xemacs && xemacs-elisp-site-regen
-}
diff --git a/app-admin/puppet/puppet-3.2.4.ebuild b/app-admin/puppet/puppet-3.2.4.ebuild
deleted file mode 100644
index e27826deaaae..000000000000
--- a/app-admin/puppet/puppet-3.2.4.ebuild
+++ /dev/null
@@ -1,160 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/puppet/puppet-3.2.4.ebuild,v 1.7 2014/01/01 17:53:29 patrick Exp $
-
-EAPI="4"
-
-USE_RUBY="ruby19"
-
-inherit elisp-common xemacs-elisp-common eutils user ruby-ng versionator
-
-DESCRIPTION="A system automation and configuration management software"
-HOMEPAGE="http://puppetlabs.com/"
-SRC_URI="http://www.puppetlabs.com/downloads/puppet/${P}.tar.gz"
-
-LICENSE="Apache-2.0 GPL-2"
-SLOT="0"
-KEYWORDS="amd64 hppa ~ppc sparc x86"
-IUSE="augeas diff doc emacs ldap minimal rrdtool selinux shadow sqlite3 vim-syntax xemacs"
-
-ruby_add_rdepend "
- dev-ruby/hiera
- >=dev-ruby/facter-1.6.2
- augeas? ( dev-ruby/ruby-augeas )
- diff? ( dev-ruby/diff-lcs )
- doc? ( dev-ruby/rdoc )
- ldap? ( dev-ruby/ruby-ldap )
- shadow? ( dev-ruby/ruby-shadow )
- sqlite3? ( dev-ruby/sqlite3 )
- virtual/ruby-ssl"
-
-DEPEND="${DEPEND}
- ruby_targets_ruby19? ( dev-lang/ruby:1.9[yaml] )
- emacs? ( virtual/emacs )
- xemacs? ( app-editors/xemacs )"
-RDEPEND="${RDEPEND}
- ruby_targets_ruby19? ( dev-lang/ruby:1.9[yaml] )
- rrdtool? ( >=net-analyzer/rrdtool-1.2.23[ruby] )
- selinux? (
- sys-libs/libselinux[ruby]
- sec-policy/selinux-puppet
- )
- vim-syntax? ( >=app-vim/puppet-syntax-3.0.1 )
- >=app-portage/eix-0.18.0"
-
-SITEFILE="50${PN}-mode-gentoo.el"
-
-RUBY_PATCHES=( "${FILESDIR}/puppet-openrc-status-fix.patch" )
-
-pkg_setup() {
- enewgroup puppet
- enewuser puppet -1 -1 /var/lib/puppet puppet
-}
-
-all_ruby_compile() {
- if use emacs ; then
- elisp-compile ext/emacs/puppet-mode.el
- fi
-
- if use xemacs ; then
- # Create a separate version for xemacs to be able to install
- # emacs and xemacs in parallel.
- mkdir ext/xemacs
- cp ext/emacs/* ext/xemacs/
- xemacs-elisp-compile ext/xemacs/puppet-mode.el
- fi
-}
-
-each_ruby_install() {
- ${RUBY} install.rb --destdir="${D}" install || die
-}
-
-all_ruby_install() {
- newinitd "${FILESDIR}"/puppet.init-r1 puppet
-
- # Initial configuration files
- insinto /etc/puppet
-
- # Location of log and data files
- keepdir /var/log/puppet
- fowners -R puppet:puppet /var/log/puppet
-
- if use minimal ; then
- rm "${ED}/etc/puppet/auth.conf"
- else
- newinitd "${FILESDIR}"/puppetmaster.init-r1 puppetmaster
- newconfd "${FILESDIR}"/puppetmaster.confd puppetmaster
-
- insinto /etc/puppet
-
- keepdir /etc/puppet/manifests
- keepdir /etc/puppet/modules
-
- keepdir /var/lib/puppet/ssl
- keepdir /var/lib/puppet/facts
- keepdir /var/lib/puppet/files
- fowners -R puppet:puppet /var/lib/puppet
- fi
-
- if use emacs ; then
- elisp-install ${PN} ext/emacs/puppet-mode.el*
- elisp-site-file-install "${FILESDIR}/${SITEFILE}"
- fi
-
- if use xemacs ; then
- xemacs-elisp-install ${PN} ext/xemacs/puppet-mode.el*
- xemacs-elisp-site-file-install "${FILESDIR}/${SITEFILE}"
- fi
-
- if use ldap ; then
- insinto /etc/openldap/schema; doins ext/ldap/puppet.schema
- fi
-
- # ext and examples files
- for f in $(find ext examples -type f) ; do
- docinto "$(dirname ${f})"; dodoc "${f}"
- done
-}
-
-pkg_postinst() {
- elog
- elog "Please, *don't* include the --ask option in EMERGE_EXTRA_OPTS as this could"
- elog "cause puppet to hang while installing packages."
- elog
- elog "Puppet uses eix to get information about currently installed packages,"
- elog "so please keep the eix metadata cache updated so puppet is able to properly"
- elog "handle package installations."
- elog
- elog "Currently puppet only supports adding and removing services to the default"
- elog "runlevel, if you want to add/remove a service from another runlevel you may"
- elog "do so using symlinking."
- elog
-
- if [ \
- -f "${EPREFIX}/etc/puppet/puppetd.conf" -o \
- -f "${EPREFIX}/etc/puppet/puppetmaster.conf" -o \
- -f "${EPREFIX}/etc/puppet/puppetca.conf" \
- ] ; then
- elog
- elog "Please remove deprecated config files."
- elog " /etc/puppet/puppetca.conf"
- elog " /etc/puppet/puppetd.conf"
- elog " /etc/puppet/puppetmasterd.conf"
- elog
- fi
-
- if [ "$(get_major_version $REPLACING_VERSIONS)" = "2" ]; then
- elog
- elog "If you're upgrading from 2.x then we strongly suggest you to read:"
- elog "http://docs.puppetlabs.com/guides/upgrading.html"
- elog
- fi
-
- use emacs && elisp-site-regen
- use xemacs && xemacs-elisp-site-regen
-}
-
-pkg_postrm() {
- use emacs && elisp-site-regen
- use xemacs && xemacs-elisp-site-regen
-}